Download it now!
Bug 45315 - [UI] Some relation elements (precedes and following) shown with different font
Summary: [UI] Some relation elements (precedes and following) shown with different font
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86-64 (AMD64) Windows (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: difficultyBeginner, easyHack, topicUI
Depends on:
Blocks:
 
Reported: 2012-01-27 08:21 UTC by Florian Reisinger
Modified: 2015-12-16 05:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The two rows at the bottom are not that sharp (21.60 KB, image/jpeg)
2012-01-27 08:21 UTC, Florian Reisinger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Reisinger 2012-01-27 08:21:56 UTC
Created attachment 56225 [details]
The two rows at the bottom are not that sharp

Please have a look at he attached screenshot...
It is the Elements window in Math.
The 2 rows at the bottom do not seem very sharp...
Windows 7 x64 LibO 3,5rc2
Comment 1 Rainer Bielefeld Retired 2012-01-27 09:03:52 UTC
[Reproducible] with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [(Build ID:  d38713d-5d03837-ca7e6f5-c4bb9bd-ce71330)]" (Voreppe_Win32_Tinderbox 2011-11-15)

Some relation elements (precedes, suceedes, ...) are shown with different font, but I can't tell whether that's intended of not (shown the same way in Help), I will do further research, soon.
Comment 2 Andras Timar 2012-03-06 10:07:30 UTC
These are bitmaps not text. These operators are new, so new icons were made. The creator of the icons could not (or did not try) to reproduce the font settings of the original icons. Possible solution: redraw these icons in a uniform manner.

See files in icon-themes\galaxy\starmath\res\.
Comment 3 Stefan Knorr (astron) 2012-03-06 10:09:01 UTC
Olivier Hallot added these Game theory items for 3.5, long after the creation of the original icons. The font is the same, but the hinting is very different.

From my perspective, it would be highly welcome if someone could replace all of these icons with icons that use a more professional-looking font than Comic Sans (my ideas in that area are FreeSans/Helvetica, Vegur/Myriad Pro or Computer Modern [Bold]).
Comment 4 Olivier Hallot 2012-03-06 10:22:10 UTC
Hi
Yes.. I am the one to blame! :-)

Please find in bug 42892 the SVG sources for the new icons. I worked with Inkscape, the letters are from MS Comic Sans,  and the math symbols from STIX fonts (http://www.stixfonts.org/ )

If necessary, this work can be flagged as an EasyHack.
Comment 5 Stefan Knorr (astron) 2012-03-06 10:27:27 UTC
Oh sorry, excuse my expressing it that way. I do not want to put the blame on you. I believe you honestly did the best you could short of ripping everything out and redoing 200+ icons.
Comment 6 Olivier Hallot 2012-03-06 11:00:28 UTC
(In reply to comment #5)
> Oh sorry, excuse my expressing it that way. I do not want to put the blame on
> you. I believe you honestly did the best you could short of ripping everything
> out and redoing 200+ icons.

Hi Astron 
No problem at all... I was ironic on my "fault", and emoticons are not rendered in BZ (giggles).

I agree that a prettier icon work are due for the whole Elements window (actually, the whole Math module should be rethinked).
Comment 7 Ralph Aichinger 2012-03-07 03:26:44 UTC
I think letters in a formula should normally be in italics, and a serif 
font. I thin LaTeX does it that way by default, and about every professional
looking maths book does it that way. Even my electronic calculator from Texas Instruments, does this, most clearly seen in "x" and "y" ;) 

I think Times Italic, Liberation Italic, Computer Modern Italic or about any serif text font with a true italic (i.e. not slanted, but genuine italic letter forms) would be fine.
Comment 8 Samuel Mehrbrodt (CIB) 2013-09-29 20:38:40 UTC
Do we need to keep the images there or could we just use normal text on the buttons?
Comment 9 Thomas Arnhold 2013-10-03 11:23:38 UTC
It's not worth to fix this one, because with some fixes on the Elements Dock the old Elements menu will be removed (see #68871).

Marking this as WONTFIX.
Comment 10 Robinson Tryon (qubit) 2015-12-16 05:24:53 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyBeginner TopicUI)
[NinjaEdit]