Bug 68871 - Remove the old Elements panel (View → Elements) from Math
Summary: Remove the old Elements panel (View → Elements) from Math
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: All All
: high major
Assignee: Julien Nabet
QA Contact:
URL:
Whiteboard: target:5.0.0
Keywords:
Depends on: 65584 65587 92405 65583 65586 65588 68877 69112 71580 71616
Blocks: Formula-Editor HelpGaps Elements-Pane
  Show dependency treegraph
 
Reported: 2013-09-03 06:22 UTC by Florian Reisinger
Modified: 2016-10-29 19:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Elements window (90.55 KB, image/png)
2013-11-13 14:18 UTC, Thomas Arnhold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Reisinger 2013-09-03 06:22:48 UTC
I firmly believe, that we do not need both, the "Elements Dock" and "Elements"
We should fix the missing features/ bugs soon and disable "Elements" entirely. I do hope we won't ship a release with both enabled :)
Comment 1 Thomas Arnhold 2013-11-12 17:26:59 UTC
Unhappily this is already shipped within the 4.1 releases. Those bugs need some attention especially for 4.2. For 4.1 it's maybe better to disable it entirely.
Comment 2 Jan Holesovsky 2013-11-13 09:39:01 UTC
Can you please provide a screenshot what is this bug about?  Thank you!
Comment 3 Adolfo Jayme 2013-11-13 12:25:06 UTC
@Kendy: this bug is about disabling by default (and eventually removing) the Elements floating window that’s been always present in LibreOffice Math to insert characters and formula elements, since we also have a new Elements Dock. As this new dock (or Sidebar) has issues, they are dependencies of this bug to ensre there are no functionality regressions when we disable the old interface element.
Comment 4 Thomas Arnhold 2013-11-13 14:18:53 UTC
Created attachment 89145 [details]
Elements window
Comment 5 Adolfo Jayme 2014-09-23 00:54:10 UTC
What about we completely remove the old Elements panel from the codebase? We’ve now shipped three major releases with both the old and new panels, which is not only redundant, but confusing as hell.

Now the old panel has even been converted to .ui by Caolán, which is a waste of his time, this should have been removed long ago. All (but two) major bugs in the new panel are fixed.
Comment 6 Julien Nabet 2015-05-02 17:06:24 UTC
I submitted a patch here:
https://gerrit.libreoffice.org/15599
Comment 7 Olivier Hallot 2015-05-04 09:46:13 UTC
Please consider removing the help contents related to this issue.

Marked meta bug 80430 (Help updates) depends on this one.
Comment 8 Adolfo Jayme 2015-05-04 12:51:46 UTC
Sure – thanks for the heads-up, Olivier!

Note to self: also, need to rename the “Elements Dock” to just “Elements”…
Comment 9 Commit Notification 2015-05-12 08:44:39 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3dfe2fc394ca1e168e800ffcc3ac0f69b4eeb173

tdf#68871: Remove the old Elements panel from Math

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-05-13 09:45:57 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=edf3c40421c193a0603d220d50320c9953cfb9ed

tdf#68871 Nuke old Elements box from menu, rename new pane

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Mike §chinagl 2015-05-21 16:23:29 UTC
This bug fix is mentioned in the release notes of the coming LibreOffice 5.0 (see release notes https://wiki.documentfoundation.org/ReleaseNotes/5.0). Therefore it would be wonderful if this feature really worked well, otherwise it should not be mentioned in the release notes. In the notes it reads:

Since the introduction of a new “Elements” docked pane in Math (in version 4.1), it was intended that it would replace the old, OOo-inherited “toolbox”, or floating pane, which was difficult to use and had visual problems in certain UI configurations (such as dark themes). This old element has finally been removed, thus streamlining the UI by removing redundancy. tdf#68871 Thanks to: Julien Nabet and Adolfo Jayme Barrientos.
Comment 12 Julien Nabet 2015-05-21 18:19:17 UTC
Mike: same comment as https://bugs.documentfoundation.org/show_bug.cgi?id=87016#c6
Comment 13 Julien Nabet 2015-05-21 19:08:25 UTC
Mike: reading your comment on the other bugtracker, did you mean here you can still reproduce the problem? If yes, which precise version of 5.0 do you use? (a recent daily build?)
Comment 14 Adolfo Jayme 2015-05-21 20:01:30 UTC
> Therefore it would be wonderful if this feature really worked well

It would be wonderful if you could state *explicitly* what is the problem that you’re experimenting, and file that in a *new* bug report.