Download it now!
Bug 65588 - Elements Dock: Scrollbar moves into input window
Summary: Elements Dock: Scrollbar moves into input window
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta2
Hardware: All All
: medium enhancement
Assignee: José Guilherme Vanz
URL:
Whiteboard: target:4.2.0
Keywords:
Depends on:
Blocks: 68871
  Show dependency treegraph
 
Reported: 2013-06-09 21:30 UTC by Regina Henschel
Modified: 2013-11-11 08:13 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Wrong position of vertical scroll bar of command window (48.83 KB, image/png)
2013-06-09 21:30 UTC, Regina Henschel
Details
Wrong located scrollbar (182.54 KB, image/png)
2013-11-04 11:40 UTC, Thomas Arnhold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2013-06-09 21:30:28 UTC
Created attachment 80589 [details]
Wrong position of vertical scroll bar of command window

Open Elements Dock window and dock it to the right edge.
Open the Example category.
Click the sum from to example (see screenshot).
Notice, that the vertical scrollbar in the command window is at a wrong position.
Comment 1 Jorendc 2013-06-09 22:01:03 UTC
I can confirm this using Linux Mint 15 x64 with LibreOffice Version: 4.2.0.0.alpha0+ Build ID: 55ff402fa24bcf9478e7fde94f2ab57c2223b7f

Little workaround for this visual glitch: make the box re-render (alter width of the element dock for example).

Kind regards,
Joren
Comment 2 Leif Lodahl 2013-06-10 17:49:09 UTC
Confirm on Ubuntu 13.04.
But the Elements Dock window doesn't appear at all.

Build ID: 28db167bee89f5b749f3853cdfd8cc1d21a058d
Comment 3 Thomas Arnhold 2013-09-03 13:08:12 UTC
The problem seems to be fixed on master. The position of the scrollbars gets recalculated, but with some delay, so that it is displaced for a short moment. It would be an improvement to recalculate that faster.
Comment 4 Marcos Souza 2013-10-30 14:59:11 UTC
I can't reproduce this in master(30/11/2013).

This issue still happens?
Comment 5 José Guilherme Vanz 2013-11-02 22:06:36 UTC
I cannot reproduce this bug in master.
Comment 6 Thomas Arnhold 2013-11-04 11:34:14 UTC
Yes, it's still reproducible. Windows and Linux an latest master:

Choose one of the largest example formulas. Click on it multiple times, so that 10 or more are inserted (so that the input window is filled!). At this moment with every new inserted formula the scrollbar moves from the window border into the input window, but get's relocated ~1 second later.
Comment 7 Thomas Arnhold 2013-11-04 11:40:17 UTC
Created attachment 88600 [details]
Wrong located scrollbar

Here's a screenshot, while I'm permanently inserting one of the example formulas.

I changed the bug title and settings, because it is more an improvement now.
Comment 8 José Guilherme Vanz 2013-11-04 17:20:39 UTC
(In reply to comment #6)
> Yes, it's still reproducible. Windows and Linux an latest master:
> 
> Choose one of the largest example formulas. Click on it multiple times, so
> that 10 or more are inserted (so that the input window is filled!). At this
> moment with every new inserted formula the scrollbar moves from the window
> border into the input window, but get's relocated ~1 second later.

Yes, I could reproduce now. Thank you
Comment 9 José Guilherme Vanz 2013-11-06 16:46:55 UTC
Hi, Guys!
Comment 10 José Guilherme Vanz 2013-11-06 16:55:19 UTC
(In reply to comment #9)
> Hi, Guys!

Again... sorry ( hunf ) :@
I'll submit a pacth soon.
Comment 11 José Guilherme Vanz 2013-11-07 04:56:56 UTC
I set a patch to gerrit trying solve this problem. Please, if you can take a look on it.

Patch: https://gerrit.libreoffice.org/#/c/6602/
Comment 12 Marcos Souza 2013-11-07 11:50:28 UTC
I pushed that patch to master.

It worked for me.

Can someone test this?
Comment 13 Commit Notification 2013-11-07 11:55:20 UTC
Jose Guilherme Vanz committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=67311738157bced7b49e94b24845091995edb142

fdo#65588 -  Elements Dock: Scrollbar moves into input window



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.