Bug Hunting Session
Bug 65587 - Elements pane: Items not reachable without mouse
Summary: Elements pane: Items not reachable without mouse
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta2
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0
Keywords: accessibility
: 104272 (view as bug list)
Depends on:
Blocks: a11y Elements-Pane 68871
  Show dependency treegraph
 
Reported: 2013-06-09 21:21 UTC by Regina Henschel
Modified: 2019-05-29 18:49 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2013-06-09 21:21:11 UTC
Open the Elements Dock window and undock it.
Put your mouse beside.
Use key F6 to select the Elements Dock window. Focus is in the category drop-down-list. You can use the list as expected with alt-arrow and enter to select a category. But there is no way to reach the items in that category. In the old elements window you switch between category and item section with the Tab key.
Comment 1 Jorendc 2013-06-09 22:04:39 UTC
I can confirm this using Linux Mint 15 x64 with LibreOffice Version: 4.2.0.0.alpha0+ Build ID: 55ff402fa24bcf9478e7fde94f2ab57c2223b7f

Kind regards,
Joren
Comment 2 Marcos Souza 2013-09-07 19:01:03 UTC
Yeah, I can reproduce this.

Maybe wee need to check what we can do for the Elements Dock to implement this feature....
Comment 3 QA Administrators 2015-04-01 14:42:51 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-04-24 17:50:06 UTC
Reproduced.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: fi_FI
Comment 5 QA Administrators 2016-09-20 10:12:01 UTC Comment hidden (obsolete)
Comment 6 Regina Henschel 2016-09-20 13:36:56 UTC
The problem still exists in Version: 5.3.0.0.alpha0+
Build ID: ba269f7294e2416659011cbb498a2c6b5f9d5199
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-09-12_02:36:16
Locale: de-DE (de_DE); Calc: group
Comment 7 V Stuart Foote 2016-11-30 17:29:11 UTC
*** Bug 104272 has been marked as a duplicate of this bug. ***
Comment 8 V Stuart Foote 2016-11-30 17:34:43 UTC
Lack of keyboard navigation and selection from the elements pane is also an a11y issue affecting the Math formula editor.
Comment 9 Alex ARNAUD 2017-07-17 16:37:00 UTC
Dear all,

With LibreOfficeDev 6.0 (Debian 8) from 2017-07-14 I can go through the Elements pane with the F6 cycle but I can't select operator.

I think we could close this issue and open another one for the operator pane.

Best regards.
Comment 10 Regina Henschel 2017-07-17 17:05:06 UTC
(In reply to Alex ARNAUD from comment #9)
> With LibreOfficeDev 6.0 (Debian 8) from 2017-07-14 I can go through the
> Elements pane with the F6 cycle but I can't select operator.
> 
> I think we could close this issue and open another one for the operator pane.
> 

No, that is exact the reported error. You cannot go into the area, where you can select an element. You can only reach the drop-down list.

So problem still exists in
Version: 6.0.0.0.alpha0+
Build ID: 9f3814af7264ce90685a82cbf4eb015a38f22bf7
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-28_00:47:42
Locale: de-DE (de_DE); Calc: group
Comment 11 Alex ARNAUD 2017-07-17 17:13:36 UTC
(In reply to Regina Henschel from comment #10)
> (In reply to Alex ARNAUD from comment #9)
> > With LibreOfficeDev 6.0 (Debian 8) from 2017-07-14 I can go through the
> > Elements pane with the F6 cycle but I can't select operator.
> > 
> > I think we could close this issue and open another one for the operator pane.
> > 
> 
> No, that is exact the reported error. You cannot go into the area, where you
> can select an element. You can only reach the drop-down list.

You're right, my apologize, I've not understand that.

Thanks for the explanation and I'm really sorry for the inconvenience. 

Best regards.
Comment 12 Yousuf Philips (jay) (retired) 2017-07-17 19:49:18 UTC
The old Elements floating window removed in 5.0 had buttons for each of the element items, while the Elements dock introduced in 4.1 has element items in a grid control that doesnt receive cursor focus.

http://opengrok.libreoffice.org/xref/core/starmath/source/ElementsDockingWindow.cxx
Comment 13 QA Administrators 2018-07-18 02:39:09 UTC Comment hidden (obsolete)
Comment 14 Regina Henschel 2018-07-18 09:25:20 UTC
The problem still exists in Version: 6.2.0.0.alpha0+ (x64)
Build ID: 1a8435a23e84f3ceeee580eb9d4404a738d98888
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
Locale: de-DE (en_US); Calc: CL
Comment 15 Commit Notification 2019-05-23 05:01:57 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2fdcd86ac08c0ed033398bdb85ed04b64f50c633%5E%21

tdf#65587 SM add key navigation to ElementControl

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2019-05-23 05:03:28 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/73f8222109c3091d5119ed47eac5cad4a55b2212%5E%21

tdf#65587 SM handle page keys in the ElementControl

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Jan-Marek Glogowski 2019-05-23 09:13:54 UTC
FYI: this just implements the KeyInput handling. Strictly taken, the bug is fixed.

What is still missing is the Accessibility integration, which is a mess in LO. Originally these elements were handled by a Toolbox, represented as various buttons. I generally plan to go the same way. But I'm not yet sure if I should abstract the Toolbox, so it's accessibility implementation will fit the new control, or write a completely new one accessibility integration. Then there is the additional scrollbar.

The control itself is a mix between a list box (scrollable list of items) and a toolbox (list of buttons). It doesn't really matter that the visual representation is more of the grid, because the navigation is currently handled as a list of items, as this is the internal representation.

An other question: should the accessibility always list all buttons, independent of the ScrollBar (which means it lists buttons currently not visible)? My guess is the various list themselves will never be long, but the ScrollBar is definitely needed.

And while at it: should the navigation work as a cycle, AKA the next item after the last item will be the first item again?

The current implementation generally works, but I consider it a working PoC and would like to get some comments.

BTW: navigation implementation as a real grid is currently out of scope! If you want that, please file an additional bug report and discuss it there.
Comment 18 Jan-Marek Glogowski 2019-05-23 09:37:13 UTC
If you wonder what a Toolbox actually is, see the button / control list at the top of the Writer navigator window / panel (F5).
Comment 19 Heiko Tietze 2019-05-23 10:48:45 UTC
Tab jumps into the elements where both right and down go forward (right only, next line after the last item) resp. right/up for back. Space and Enter inserts the formula and focus on the editor.

It would be good to go down by cursor without moving right (patch note says it's tricky) and maybe also to jump to the next section per tab (as known from the Sidebar). Alex, what do you think? Resole as fixed or is there something absolutely required (eg. haven't tested with a screen reader).
Comment 20 Heiko Tietze 2019-05-23 11:01:39 UTC
(In reply to Heiko Tietze from comment #19)
> ... and maybe also to jump to the next section per tab

Tab jumps back to the dropdown, could be ctrl+tab (cf. https://wiki.documentfoundation.org/Design/SideBar).
Comment 21 Jan-Marek Glogowski 2019-05-23 16:28:54 UTC
(In reply to Heiko Tietze from comment #19)
> Tab jumps into the elements where both right and down go forward (right
> only, next line after the last item) resp. right/up for back. Space and
> Enter inserts the formula and focus on the editor.

The Elements list is considered a single control, so the Window just has two controls, which means tab will switch between the combo box and the element list.

> It would be good to go down by cursor without moving right (patch note says
> it's tricky) and maybe also to jump to the next section per tab (as known
> from the Sidebar).

That would require handling it as a grid, so yup - that would need quite some work to do. 

> Alex, what do you think? Resole as fixed or is there
> something absolutely required (eg. haven't tested with a screen reader).

As I've already written, accessibility isn't yet implemented. That'll be an additional patch at some point.

(In reply to Heiko Tietze from comment #20)
> (In reply to Heiko Tietze from comment #19)
> > ... and maybe also to jump to the next section per tab
> 
> Tab jumps back to the dropdown, could be ctrl+tab (cf.
> https://wiki.documentfoundation.org/Design/SideBar).

Sorry, I'm not sure I follow you. Is your proposal to use Tab and Shift+Tab to change the dropdown to the next / previous item, and keep the focus in the elements list and instead use Ctrl+Tab to change the focus from the Elements List back to the drop down?

So Tab becomes a short-cut to traverse the drop down from the Element list.
How will the user now know, that he has to use Ctrl+Tab to leave the Elements list? Do you think it's not needed?
Comment 22 Commit Notification 2019-05-29 18:16:16 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/a7e52282e36987f4ca6bed968e87ada6849b10e8%5E%21

tdf#65587 SM implement ElementControl accessibility

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.