Bug Hunting Session
Bug 45418 - FILEOPEN: IMPORT XSLT Filter do not work on LINK or Insert
Summary: FILEOPEN: IMPORT XSLT Filter do not work on LINK or Insert
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: All Windows (All)
: medium normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:4.4.0 target:4.3.1
Keywords: regression
: 45424 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-30 15:58 UTC by famo
Modified: 2015-12-24 19:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
MSO Word 2003 XML Testcase (32.77 KB, text/xml)
2012-01-30 15:59 UTC, famo
Details
MSO Excel 2003 XML Testcase (3.06 KB, text/xml)
2012-01-30 16:00 UTC, famo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description famo 2012-01-30 15:58:38 UTC
XSLT filter do not work on:
Calc:
Insert - Link to External Data...
Insert - Sheet from File...
Writer:
Insert - File...

Although LO is able to open the files via File - Open... 

Reproducible: Always

How to reproduce on Writer:
1. Open Writer
2. Choose Insert - File...
3. Select MSO-Word-2003_testcase.xml (see attachment) AND under File Type choose "Microsoft Word 2003 XML (*.xml;*.doc)"
4. Hit OK
5. Notice error: "Read-Error. Error reading file."
-> Expected file should open fine.

How to reproduce on Calc1:
1. Open Calc
2. Choose Insert - Link to External Data...
3. Hit "...", select MSO-Excel-2003_testcase.xml (see attachment) AND under File Type choose "Microsoft Excel 2003 XML (*.xml;*.xls)"
4. Hit OK
5. Notice: No tables are listed under "available tables/ranges", "OK" button is greyed out
-> Expected testcase table should be listed and OK should work.

How to reproduce on Calc2:
1. Open Calc
2. Choose Insert - Sheet from File...
3. Hit "...", select MSO-Excel-2003_testcase.xml (see attachment) AND under File Type choose "Microsoft Excel 2003 XML (*.xml;*.xls)"
4. Hit OK
5. Notice: Under "From file" "Sheet1" (should be "testcase" actually) is listed
6. Hit OK
7. Notice empty sheet is inserted.
-> Expected testcase table should be inserted as sheet.


Notice:
1. Provided testcase are imported as expected via File - Open...
2. This Issue is *NOT* about the MSO 2003 XML XSLT filter, the same issues applie to other/custom XSLT filter (the MSO 2003 Filter are just chosen as samples).


Tested on Windows XP and LO 3.5 RC2
Comment 1 famo 2012-01-30 15:59:25 UTC
Created attachment 56351 [details]
MSO Word 2003 XML Testcase
Comment 2 famo 2012-01-30 16:00:00 UTC
Created attachment 56352 [details]
MSO Excel 2003 XML Testcase
Comment 3 Rainer Bielefeld Retired 2012-01-30 23:24:17 UTC
[Reproducible] with "LibreOffice 3.5.0 RC2 German UI/Locale [Build-ID: e371a95-bf68a13-5a1aa2b-d3c1ae9-b938258] on German WIN7 Home Premium (64bit) (I tested WRITER / MSO Word 2003 XML Testcase).

Old issue, get error message tsting with Master from July 2011

"LibreOffice 3.4.5 German UI [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7 Home Premium (64bit) does not show error message, but imports nothing (See my additional bug report). 

Worked fine with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]"
Comment 4 Rainer Bielefeld Retired 2012-01-30 23:26:07 UTC
Please also see "Bug 45424 - FILEOPEN: IMPORT XSLT Filter imports nothing from MSO OFFICE 2003 XML"
Comment 5 famo 2012-01-31 03:06:09 UTC
(In reply to comment #3)
> Worked fine with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit)
> German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]"
Did you tested here also the Calc testcases?

I tested the Calc testcases in OOo 3.2.1 (should have written that before) and I couldn't get them to work here either. So I'm not so sure about the regression thing.


Or this bug is to "wide", although all these issues are somehow related.
Comment 6 Teo91 2013-09-29 12:59:06 UTC
I can confirm this with LO 4.1.1. on Windows 7 SP1
Comment 7 Teo91 2013-09-29 13:02:24 UTC
Notice: AOO 4.0 open both testcase correctly
Comment 8 Maxim Monastirsky 2014-08-06 07:53:40 UTC
*** Bug 45424 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2014-08-06 09:37:57 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b7325b907edf0cd8e2ca577e9796c1cf7d56bd70

fdo#45418 xslt: Make sure we're reading from the beginning



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2014-08-06 13:45:57 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e9affcdc32fe6796b60b5b4d484b296f70e745b2&h=libreoffice-4-3

fdo#45418 xslt: Make sure we're reading from the beginning


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.