Bug Hunting Session
Bug 45424 - FILEOPEN: IMPORT XSLT Filter imports nothing from MSO OFFICE 2003 XML
Summary: FILEOPEN: IMPORT XSLT Filter imports nothing from MSO OFFICE 2003 XML
Status: RESOLVED DUPLICATE of bug 45418
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.1 RC1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-01-30 23:24 UTC by Rainer Bielefeld Retired
Modified: 2014-08-06 07:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-01-30 23:24:01 UTC
Steps how to reproduce with "LibreOffice 3.4.1RC1  - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:101)]":

0. Download sampel from 
   "Bug 45418 - FILEOPEN: IMPORT XSLT Filter do not work on LINK or Insert"
    <https://bugs.freedesktop.org/attachment.cgi?id=56351>
1. Start LibO 3.4.1 from LibO Start Center
2. 'New -> WRITER Document'
3. Menu 'Insert -> File -> Filetype = Microsoft WORD 2003 XML' Select Sample
4. <Open>
   Expected: Lorem Ipsum Text from sample document will be inserted
   Actual: Nothing happens, noi error message, no text becomes visible, further 
           text shows no lorem ipsum txt in "content.xml"

Worked fine with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]" 

The problem seems to be limited to particular file types, proceeding 0 to 4 worked fine with a sample.odt containing 20 times sting "My text".

It looks as if this broke from LibO 3.3 to 3.4

I found this problem during my research for Bug 45418
Comment 1 sasha.libreoffice 2012-03-16 02:17:45 UTC
Reproduced in 3.5.1 on Fedora 64 bit
in step 4 on screen appears windows with this text:
Read-Error.
Error reading file.
Comment 2 A (Andy) 2013-03-10 10:27:37 UTC
reproducible with LO 4.0.1.2 (Win7 Home, 64bit)

Result:
"Read-Error.
Error reading file."
Comment 3 Michael Meeks 2014-01-13 15:36:38 UTC
Interesting; the file loads nicely if you don't select the format type though (which is interesting).
Comment 4 Maxim Monastirsky 2014-08-06 07:53:40 UTC

*** This bug has been marked as a duplicate of bug 45418 ***