Bug 45518 - FILESAVE: rectangle rounded corners not saved
Summary: FILESAVE: rectangle rounded corners not saved
Status: CLOSED DUPLICATE of bug 39907
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-02-01 16:12 UTC by jareddabc
Modified: 2012-08-24 20:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jareddabc 2012-02-01 16:12:18 UTC
Problem description: 
After creating a rectangle with rounded corners (e.g. select shape, right click -> Position and size... -> Slant & Corner Radius -> Radius = 1") and saving the presentation.  The corners are back to square after reopening the presentation.

Steps to reproduce:
1. Add rounded-corner rectangle to some slide.
2. Save and close the presentation.
3. Reopen the presentation, observe the corners are now square.

Current behavior:
Corners do not preserve rounded-ness.
Expected behavior:
I expect the shapes to be preserved over closing/opening of files.
Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Comment 1 sasha.libreoffice 2012-04-03 04:38:41 UTC
reproduced in 3.5.1 on Fedora 64 bit
but not reproducible in 3.3.4 , therefore regression after 3.3.4
Use this for create round corners:
> select shape, right click
> -> Position and size... -> Slant & Corner Radius -> Radius = 1
Comment 2 daniel.schaaaf 2012-05-30 02:48:40 UTC
Confirmed in 3.5.4.2 and 3.6.0alpha on win64 ... looks like we have to revert to 3.3.4.
Comment 3 Regina Henschel 2012-06-27 15:53:34 UTC
You are using the 'custom shape' rectangle instead of the 'classical' rectangle. For details read issue 39907.

*** This bug has been marked as a duplicate of bug 39907 ***