Download it now!
Bug 39907 - Disable UI "Corner Radius" for custom shape rectangle
Summary: Disable UI "Corner Radius" for custom shape rectangle
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Radek Doulik
URL:
Whiteboard: target:4.1.0
Keywords:
: 45518 46503 51385 53848 53922 59768 63521 63970 66536 66583 66639 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-07 12:26 UTC by tomasz.banaszewski
Modified: 2016-05-04 19:42 UTC (History)
16 users (show)

See Also:
Crash report or crash signature:


Attachments
choosed form (12.53 KB, image/png)
2011-08-09 03:17 UTC, tomasz.banaszewski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tomasz.banaszewski 2011-08-07 12:26:43 UTC
The property of rectangle "corner radius" cannot not be saved. (Draw , Impress.)
Create empty drawing, draw a rectangle, set property "position and size -> corner radius" to i.e. 0.5 cm. The property will be applied. Than safe and close the document. If you open this document again the rectangle appears without rounded corners.
Comment 1 Regina Henschel 2011-08-08 17:05:16 UTC
I cannot confirm it with WinXP. Here it saves and reopens without problems.
Comment 2 tomasz.banaszewski 2011-08-09 03:17:39 UTC
Created attachment 50064 [details]
choosed form
Comment 3 tomasz.banaszewski 2011-08-09 03:19:02 UTC
(In reply to comment #1)
> I cannot confirm it with WinXP. Here it saves and reopens without problems.

I use WIN-Vista. 
If I open a document that was created with older version (LibO 3.3.x) and the rounded rectangle was saved, I can take changes on radius and they will be saved.
But if I create a new rectangle or square and try to change the radius it won't be saved. 
I mean the nativ rectangle form and NOT this special rounded rectangle (see screenshot) 
The special rounded rectangle works correctly. 
(In reply to comment #1)
> I cannot confirm it with WinXP. Here it saves and reopens without problems.
Comment 4 Regina Henschel 2011-08-09 04:10:11 UTC
I guess, what the error is. But to be sure: Please click on the misbehaving rectangle and look at the left part of the status bar. Does it tell "Rectangle" or "Shape"?
Comment 5 tomasz.banaszewski 2011-08-09 04:27:42 UTC
(In reply to comment #4)
> I guess, what the error is. But to be sure: Please click on the misbehaving
> rectangle and look at the left part of the status bar. Does it tell "Rectangle"
> or "Shape"?

it tells "shape marked". I use german language version: "Form markiert"

=======================================================================

Danke für die rasche Antwort. Liebe Grüße aus Salzburg.
Comment 6 Regina Henschel 2011-08-09 08:22:29 UTC
From version 3.3 to version 3.4 the single version of the rectangle has been changed from the classical rectangle (status bar says 'rectangle') to the custom shape rectangle (status bar says 'shape'). This was done with http://cgit.freedesktop.org/libreoffice/impress/commit/?h=libreoffice-3-4&id=d31b6292b14546ac7b04b4f483b70f68b56412e6

The custom shape kind rectangle is not able to carry the information "rounded corners", so it is not stored. But the UI in position&size is enabled, so it looks like it would be possible. If you use it, the shape is transformed as if it is classical rectangle. This differs between classical rectangle and custom shape rounded rectangle in the way the rounding is done for large values.

The bug is, that the UI for "rounded corners" is not disabled. In LO3.3 this part is disabled for the custom shape rectangle.
Comment 7 tomasz.banaszewski 2011-08-09 11:05:42 UTC
thank's for your assistance. 
I added the classical rectangle tool to the drawing toolbar. 
It works as expected.
One question.
What is the advantage of the custom shape kind rectangle ?
Comment 8 tomasz.banaszewski 2011-08-09 11:27:30 UTC
First I didn' noticed this comment: 
"sd-toolbar-advanced-shapes.diff: used advanced Ellipse and Rectangle shapes
they allow to wrap text according to the shape which is a very nice feature (bnc#171052)"
Comment 9 tomasz.banaszewski 2011-08-10 07:41:37 UTC
Should I mark this bug as "resolved" ?
Last notice from Regina was:
> The bug is, that the UI for "rounded corners" is not disabled ... for the custom shape rectangle < so I don't know how should I proceed further with this request.
Comment 10 Regina Henschel 2011-08-10 08:11:40 UTC
No, it is not resolved. But I will change the subject to reflect the underlying problem.

It is a regression in comparison to LO3.3 that the part "rounded corner" is enabled now, although this kind of rectangle is not able to have this property.
Comment 11 Björn Michaelsen 2011-12-23 12:29:12 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 12 Regina Henschel 2012-02-23 14:42:46 UTC
*** Bug 46503 has been marked as a duplicate of this bug. ***
Comment 13 uwe.oberlack 2012-05-31 05:07:14 UTC
This bug persists in version 3.5.4 on Mac OS X. It is very annoying, since the same button in the toolbar, which is still (misleadingly!) called "Rectangle" when moving the mouse over it, now has a different meaning, namely it is a custom shape, as explained in comment 6. The shape is actually adapted, the corners look rounded, as they used to, while working on the file. But now, all these changes are lost once the document is closed!

This bug needs to be fixed, therefore I put the status to "reopen".
Comment 14 uwe.oberlack 2012-05-31 05:20:43 UTC
(In reply to comment #13)
> This bug persists in version 3.5.4 on Mac OS X. It is very annoying, since the
> same button in the toolbar, which is still (misleadingly!) called "Rectangle"
> when moving the mouse over it, now has a different meaning, namely it is a
> custom shape, as explained in comment 6. The shape is actually adapted, the
> corners look rounded, as they used to, while working on the file. But now, all
> these changes are lost once the document is closed!
> 
> This bug needs to be fixed, therefore I put the status to "reopen".

I haven't found out how to get back the classic rectangle, where I can still set the corner radius. The rounded rectangle und "Basic Shapes" has a fixed rounding radius, which is not always the one I want. Does the classic "rectangle" still exist?
Comment 15 Regina Henschel 2012-05-31 08:12:26 UTC
(In reply to comment #14)
> I haven't found out how to get back the classic rectangle, where I can still
> set the corner radius. The rounded rectangle und "Basic Shapes" has a fixed
> rounding radius, which is not always the one I want. Does the classic
> "rectangle" still exist?

You should ask on a mailing list. Here a short answer: Yes, it is still there. You can customize this tool bar and will find it in the category 'Drawing'. I personally do not insert the single rectangle, but the rectangle toolbox from there.
Comment 16 Regina Henschel 2012-06-27 15:52:32 UTC
*** Bug 51385 has been marked as a duplicate of this bug. ***
Comment 17 Regina Henschel 2012-06-27 15:53:34 UTC
*** Bug 45518 has been marked as a duplicate of this bug. ***
Comment 18 Rainer Bielefeld Retired 2012-06-27 21:09:37 UTC
It's the radius input in menu 'format -> Position and Size -> Slant & Corner Radius'. All(?) other basis shapes have radius input disabled.

Still [Reproducible] with server-installation of Master "3.7.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: b255de8]" (tinderbox: Win-x86@6-fast, pull time 2012-06-05 23:16:58)

@Thorsten:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 19 Regina Henschel 2012-08-24 20:11:34 UTC
*** Bug 53922 has been marked as a duplicate of this bug. ***
Comment 20 daniel.schaaaf 2012-09-12 12:59:10 UTC
Bug 53848 might be a duplicate of this bug and it can be reproduced in 3.5.6 and 3.7alpha0 (Win Server 2008).

As so very often, the UI is kind of messed up in different documents and LibreOffice is very inconsistent.

Calc allows drawing of a "rectangle" and a rectangular shaped "shape" and both have different properties. In Draw, I can only draw shapes, even though the toolbar (3.7.alpha0) looks similar to the one in Calc. If you take a closer look, the rectangle in Calc is blue, while the rectangular shape in Draw is gray. 

In my opinion, we should get rid of the real rectangle (and ellipse) completely and clean up in the shapes department. E.g. do we really have to have four kinds of rectangle shapes (rectangle, rounded rectangle, square, rounded square), or two circles (circle, ellipse), or ...
I personally do not like to be restricted, only to make things easier for newcomers. One rectangular shape is enough and the user should be able to modify the shape himself (to transform the rectangle into a square or apply rounded corners).
Comment 21 Regina Henschel 2012-09-12 14:07:15 UTC
*** Bug 53848 has been marked as a duplicate of this bug. ***
Comment 22 Regina Henschel 2012-09-12 14:20:35 UTC
I disagree with the proposal to remove the classical shapes. They are part of ODF and they are part of SVG too. There exist a lot of documents which use this classical shapes and a lot of users, who want to use the classical rectangle as can be seen from the lot of duplicates here.

The fact, that the property "corner radius" is not disabled for a custom shape, is a real error.

Exchanging the classical rectangle with a custom shape rectangle in the toolbar has been a bad UI decision, because users expect a classical rectangle there and a user cannot easily notice, that it was changed.
Comment 23 Evan Carroll 2012-10-21 21:43:05 UTC
> What is the advantage of the custom shape kind rectangle ?

Well my girlfriends assignment requires her to create a rounded-rectangle that looks like an Elongated Circle (not an oval). Currently, this can only be done by creating a rectangle with a custom curve radius.

The figure has to look something like this, http://en.wikipedia.org/wiki/File:Elongated_circle_896.svg
Comment 24 Evan Carroll 2012-10-21 21:44:56 UTC
I just wanted to add to this bug report that this information is not passed on when using Export to PDF functionality. These custom shapes with custom corner radiuses are not exported to PDF.
Comment 25 Regina Henschel 2012-10-21 22:46:58 UTC
The custom shapes have a separate rectangle shape for circle kind rounded corners. Open the custom shape group "Basic shapes". And it exports to pdf without problems.
Comment 26 Thorsten Behrens (CIB) 2012-10-26 20:32:51 UTC
Rodo, this is a recurring issue after the change from std to custom shapes. Can you take over this one, possibly get UX input, and have it solved one way or the other? The current situation is less than optimal.
Comment 27 Rainer Bielefeld Retired 2013-04-02 05:59:23 UTC
*** Bug 59768 has been marked as a duplicate of this bug. ***
Comment 28 Rainer Bielefeld Retired 2013-04-02 06:03:58 UTC
Added Radek to CC Due to Comment 26
Comment 29 Rainer Bielefeld Retired 2013-04-02 06:06:39 UTC
*** Bug 58051 has been marked as a duplicate of this bug. ***
Comment 30 Radek Doulik 2013-04-04 12:06:07 UTC
OK, I have disabled round corner on rectangle shape. Pushed to master.
Comment 31 Commit Notification 2013-04-04 12:08:37 UTC
Radek Doulik committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0c7bbbe9da7602f5d72aecd481f6d26d9af217f0

disable round corners for rectangle shape. fixes fdo#39907



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 32 Regina Henschel 2013-04-04 14:37:17 UTC
I think, it is the wrong object. The problem is, that a _custom shape_ has the UI "corner radius", but custom shapes do not have that property.

For the primitive rectangle the UI is correct and must not be changed.

The error is not in the info. The custom shape has already set rInfo.bEdgeRadiusAllowed=sal_False in method TakeObjInfo. The problem is, that that this part of the dialog is enabled despite of this information.
Comment 33 Radek Doulik 2013-04-05 09:49:58 UTC
Not sure I understand it correctly then. My patch disables UI for rectangle shape which is on bottom toolbar, 4th position and also 1st shape in submenu on that toolbar with other custom shapes. Both of these loose corner radius after saving to odp.

With my patch the UI for its corner radius is disabled.

Please could you explain which shape do you mean then? (best with example)
Comment 34 Regina Henschel 2013-04-05 10:22:16 UTC
svdorect.cxx belongs to the primitive rectangle (<draw:rect> in the file) and not to the custom shapes. The custom shapes are handled in svdoashp.cxx. But there the information is correctly set by "rInfo.bEdgeRadiusAllowed=sal_False". Therefore the error must be somewhere else, perhaps a copy, clone or assign operation somewhere does not copy it and therefore the default "true" is used. But I don't know, otherwise I would have solved it already.

Your change does indeed disable that dialog part for the primitive rectangles as I guessed yesterday. I have tested it just with the daily. And your change does not only affect Impress, but all the other modules too.

Remember, that you have to configure the toolbar in Impress, to show a primitive rectangle. Look at the statusbar to be sure, what kind of object you are working on. A shape always shows 'shape selected'. But a primitive rectangle shows detailed information like 'rectangle selected' or 'Rounded rectangle selected' or 'Rounded parallelogram selected'. But as it can be seen in other modules too, you can try it in Draw as well.

So please revert the commit.
Comment 35 Radek Doulik 2013-04-05 12:50:41 UTC
OK, I see what you mean now.

I fixed it on custom shapes level and it should work now. Old primitive rectangle shapes have corner radius UI enabled, while the rectangles from Drawing toolbar have it disabled.
Comment 36 Regina Henschel 2013-07-03 18:33:29 UTC
*** Bug 63521 has been marked as a duplicate of this bug. ***
Comment 37 Regina Henschel 2013-07-03 18:34:04 UTC
*** Bug 66536 has been marked as a duplicate of this bug. ***
Comment 38 Regina Henschel 2013-07-03 18:35:05 UTC
*** Bug 63970 has been marked as a duplicate of this bug. ***
Comment 39 m.a.riosv 2013-07-06 13:33:31 UTC
*** Bug 66583 has been marked as a duplicate of this bug. ***
Comment 40 m.a.riosv 2013-07-06 13:34:08 UTC
*** Bug 66639 has been marked as a duplicate of this bug. ***