Bug 99684 - Corner radius of rounded rectangle can be set by dragging point, but not by entering a value
Summary: Corner radius of rounded rectangle can be set by dragging point, but not by e...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-05-04 19:42 UTC by Stanislav Horacek
Modified: 2020-02-07 14:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Horacek 2016-05-04 19:42:33 UTC
1. In Writer, choose "Rectangle, Rounded" on the Drawing toolbar.
2. Draw a rectangle. You will see a yellow point near its corner - you can adjust the corner radius by dragging it.
3. In context menu of the rectangle, choose "Position and Size" and go to the "Slant & Corner Radius" tab. The "Radius" field is disabled and the radius cannot be set by a value.

The UI for radius has been disabled for rectangles because it was not preserved after document reopen (see bug 39907) - but this seems not to be the case.

Tested in 5.0.5 and 5.1.2, Ubuntu 15.10.
Comment 1 Buovjaga 2016-05-07 12:24:09 UTC
Confirmed.

64-bit, KDE Plasma 5
Build ID: 5.1.2.2 Arch Linux build-1
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 2 Joachim Otahal 2016-10-09 23:36:10 UTC
Confirmed "me too"
Window 10 x64, 5.2.2.2
If you use the "Basic shapes" version you can only drag, but not enter the value.
You have to use View -> Toolbars -> Legacy rectangles to get one where you can enter the exact value, which is quite often needed.
Comment 3 chbok 2017-09-20 07:04:46 UTC
With my Libo 5, i just updated old documents, and tried to create new rounded rectangle... And i discovered that the radius field is disabled.
I loosed time to understand the issue.

In fact, olds documents contains "draw:rect" in content.xml, and new "rectangle" (round or not) are create with "draw:custom-shape".
The manual adjustment of the rounding is not possible for my need.
my soluce : copy and paste my old shapes, what a mess

(tested with libo 5.3 - windows 10)
Comment 4 QA Administrators 2018-09-21 02:47:33 UTC Comment hidden (obsolete)
Comment 5 Roman Kuznetsov 2018-09-21 12:44:59 UTC
still repro in 6.1.1.2
Comment 6 QA Administrators 2019-09-22 02:59:03 UTC Comment hidden (obsolete)
Comment 7 chbok 2019-11-01 12:24:27 UTC
still repro in 6.3.3.2 (x64 W10)
A quick manual basic rounded rectangle create a soup of content like that :

<draw:custom-shape draw:name="Forme1" draw:style-name="gr1" svg:y="1.032cm" svg:x="1.011cm" svg:height="2.834cm" svg:width="6.97cm" draw:z-index="0" text:anchor-type="paragraph">
  <text:p/>
  <draw:enhanced-geometry draw:enhanced-path="M ?f7 0 X 0 ?f8 L 0 ?f9 Y ?f7 21600 L ?f10 21600 X 21600 ?f9 L 21600 ?f8 Y ?f10 0 Z N" draw:modifiers="3600" draw:type="round-rectangle" draw:text-areas="?f3 ?f4 ?f5 ?f6" draw:path-stretchpoint-y="10800" draw:path-stretchpoint-x="10800" svg:viewBox="0 0 21600 21600">
  <draw:equation draw:name="f0" draw:formula="45"/>
  <draw:equation draw:name="f1" draw:formula="$0 *sin(?f0 *(pi/180))"/>
  <draw:equation draw:name="f2" draw:formula="?f1 *3163/7636"/>
  <draw:equation draw:name="f3" draw:formula="left+?f2 "/>
  <draw:equation draw:name="f4" draw:formula="top+?f2 "/>
  <draw:equation draw:name="f5" draw:formula="right-?f2 "/>
  <draw:equation draw:name="f6" draw:formula="bottom-?f2 "/>
  <draw:equation draw:name="f7" draw:formula="left+$0 "/>
  <draw:equation draw:name="f8" draw:formula="top+$0 "/>
  <draw:equation draw:name="f9" draw:formula="bottom-$0 "/>
  <draw:equation draw:name="f10" draw:formula="right-$0 "/>
  <draw:handle draw:handle-range-x-maximum="10800" draw:handle-range-x-minimum="0" draw:handle-switched="true" draw:handle-position="$0 top"/>
  </draw:enhanced-geometry>
</draw:custom-shape>

Give back simple "<draw:rect/>"
Comment 8 Gerhard Weydt 2020-01-26 23:27:21 UTC
The same applies to all components of LibO, so I changed the component accordingly.
Still present in 
Version: 6.3.4.2 (x64)
Build-ID: 60da17e045e08f1793c57c00ba83cdfce946d0aa
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: threaded
Comment 9 Gerhard Weydt 2020-01-27 00:08:06 UTC
And corner radius can still be set via context menu -> Position and Size
Comment 10 Gerhard Weydt 2020-01-27 19:00:17 UTC
(In reply to Gerhard Weydt from comment #9)
> And corner radius can still be set via context menu -> Position and Size

Sorry, I was wrong.
Comment 11 Regina Henschel 2020-02-05 23:21:37 UTC
(In reply to chbok from comment #7)
> Give back simple "<draw:rect/>"

It still exists. Draw:Impress: It is in the toolbar "Legacy Rectangles". You can open it via View > Toolbars or add it as sub-list to a toolbar via Customize. Writer/Calc: The rectangle is available as single command "Rectangle" via Customize.

The "Slant and Corner Radius"-tab of the Position&Size dialog has got two sections "Control Point" in the meantime. They allow to determine the position of handles of shapes, which are "draw:custom-shape". So for to enter the corner radius for such an rectangle, you have to use the field "Control Point 1, X:" and not the field "Corner Radius".

The field cannot be named "Corner Radius", because it works for handles of other shapes too.

With getting these new fields in the dialog, the bug is a "works for me" now.
Comment 12 chbok 2020-02-06 07:56:08 UTC
Ho ! you explain me how to add an "legacy rectangle", but why still subsits two manners for drawing them ?
A casual user under Writer never will understand that, if he must open Draw:Impress to draw a shape, and next copy/paste it in Writer.
okay, i tested your procedure and it works. But the bug refer to Writer. So, i claim for return the "legacy forms" back in Writer.
Comment 13 Gerhard Weydt 2020-02-06 18:12:59 UTC
(In reply to chbok from comment #12)
> Ho ! you explain me how to add an "legacy rectangle", but why still subsits
> two manners for drawing them ?
> A casual user under Writer never will understand that, if he must open
> Draw:Impress to draw a shape, and next copy/paste it in Writer.
> okay, i tested your procedure and it works. But the bug refer to Writer. So,
> i claim for return the "legacy forms" back in Writer.

There's no need to add a legacy rectangle. Simply add a rectangle via menu or tool bar, it will be of the new type "custom shape". And if you won't/can't use the mouse, then change the corner radius - as pointed out by Regina - by changing the control point: the value shown in the X or Y coordinate (it depends on which side is longer) is the distance between the control point and the corner point, which is also the radius of the circle used to draw the rounded corner.
Comment 14 Stanislav Horacek 2020-02-06 22:11:08 UTC
As explained in comment #11, the added Control points indeed fixed the bug I've reported. Thanks for closing this!
Comment 15 chbok 2020-02-07 14:25:46 UTC
Please, think to a basic user. When drawing a basic shape like a rounded rectangle, he only see a disabled "corner radius" field and must guess that to adjust precisely this radius, he must :
- use Draw:Impress to copy a "legacy rounded one" to have access to the "corner radius" field
- or enter the radius value in a mystical "Control Point" field (mystical for this particular user)