Bug 59768 - FILESAVE looses LibO 3.4.5 (and later) rectangle corner radius
Summary: FILESAVE looses LibO 3.4.5 (and later) rectangle corner radius
Status: RESOLVED DUPLICATE of bug 39907
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-23 15:46 UTC by Dave
Modified: 2013-04-02 06:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Before and after screenshots of rectangle with rounded corners (69.95 KB, image/png)
2013-01-23 15:46 UTC, Dave
Details
New Sample (12.29 KB, application/vnd.oasis.opendocument.graphics)
2013-04-02 06:00 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave 2013-01-23 15:46:41 UTC
Created attachment 73531 [details]
Before and after screenshots of rectangle with rounded corners

Problem description: 
Rounded corner attributes on rectangles aren't saved.

Steps to reproduce:
1. Create a new .odg document.
2. Create a rectangle, filled or not, makes no difference.
3. Press F4 and set the corner radius to something. The rectangle should display rounded corners on the screen.
4. Save the document.
5. Close the document.
6. Reopen the document. The rectangle now has square corners.

Current behavior:

Expected behavior:
Rectangles saved with rounded corners ought to have rounded corners when the document is reloaded.
              
Operating System: openSUSE
Version: 3.6.4.3 release
Comment 1 Radu 2013-01-23 22:35:07 UTC
Reproduced on Kubuntu 12.04 with 3.5.4.2 and Version 4.1.0.0.alpha0+.
Comment 2 will 2013-02-07 17:25:15 UTC
I can confirm that this bug exists in Version 3.6.2.2 (Build ID: 360m1(Build:2)) as installed from deb on Ubuntu 12.12
Comment 3 michael.letzgus 2013-03-18 09:13:59 UTC
Same Problem with LO 4.0.1, Linux X64
Comment 4 Rainer Bielefeld Retired 2013-04-02 05:59:23 UTC
Still worked fine with Server Installation of "LibreOffice 3.3.3  German UI/Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit)

[Reproducible] with Server Installation of  "LibreOffice 3.4.5 German UI [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7 Home Premium (64bit):

1. open attached sample document
   shows top left rectangle with corner radius 5mm (ok)
   shows rectangle below with corner radius 0mm (NOT ok)
2. For both rectangles:
   Rightclick -> Position & Size -> Slant & corner Radius - Radius = 15mm'
3. Save - Close - Reopen
   Expected: Both modified rectangles with corner radius 15mm
   Actual: only rectangle created with 3.3.3 with corner radius >0          !!!

It seems we changed the Corner Radius code with 3.4.? 
In attached sample you find a rectangle with corner radius created with 3.3.3. and below a rectangle with corner radius. You can edit radius in both rectanangles with all versions starting with 3.4 (I started with 3.4.5), always saving corner radius for 3.4.5 rectangle fails.
3.3.3 will not recognize a corner radius for 3.4.5 rectangle

Due to 
<https://bugs.freedesktop.org/show_bug.cgi?id=39907#c6> this one is a DUP of "Bug 39907 - Disable UI "Corner Radius" for custom shape rectangle"

*** This bug has been marked as a duplicate of bug 39907 ***
Comment 5 Rainer Bielefeld Retired 2013-04-02 06:00:13 UTC
Created attachment 77301 [details]
New Sample

See comment above how to use