Bug 53848 - FILESAVE corner radius not saved
Summary: FILESAVE corner radius not saved
Status: CLOSED DUPLICATE of bug 39907
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Leif Lodahl
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-20 14:57 UTC by troudelalmanach
Modified: 2012-09-12 14:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example of shape with corner radius (is missing) (8.70 KB, application/vnd.oasis.opendocument.graphics)
2012-08-30 13:10 UTC, Leif Lodahl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description troudelalmanach 2012-08-20 14:57:19 UTC
Saving a draw document containing rectangle where the corner radius has been set via 'Position and Size|Slant & Corner Radius' will not show the corner formatting when opened again. (LibO version 3.5.6 Win_x86)
Comment 1 Leif Lodahl 2012-08-30 13:10:57 UTC
Created attachment 66336 [details]
Example of shape with corner radius (is missing)

This file was saved with a corner radius of 0,3 cm. After saving the document the corner radius is reset to 0,0 cm.
Comment 2 Leif Lodahl 2012-08-30 13:11:16 UTC
Confirmed also in 3.6.0 and 3.6.1 using debian-Linux.
Comment 3 daniel.schaaaf 2012-09-12 12:43:03 UTC
This bug seems to be related to 39907 and can be reproduced in 3.5.6 and 3.7alpha0.

In Calc, There are two rectangle types, a "real" rectangle and a "shape" rectangle. The real rectangle keeps its rounded corners after re-loading the document, while the shape rectangle doesn't. For some reason, Draw only has shape rectangles!
A rectangle created in Calc can be copied to Draw and will be identified as "(rounded) rectangle", while everything else in Draw seems to be just a shape. (Another great example of how different document types are completely messed up by divergence in LibreOffice)

In my opinion, we should get rid of the real rectangle completely (and real ellipse) and clean up in the shapes department. E.g. do we really have to have four kinds of rectangle shapes (rectangle, rounded rectangle, square, rounded square), or two circles (circle, ellipse), or ...
Comment 4 Regina Henschel 2012-09-12 14:07:15 UTC
It is surely a duplicate of bug 39907.

*** This bug has been marked as a duplicate of bug 39907 ***