Bug Hunting Session
Bug 66536 - FILESAVE: corner radius of rectangles
Summary: FILESAVE: corner radius of rectangles
Status: RESOLVED DUPLICATE of bug 39907
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-03 06:37 UTC by Mohith Manoj
Modified: 2013-07-03 18:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mohith Manoj 2013-07-03 06:37:52 UTC
The property 'Corner radius' of rectangles are not saved.

1) Create a new drawing or presentation
2) Draw a rectangle
3) Set corner radis to a non zero value through 'Right click on object > Position and Size > Slant & Corner Radious > Corner Radius'
4) Save the document and close
5) Open the document.
The corner radius property is reset to 0!

This issue has been reported already under,
Bug 63521
Bug 39907
Bug 63970
Bug 46503
Bug 51385
Bug 45518 etc, however for different versions of LO.

The solution for the issue appears to be simple (I'm no expert, just a guess). Since the other bug reports have been alive for quite a while, please do not mark this as a duplicate of some other bug such that this one also goes lost in the existing web of bugs!
Comment 1 retired 2013-07-03 08:59:39 UTC
Mohith: Thanks for reporting this problem.

But as you write yourself this is a duplicate of Bug 63521. The policy (https://wiki.documentfoundation.org/QA/BugTriage) is not to create a single bug for each version of LO this still happens with, but to update the existing bug with that info. You already have done just that - thanks.

If we don't mark this as duplicate it would actually create a very messy bug database. I don't think the existing bug did get "lost in the existing web of bugs". The opposite is true. If we would not mark dupes as dupes, devs would be very  lost with an unusable bug database.

You just have to keep in mind that there are over 8.000 bugs currently for LO. That means, that with the limited time available from devs not all bugs will immediately get fixed.

The existing bug you point to was created on 2013-04-14 which isn't very old. This is open source software so there's always the option to fix it yourself or wait for another dev to take a shoot at this.

*** This bug has been marked as a duplicate of bug 63521 ***
Comment 2 Regina Henschel 2013-07-03 18:34:04 UTC

*** This bug has been marked as a duplicate of bug 39907 ***