Bug Hunting Session
Bug 45596 - EDITING: App hangs after cut-and-paste
Summary: EDITING: App hangs after cut-and-paste
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: perf
Depends on:
Blocks:
 
Reported: 2012-02-03 08:09 UTC by Chip Eastham
Modified: 2016-09-19 16:47 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot (partial) of Web page showing selected lines (1.00 MB, image/x-MS-bmp)
2012-02-08 09:06 UTC, Chip Eastham
Details
I copy the text in this file, it freeze 5 sec before i can paste (6.50 KB, application/vnd.ms-excel)
2012-09-02 22:35 UTC, Duke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chip Eastham 2012-02-03 08:09:08 UTC
Problem description: 

While cutting and pasting from one cell to another, spreadsheet became unresponsive (target cell selected but no content appeared from the paste operation).  MS Windows 7 mouse went to "clocking" mode (swirling circle).  Application generally unresponsive (no menu would open, app would not close).

Several cut-and-paste operations (less than a dozen) had already been successful to this point (in a new document).  Task manager did not display any suspicious information.

After force close by shutdown/restart, recovery in LO Calc was unsuccessful (blank document opened).

I'll try and reproduce the problem.

Browser: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.77 Safari/535.7
Comment 1 Rainer Bielefeld Retired 2012-02-03 12:20:33 UTC
@Chip Eastham

If you successfully reproduce the problem, please:
- Attach a sample document (not only screenshot)
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (due to example in Bug 43431)
– if possible contribute an instruction how to created a sample document 
  from the scratch
- add information 
  -- concerning your PC (video card, ...)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration ...)
  -- how you launch LibO and how you opened the sample document
  -- everything else crossing your mind after you read linked texts
Comment 2 Chip Eastham 2012-02-07 10:18:21 UTC
Here are steps that precisely reproduced the problem for me today:

1.  Googling for "white pages" I pulled up this site:

http://www.whitepages.com

and did a search with my own name.  It should open a page with formatted text for name, phone number and address (street and city/zipcode).  I selected those lines (ctrl-C), which form a sort of column along the left side of the Web page.

2.  Using LibreOffice 3.4 icon on my Windows7 start menu, I opened a dialog box that lets me create a new LO spreadsheet (Calc).  I did not save or name the spreadsheet or any "sheets" within the default spreadsheet that opens.

3.  I pasted the copied text (see step 1.) into the first cell of the spreadsheet.  The contents actually parse out into cells A1:A4.

4.  Cell A1 grows awfully large due to the font size being used.  I change font size down (from 22) to 12, leaving the font for that cell as Times New Roman.  I stretch cell A1 to the right so that the width is enough to display contents.

5.  I then apply a Ctrl-X, Ctrl-V cut-and-paste to each of cells A2:A4 in turn (one by one), copying the "column A" entries into "first row" entries B1:D1,  the phone number, the street address, and the city/state/zip.  I stretch the widths as needed for these three columns as I go.

6.  I now go back to step 1, copying again exactly the same name, phone number, and address information as before.

7.  I paste that copied selection into cell A2, basically repeating the step 3. except beginning now in the second row of the (already open) spreadsheet.  The selection parses out into cells A2:A5

8.  I repeat step 4. reducing the Times New Roman font size down to 12.  However it is not necessary to change the cell width this time around.

9.  I repeat step 5. moving contents of cells A3:A5 one at a time to cells B2:D2.  Again there is no need to change cell width because that was accomodated previously.

10. When the attempt is made to move cell A4, the cutting of the contents (ctrl-X) appears to work correctly.  However upon trying to paste that street address (ctrl-V) into cell C2, the application freezes, with the mouse changing to a swirling "wait/operation in progress" form.  The LibreOffice Calc application remains frozen so long as I've cared to wait, unable to close by menu or button actions.
Comment 3 Rainer Bielefeld Retired 2012-02-07 21:05:23 UTC
Chip Eastham:
"Those Lines"? I can't guess what page contents you are talking about. I even do not understand what a "Line" might be.
Comment 4 Alex Thurgood 2012-02-07 22:28:18 UTC
Hi Rainer,

At a guess, this is a dup of a cut n paste from html bug.

Alex
Comment 5 Chip Eastham 2012-02-08 09:06:14 UTC
Created attachment 56758 [details]
screen shot (partial) of Web page showing selected lines

I took a screen shot from my browser for the purpose of demonstrating what four lines are referred to (name, phone number, street address, city/state/zip).  I cropped and painted out some peripheral/personal data, though of course you can always go to the Web site and see for yourself.  I find that the bug is reproducible regardless of which particular person's data is pulled up.

The file is in 24-bit BMP format.  If that's a problem, I'll try a different graphic format.  However I didn't think it all that necessary to make my personal info all that easy to access.  The directions for reproducing the bug are self-contained and as noted do not depend on whose data is queried.
Comment 6 Chip Eastham 2012-02-08 16:00:50 UTC
Per what Alex Thurgood suggests, this is consistent with my experience in that to get the job done, I switched to Paste Special/paste-as-text (instead of simple Ctrl-V) in building the spreadsheet.  Some 30 rows of data were then populated without difficulty.
Comment 7 e325001 2012-06-20 08:48:30 UTC
Steps to reproduce:
* Launch LibreOffice via shortcut ("C:\Program Files (x86)\LibreOffice 3.5\program\soffice.exe")
* Create a new Calc document by clicking the button
* Enter "text" in the first cell and press enter
* Press up on the keyboard to reselect the cell with content "text"
* Press F2 to edit
* Press Ctrl+A to select all
* Press Ctrl+C to copy

What happens:
* The application freezes for approx. 5 seconds. No input is possible, but other applications continue to work (i.e. the system doesn't freeze, only Calc does)
* The "text" is copied to the clipboard

What is expected to happen:
* The "text" is copied to the clipboard immediately


System:
* Libre Office 3.5.4.2 German, Build: 165a79a-7059095-e13bb37-fef39a4-9503d18
* Windows 7 Pro x64 SP1
* Intel Core 2 Quad Q9550
* Sapphire Radeon 4850
* Asus P5QL-E board
* 4 GB RAM
* 1 TB HD

Further tests:
* Deactivated Hardware acceleration and Anti-Aliasing in LO options. Didn't help.
* Opened dozens of existing documents. The error ALWAYS occurs for me.
Comment 8 Rainer Bielefeld Retired 2012-06-20 09:07:23 UTC
NOT reproducible as per Comment 7 with "LibreOffice 3.5.5.1  German UI/Locale [Build-ID: c9944f7-48b7ff5-0507789-54a4c8a-8b242a8] on German WIN7 Home Premium (64bit) 

This one really is a hard nut, I remember several similar complaints, and "Bug 46098 - EDITING Copy part of the cell content freeze Calc for a few seconds" sounds similar. So there is no doubt that the problem exists, 

Chip Eastham: 
<http://wiki.documentfoundation.org/BugReport_Details#Version>
Can we narrow down the moment when the "freeze" happens? Subject line says "after paste", Comment 7 "after copy"
Please attach a sample document, yes, the spreadsheet with 1 word "text" - you never know!
Comment 9 Duke 2012-09-02 22:35:30 UTC
Created attachment 66519 [details]
I copy the text in this file, it freeze 5 sec before i can paste

Here is a requested attachment that has the bug. 

I've also faced this problem for a while now. It happened after I upgrade my system with a RAID1 mirroring card, and I reinstalled Window XP & LibreOffice in May. At first, I thought something must be wrong with my cheap RAID card that cap the hard-drive access speed. Thus I've added a 3rd hard-drive to install LibreOffice. The issue seems to go away... for few weeks. Now it's coming back. So, my Libreoffice is on my 3rd hard-drive, and temp directory is also pointing to the 3rd hard-drive. the problem still exist. (I know my speed-cap logic is flawed, but reinstalling LibreOffice on different hard-drive has a temporary fix. so, just treat this as symptom. =)

I've installed 3.5.6.2 today, and problem still exist. I've created the attached xls file with the latest LibreOffice, today. But i'm afraid this may be to do with settings, and not the file itself. I received XLS file every week from my peer, and it got the same issue. (my peer uses MS Excel). 

Note that there are NO problem when copying cell. It's only when copying the text (ie/ from formula bar). I have to copy text out of an XLS file weekly, so cell to cell copy won't work for me. 

System:
WinXP 32bit 
LibreOffice is English build, but with Traditional Chinese language pack. UI in English. 

Thanks! =)
Comment 10 Rainer Bielefeld Retired 2012-09-03 06:03:04 UTC
NOT [Reproducible] with " I copy the text in this file, it freeze 5 sec before i can paste" and Server installation (own profile) of "LibreOffice  3.5.6.2  German UI/Locale [Build-ID: e0fbe70-5879838-a0745b0-0cd1158-638b327] on German WIN7 Home Premium (64bit) 

I opened document from LibO Start Center file menu, Click A2, <control+c> for copy, can click B2 immediately and can do <control+v> for paste immediately.

Currently no what additional info might help.
Comment 11 Joel Madero 2012-10-14 20:02:10 UTC
I'm marking this as WORKSFORME as I also can't really follow the steps exactly, when I search for my name I'm not getting a table that takes up A1:A4, mine is A1:D1 (four columns, 1 row), no big font, no problems with copy, cut, and paste. 

If you can provide instructions that are a bit easier to follow and if this is still a problem for you please reopen as UNCONFIRMED and I'll try. 

LibO Version 3.6.1.2 (Build ID: e29a214)
Comment 12 Duke 2012-12-23 23:10:31 UTC
I've just tested on 3.6.4.3, and this is still happening. 

The steps to reproduce for me is pretty simple:

1. copy text from a cell in the formula bar. 
2. it freeze for few seconds before you can paste. 

Note that the copy is from the forumla bar, or after double click on the cell. NOT cell to cell copy. 

Looks like this may be due to platform or environment the user is in, rather than the file itself. 

again, i'm on WinXP. But google "libreoffice freeze copy" will reveal others on different platform. Not sure what you can do if you can't reproduce it. May be review the code, and look for possible cause?
Comment 13 Paul Ericson 2013-01-08 14:56:29 UTC
This is on Win 7 64-bit, LO is 3.6.4. 3Build ID: 2ef5aff.

Still having this problem. Doesn't matter if it's content outside or inside LO. Copy is what seems to be hanging up the system, not pasting. If you're patient, pasting does finally complete.

During the freeze the LO window occasionally cycles back and forth between active window and minimized views.

Task Manager shows no high CPU/memory usage.

Is there a LO console that shows me everything it thinks it's doing?
Comment 14 Burkhard 2013-05-29 09:56:04 UTC
same problem, espacially after quick using of "cut and paste". After file-reconstruction it is not possible to format cells in the recovered file again (for instance : negative values red). Old formats are lost in the recovered table.
Comment 15 Joel Madero 2013-06-27 22:01:17 UTC
I am still not able to reproduce any of this on my Windows 7 machine following steps on comment 7 precisely.

Because there are multiple users affected I am going to request additional input
Comment 16 retired 2013-07-03 13:44:19 UTC
Can any user confirm this is still happening on Win7 using LO 4.1.0.1 from here http://www.libreoffice.org/download/pre-releases/ ?

No problems on OS X 10.8.4 or Ubuntu 13.04 with the test document.
Comment 17 Chip Eastham 2013-07-04 12:23:19 UTC
(In reply to comment #16)
> Can any user confirm this is still happening on Win7 using LO 4.1.0.1 from
> here http://www.libreoffice.org/download/pre-releases/ ?
> 
> No problems on OS X 10.8.4 or Ubuntu 13.04 with the test document.

I've tried to reproduce the problem originally reported (freeze after repeated cut-and-paste involving both external and internal text) using LO 4.1.0 release candidate, newly installed on my wife's Win7 laptop.  Everything works, no freeze. My original report was for LO 3.4, and used Firefox as the source for external text.  On my wife's laptop I only checked IE9 and Google Chrome 27.0 (up-to-date).

I'll go back to the Win7 desktop where the problem originally occurred and verify that the problem is resolved, giving another report this morning.
Comment 18 Duke 2013-07-12 23:29:28 UTC
for some reason, mine get working again, without upgrade on hardware/software/operating system. 

this is strange. This "working again" happened before, lasted few months. But the bug came back again afterwards.
Comment 19 Robinson Tryon (qubit) 2013-10-19 00:11:30 UTC
Remove comma from whiteboard.
Comment 20 Jean-Baptiste Faure 2014-01-02 22:07:01 UTC
Due to comments #17 and #18, closing as WorksForMe.

Please, feel free to reopen if the problem reappears.

Best regards. JBF
Comment 21 Robinson Tryon (qubit) 2015-12-15 11:14:39 UTC Comment hidden (obsolete)
Comment 22 Xisco Faulí 2016-09-19 16:47:59 UTC Comment hidden (obsolete)