Download it now!
Bug 45620 - Writer FILESAVE: validation of odt not passed
Summary: Writer FILESAVE: validation of odt not passed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: odf odf_validation
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-04 06:24 UTC by sasha.libreoffice
Modified: 2012-09-14 13:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test case (10.20 KB, application/vnd.oasis.opendocument.text)
2012-02-04 06:24 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2012-02-04 06:24:19 UTC
Created attachment 56598 [details]
test case

validation not passed on http://odf-validator.rhcloud.com/
LibO 3.6.0 master a1275f8-9eed775-f061262
this file created by opening doc file from site:
Bug 41765 - cannot open OLE object when the document is opened in read-only mode

error is:
Container1.odt/content.xml[32,233]: Error: uncompleted content model. expecting: <binary-data>
Comment 1 Joel Madero 2012-09-10 20:06:19 UTC
@Sasha, is this just you repeating the bug from 41765 with more information? I'm not understanding why this was opened as a new bug vs. just additional information for the bug you cite. Please clarify.
Comment 2 sasha.libreoffice 2012-09-11 11:36:59 UTC
I tried to save Container1.doc to odt in 3.6.1. But can not verify initial problem because http://odf-validator.rhcloud.com/ not working now.
I found this validator:
http://opendocumentfellowship.com/validator
But it complains about completely different problem (with styles).

Closing as Invalid because initial validator site not working and I do not have enough knowledges to validate document manually.
Comment 3 Michael Stahl (CIB) 2012-09-14 13:20:09 UTC
i cannot reproduce the problem on current 3.5/3.6/master,
even when opening the document read-only.

@Joel: this bug is about invalid ODF written by LO,
which is a problem independent of whether
LO can edit some OLE objects or not, so it makes sense
to have it as a separate bug.

PS:
yes the validator site appears to be down;
i've built it from source for that reason, you can try
http://people.freedesktop.org/~mst/odfvalidator-1.1.6-incubating-SNAPSHOT-jar-with-dependencies.jar