Bug Hunting Session
Bug 45637 - EDITING: copy and paste text from Writer to Calc performs wrong (regression since 3.4)
Summary: EDITING: copy and paste text from Writer to Calc performs wrong (regression s...
Status: RESOLVED DUPLICATE of bug 46038
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 Beta3
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-02-05 00:45 UTC by delbouys
Modified: 2012-03-14 07:50 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
un example (27.52 KB, application/pdf)
2012-02-05 00:45 UTC, delbouys
Details

Note You need to log in before you can comment on or make changes to this bug.
Description delbouys 2012-02-05 00:45:21 UTC
Created attachment 56615 [details]
un example

Problem description: problem when copying and pasting text to 

Steps to reproduce:
1. put a head in writer
2. write text in the page
3. copy texte
4. open Calc
5. Paste


Current behavior: the header is to stick with the text in the cell above

Expected behavior:the header should not be copy and paste

Platform (if different from the browser): window7 64bits
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0
Comment 1 Rainer Bielefeld Retired 2012-02-05 07:32:17 UTC
NOT reproducible with "LibreOffice 3.5.0 RC3 German UI/Locale [Build-ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735] on German WIN7 Home Premium (64bit) 

@delbouys
May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport>?
Then please:
- Write a meaningful Summary describing exactly what the problem is
- Attach 2 sample documents WRITER, CALC result (not only screenshot)
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem, starting with "Start LibO from 
  WIN Start center"
– if possible contribute an instruction how to created a sample document 
  from the scratch
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC (video card, ...)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO version and localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration ...)
  -- how you launch LibO and how you opened the sample document
  -- everything else crossing your mind after you read linked texts
Comment 2 sasha.libreoffice 2012-02-22 03:07:37 UTC
Thanks for bugreport. It will help us.

Reproduced in 3.5.0 on Fedora 64 bit and Windows XP 32 bit
but not reproducible in 3.4, therefore regression
Steps to reproduce:
0. Start Writer
1. Insert->Header->Default, put some text in header
2. Write some text inside of document
3. Select text in document, press Ctrl-C
4. Start Calc
5. on Linux press Ctrl-V
   on Windows press Ctrl-Shift-V and select "Formatted rtf"
Expected: selected text inserted into cell
Actually: into cell inserted content of header, selected text inserted into next to bottom cell
Comment 3 Caolán McNamara 2012-03-07 13:03:51 UTC
This sounds like it should be fixed by the same fix for bug #46038, i.e. to fix that bug we don't include the "page styles" in the temp document we use to generate the rtf from, and this bug sounds like that the rtf import part of the paste into calc doesn't understand the "header text in page styles" stuff, which isn't surprising as that's an illadvised extension to rtf.

If I'm wrong, and this is still reproducible with 3.5.1, reopen and assign it to me.

*** This bug has been marked as a duplicate of bug 46038 ***
Comment 4 sasha.libreoffice 2012-03-14 06:16:21 UTC
I can not reproduce it in 3.5.1.2 on Fedora
Appears that fixed

Thanks for fixing it!
Comment 5 Caolán McNamara 2012-03-14 07:50:43 UTC
*** Bug 47274 has been marked as a duplicate of this bug. ***