Download it now!
Bug 47274 - EDITING: Crash when copy/paste table with data from Writer
Summary: EDITING: Crash when copy/paste table with data from Writer
Status: RESOLVED DUPLICATE of bug 46038
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-03-13 05:05 UTC by Timur
Modified: 2012-03-14 10:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash when Paste table with data from Writer to Calc ODT (14.33 KB, application/vnd.oasis.opendocument.text)
2012-03-13 05:05 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2012-03-13 05:05:43 UTC
Created attachment 58366 [details]
Crash when Paste table with data from Writer to Calc ODT

I'm experiencing a Crash when copy/paste table WITH DATA from Writer to Calc.
I attached Writer document with the particular table that causes crash, if copied to Calc. 

Previously, there was Bug 37429 - EDITING: Crash when  copy / paste table from Writer (EMPTY table) and it's fixed, but it doesn't seem releted.

I tested with LO 3.5.0 on Win 7 64bit an beta Ubuntu 12.04.
Comment 1 Roman Eisele 2012-03-14 01:09:45 UTC
NOT reproducible neither with
-- LibreOffice 3.4.5 (OOO340m1, Build:502) nor with
-- LibreOffice 3.5.1.2 (Build-ID: dc9775d-05ecbee-0851ad3-1586698-727bf66)
both running on MacOS X 10.6.8 and both with German langpack installed.

What I did:
I opened the sample file, clicked into the table, pressed Cmd-A, then Cmd-C, then selected 'New Spreadsheet' from File > New, then pressed Cmd-V. (Cmd has on MacOS the same function as Ctrl or Strg on Windows.) Voila!

What has happened:
No crash; the table is copied completely into the spreadsheet; the layout is not perfect, but all data are present.

@Timur:
Could you please give the exact steps you use to reproduce the bug? Am I doing something different?

This could also be an OS-related bug ... maybe something 64bit specific?
Comment 2 Timur 2012-03-14 07:15:18 UTC
I confirm the crash and ask kindly you and others to test on some other system.
I opened the sample file, clicked into the table, pressed Ctrl-A twice to select the whole table, then Ctrl-C to copy it, then selected 'New Spreadsheet' from File > New, then pressed Ctrl-V. Crash. 
I tested with LO 3.5.0 on Win 7 64bit and beta Ubuntu 12.04. 32bit.
Comment 3 Caolán McNamara 2012-03-14 07:50:43 UTC
I suspect, because the source document has a footer, that this is a duplicate of bug 46038, which is now fixed in 3.5.1.

If I'm wrong, and this still crashes in 3.5.1 let me know

*** This bug has been marked as a duplicate of bug 45637 ***
Comment 4 Timur 2012-03-14 10:20:07 UTC
It looks like that. When I removed header and footer in Writer document, it works fine.

*** This bug has been marked as a duplicate of bug 46038 ***