Bug 45647 - FORMATTING Format Paintbrush Cannot Be Used Across Multiple Documents
Summary: FORMATTING Format Paintbrush Cannot Be Used Across Multiple Documents
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: x86 (IA32) Windows (All)
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Clone-Formatting
  Show dependency treegraph
 
Reported: 2012-02-05 03:51 UTC by Zoltan Laszlo
Modified: 2018-10-08 22:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltan Laszlo 2012-02-05 03:51:55 UTC
I'd like to mention three Format Paintbrush issues (I am not sure, whether these are bugs or missing/incomplete features):

1. Format Paintbrush does not seem to transfer attributes outside the open document. If I open a two documents, copy the attributes from a piece of text for example, and then move to the other document (of the same type, e. g. two presentations) I can not apply the attributes in the second document. The same happens in Writer, too.

2. Format Paintbrush does not copy language settings (language and hyphenations, at last language).

3. Format Paintbrush applies attributes, but on save and reopen paragraph indent reset themselves to some parameters of unknown origin. Could this be related to MSOff 2010 compatibility issues?
Comment 1 sasha.libreoffice 2012-03-16 08:49:20 UTC
Thanks for bugreport
1. This if feature. Each window has it's own brush.
2. It is a bug
3. Something very interesting. Please, write step-by-step instruction how to reproduce this bug, or attach document that demonstrates this bug.

PS: IMHO LibreOffice users prefer using styles instead of Format Paintbrush for formatting. Styles have many advantages comparing to Format Paintbrush.
Comment 2 Joel Madero 2012-10-23 19:13:44 UTC
I am going to confirm #1 as an enhancement request.

#2 looks solved as Sasha has a link to a bug that is resolved. 

#3: should be a new bug report. We don't like combining bugs as it makes it much more difficult to track and fix bugs. If it's still a problem please open a new bug, describe the steps to reproduce and provide a sample document that we can test on that you have seen the issue.

Edited title to reflect only bug #1, also prioritizing:

Enhancement: This is an enhancement request, not a bug

Importance: Low - not many users use the format paintbrush, for those who do, they would only see the problem if you are trying to do something very specific (use across documents). Furthermore, workaround is relatively simple, just set some text to the same settings and use format paintbrush internally on the second document.


Best Regards,
Joel