Bug 45781 - [RFE] Replacing an image in writer
Summary: [RFE] Replacing an image in writer
Status: RESOLVED DUPLICATE of bug 82496
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-08 07:02 UTC by Nicolas Mailhot
Modified: 2016-01-15 12:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Mailhot 2012-02-08 07:02:04 UTC
A bitmap image in writer can have a lot of metadata (size, position, target, alternate name, etc)

However once the image is inserted you may notice problems in it and need to replace it.

Right now that requires removing the old image, inserting a new one, and re-typing the whole metadata (if you can retype it all by memory without errors)

It would be much user-friendly to be able to just select the image, and have a replace entry in the contextual menu
Comment 1 sasha.libreoffice 2012-02-22 05:29:18 UTC
For be able change picture with saving all meta-information, paste pictures as link. (Insert->Picture->From file, and option "Link" on bottom)
Comment 2 Nicolas Mailhot 2012-02-22 06:21:28 UTC
That requires a special filesystem structure and makes the document difficult to share

This RFE is about replacing pictures on any document opened in writer, regardless of how the pictures were inserted in the first place.
Comment 3 Brian 2013-10-22 03:43:42 UTC
Still a problem here (LO 3.5.7.2). According to the email archives, this was a conscious developer decision:

http://article.gmane.org/gmane.comp.documentfoundation.libreoffice.user/13940

There's an old extension that reimplements this feature as a toolbar button, but it is lacking (e.g., it doesn't seem to allow "Undo" or CTRL-Z):

http://extensions.services.openoffice.org/project/ChangePicture

IMO, this feature should be (re?)introduced to the context-sensitive menu, and to the Picture toolbar.
Comment 4 Oliver Specht (CIB) 2016-01-15 12:14:44 UTC

*** This bug has been marked as a duplicate of bug 82496 ***