Bug 82496 - change picture option is not available in libreoffice writer
Summary: change picture option is not available in libreoffice writer
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: x86 (IA32) Windows (All)
: medium enhancement
Assignee: jeyli
QA Contact:
URL:
Whiteboard: target:4.4.0
Keywords: difficultyBeginner, easyHack, skillCpp
: 45781 73728 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-08-12 09:15 UTC by Prathapmuruganandam
Modified: 2016-01-15 12:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Change picture option is not available while rightclicking the picture (252.50 KB, image/jpeg)
2014-08-12 09:15 UTC, Prathapmuruganandam
Details
Change picture option is not available while rightclicking the picture. (252.50 KB, image/png)
2014-08-12 09:18 UTC, Prathapmuruganandam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Prathapmuruganandam 2014-08-12 09:15:25 UTC
Created attachment 104478 [details]
Change picture option is not available while rightclicking the picture

When i try to change the picture by clicking the current picture there is no option available for changing the picture.
Comment 1 Prathapmuruganandam 2014-08-12 09:18:45 UTC
Created attachment 104485 [details]
Change picture option is not available while rightclicking the picture.
Comment 2 Caolán McNamara 2014-08-28 13:36:20 UTC
*** Bug 73728 has been marked as a duplicate of this bug. ***
Comment 3 Caolán McNamara 2014-08-28 13:40:40 UTC
Setting as an easy-hack: how-to...

In sd/source/ui/app/popup2_tmpl.src we have ITEM_SAVE_GRAPHIC which is the impress/draw menu. To get the menu to appear in writer it should be to case to add it to sw/source/ui/app/mn.src in MN_GRF_POPUPMENU and then the "sw" parts of this example http://cgit.freedesktop.org/libreoffice/core/commit/?id=44faceac60f9046e4827290a85f790a46ed1e227 shows the right places to handle the resulting "SID_CHANGE_PICTURE" id
Comment 4 Commit Notification 2014-09-09 09:07:47 UTC
Jennifer Liebel committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=24077ffc063990f9de11c6819432219a59d809f8

fdo#82496: Change picture option by rightclicking



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Mike §chinagl 2014-12-20 21:51:22 UTC
This bug fix comes with LibreOffice 4.4 (release notes https://wiki.documentfoundation.org/ReleaseNotes/4.4) 


Writer now has an option to change the currently selected image to another graphic via the context menu, reaching feature parity with Impress and Draw. 

See a graphic of the work:
https://wiki.documentfoundation.org/File:Writer-change-picture.png
Comment 6 Robinson Tryon (qubit) 2015-12-15 23:35:42 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyBeginner SkillCpp )
[NinjaEdit]
Comment 7 Oliver Specht (CIB) 2016-01-15 12:14:44 UTC
*** Bug 45781 has been marked as a duplicate of this bug. ***