Bug 73728 - Bundle "Change Picture" extension with LO writer
Summary: Bundle "Change Picture" extension with LO writer
Status: RESOLVED DUPLICATE of bug 82496
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-17 08:40 UTC by Roland Seuhs
Modified: 2014-08-28 13:36 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
The "Change Picture" extension downloaded from extensions.openoffice.org (14.25 KB, application/vnd.openofficeorg.extension)
2014-01-17 08:40 UTC, Roland Seuhs
Details
Adapted version of extension for Libreoffice (added SVG-support) (14.09 KB, application/vnd.openofficeorg.extension)
2014-01-17 09:04 UTC, Roland Seuhs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roland Seuhs 2014-01-17 08:40:44 UTC
Created attachment 92265 [details]
The "Change Picture" extension downloaded from extensions.openoffice.org

In LO Presenter there is a "change picture" functionality, which allows you to change a picture without having to redo all the adaptations (size, cropping, etc.)
IIRC, there is also a similar option in Microsoft Word.

In OO/LO Writer that functionality is already available as an extension, see http://extensions.openoffice.org/en/project/change-picture

I think this functionality should be integrated into the default installation because:

- it is even more useful in Writer than in Presenter because in Writer I need to do much more adaptations to fit it to the text
- MS Word has it and people will expect it in LO Writer as well (search for "Libreoffice exchange picture" and you get a lot of unhappy people that want that feature)

In the extension, SVG-files are missing in the file dialog (because it was written for OO without SVG-support), therefore the filter in the file-dialog should also be extended to include SVG-files for OO. (I have tested the extension by dragging an SVG-file into the file-dialog and it works fine with SVG-files)

Attachment: The extension downloaded today from the above URL
Comment 1 Roland Seuhs 2014-01-17 09:04:09 UTC
Created attachment 92269 [details]
Adapted version of extension for Libreoffice (added SVG-support)

Added SVG support to extension
Comment 2 Roland Seuhs 2014-01-17 09:12:47 UTC
I have forked the abovementioned extension to add SVG support (it seems abandoned and also not available in the libreoffice extension system)

However I was not able to get an account for the libreoffice extension system, therefore I was not able to publish it there.
Comment 3 Jean-Baptiste Faure 2014-01-19 17:49:48 UTC
Comment on attachment 92265 [details]
The "Change Picture" extension downloaded from extensions.openoffice.org

fixing mime type
Comment 4 Caolán McNamara 2014-08-28 13:36:20 UTC
I think we should just add the functionality into writer

*** This bug has been marked as a duplicate of bug 82496 ***