Bug 45784 - Removing empty lines after a table
Summary: Removing empty lines after a table
Status: RESOLVED DUPLICATE of bug 60967
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-02-08 07:24 UTC by Nicolas Mailhot
Modified: 2017-06-27 08:57 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
testcase (9.46 KB, application/vnd.oasis.opendocument.text)
2012-09-11 14:59 UTC, Nicolas Mailhot
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Mailhot 2012-02-08 07:24:05 UTC
Currently placing the insertion point to the bottom right of a table, and pressing delete, does not remove the empty lines following the table

This makes it impossible to cull the last empty line when a footer is composed by a single table. That useless empty line after the table screws up formatting by taking space (yes I know you can set the line size to 2pt ; that's a band-aid, and not a good band-aid – when exporting to .doc the 2pt paragraph is expanded and screws up formatting tome more)

There should be an easy intuitive way to remove empty lines after tables
Comment 1 manj_k 2012-02-08 10:06:04 UTC
You might try the default shortcut key
<Ctrl+Shift+Delete>
[Category: Edit · Function: Delete to End of Sentence].
Comment 2 Nicolas Mailhot 2012-02-09 05:56:01 UTC
Does it work on your system? Because it does not here (and besides, that's not as discoverable as place cursor at the end of a table and press delete)
Comment 3 sasha.libreoffice 2012-05-16 02:42:04 UTC
Thanks for bugreport
> <Ctrl+Shift+Delete>
Works well in document, but produces problem with saving document. So, do not save such document to doc format.
Comment 4 Joel Madero 2012-09-09 03:31:27 UTC
Please provide a test document for us to look at. Once an attachment is made change status back to UNCONFIRMED and I'll confirm the bug and hopefully a dev can take a look at it soon. Marking as NEEDINFO in th mean time. Thanks for reporting
Comment 5 Nicolas Mailhot 2012-09-11 14:59:41 UTC
Created attachment 66977 [details]
testcase
Comment 6 sasha.libreoffice 2012-09-11 15:32:22 UTC
Thanks for attachment
If table is in footer, then it looks like we can reduce footer hight so that empty line becomes outside of page. I see no problem with saving such document to doc format.

What about Ctrl-Shift-Del: it works, but export filters do not expect situation that after table is no paragraph. And produce corrupted odt and doc files. So, export filters should be improved first.

Personally I think that ability of deleting line after table just by use Del or Backspace is good idea
Comment 7 manj_k 2012-11-22 09:18:53 UTC
Marked as NEW.
Comment 8 Joel Madero 2012-11-25 04:46:36 UTC
Yeah I've always thought this also (what Sasha said). Pressing Del at last row should probably delete the row but this is by design so it should be an enhancement request, marking as such.

Marked as low as there is a solution (cntrl + shift + delete) this is how LibO (as well as other office suites) work
Comment 9 Vitaliy 2012-11-28 09:20:42 UTC
I need this trouble to be fix, too. I have it on 3.6.3 This is my question on AskLibre http://ask.libreoffice.org/question/7412/how-i-can-delete-empty-line-after-table-in-writer/
Comment 10 Joel Madero 2012-11-28 14:49:59 UTC
As I said, it's not really trouble, this is by design and it's consistent across every office suite that I know of. 

<Ctrl+Shift+Delete> will do the trick. I doubt that this one will be changed any time soon so it's better to get used to the current method of deleting rows of tables
Comment 11 bugquestcontri 2013-02-13 12:38:01 UTC
I am sorry to say so but the ctrl+shift;del trick doesn't work. I just tried all remedies listed in http://ask.libreoffice.org/en/question/7412/how-i-can-delete-empty-line-after-table-in-writer/

This bug is an ugly one as it doesn't allow a proper alignment of a table at the end of the last page. Therefore it should not be regarded as an enhancement but as a bug. Even if MSO has the same bug (I read this somewhere above but  could not verify ) the problem should be solved.

LibOVersion Version 3.6.5.2 (Build ID: 5b93205)
XP prof / SP3
Comment 12 Joel Madero 2013-02-14 06:30:28 UTC
you have to highlight the row for it to work
Comment 13 waynedpj 2013-02-27 18:34:08 UTC
(In reply to comment #12)
> you have to highlight the row for it to work

using Libre Office version 3.6.4.3 on amd64 Gentoo, <Ctrl+Shift+Delete> does nothing on my own docs nor the "testcase" attached to this thread, whether the row is highlighted or not.  any other workarounds besides super small font size, and any chance on a fix?  seems like it is also being reported as not working in 4.0 as well:

http://ask.libreoffice.org/en/question/7412/how-i-can-delete-empty-line-after-table-in-writer/

thanks
Comment 14 Jochen 2013-03-20 21:37:32 UTC
Bug is still present in LO 4.0.1, ie removing empty line(s) after a table via strg+shift+del isn´t possible.
Comment 15 Harald Koester 2013-03-21 11:34:52 UTC
<Ctrl+Shift+Delete> works for me with LO versions 3.5.3, 3.5.7, 3.6.0 and 3.6.2. It does not work with versions 3.6.3 and 3.6.4. 

Version 3.6.2:
But if you delete the 'empty' paragraph after the table, then save and reopen again the text document the just deleted paragraph is present again. So LO adds the paragraph either during saving or opening the file. But, if a table is inside the footer - like in the attached document - LO does not add a paragraph during saving or opening.

In reply to comment 6:
I agree with the proposal of Sasha, that there should be a more intuitive possibility (<Del>, <Backspace>) to delete an 'empty' paragraph after a table. I think many users do not know the short cut <Ctrl+Shift+Delete>.
Comment 16 John Smith 2013-03-25 18:44:23 UTC
Shift+Ctrl+Delete does not delete the following paragraph, or behave at all as described in the Help files, when the cursor is at the end of a table, in any of the release 4.0 versions.
Comment 17 Miklos Vajna 2013-04-03 08:30:46 UTC
Regarding "can't delete last empty paragraph after table in footnote using ctrl-shift-delete", it's indeed a regression in 4.0, it worked on 3.6. git bisect says:

af4b6c94c68b5f67b931cde8d0acda6ec8b288bb is the first bad commit
commit af4b6c94c68b5f67b931cde8d0acda6ec8b288bb
Author: Michael Stahl <mstahl@redhat.com>
Date:   Wed Sep 19 20:47:48 2012 +0200

    rhbz#689053: fix crash following delete at last table cell:
    
    The IsSelOvr() in SwCrsrShell::Combine() detects that the PaM with mark
    in the last table cell and point ouside the table is invalid, but
    unfortunatley restores the wrong position, which does not actually
    correct the PaM; the deletion on the invalid PaM then removes the
    last SwTxtNode in the document, which leads to crash later.
    
    Change-Id: Ib2ae0b54e6c15dbe5b6811d8696531bf2022e1a4

Michael, any ideas?

Thanks.
Comment 18 Michael Stahl (allotropia) 2013-04-03 16:56:31 UTC

*** This bug has been marked as a duplicate of bug 60967 ***
Comment 19 m.a.riosv 2015-11-18 22:23:54 UTC
*** Bug 95907 has been marked as a duplicate of this bug. ***