Download it now!
Bug 60967 - EDITING: Table shortcut Ctrl+Shift+Del ineffective cannot delete following paragraph of a table
Summary: EDITING: Table shortcut Ctrl+Shift+Del ineffective cannot delete following pa...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: high minor
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: bibisected40 target:4.1.0 target:3.6....
Keywords: regression
: 45784 (view as bug list)
Depends on:
Blocks: 42504
  Show dependency treegraph
 
Reported: 2013-02-16 19:50 UTC by Olivier Hallot
Modified: 2019-07-15 18:39 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
bibisect40 log (2.94 KB, text/plain)
2013-02-16 19:57 UTC, Jorendc
Details
Can't delete blank paragraph after table (9.13 KB, application/vnd.oasis.opendocument.text)
2013-06-25 23:58 UTC, Marcos Mello
Details
Problematic doc (9.03 KB, application/vnd.oasis.opendocument.text)
2014-02-06 18:32 UTC, Brice Maron
Details
example for bug (20.39 KB, application/vnd.oasis.opendocument.text)
2014-02-06 19:03 UTC, Jochen
Details
example-bug60967 (17.99 KB, application/vnd.oasis.opendocument.text)
2014-03-20 09:36 UTC, Miguel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2013-02-16 19:50:31 UTC
Shortcut key combination Ctrl+Shift+Del does not delete the paragraph that follows a table.

In the past, if you place the cursor in the bottom-rightmost cell of table and press the shortcut, the paragraph that immediately follows the table is deleted.

The situation gets critical if the table is in the footer/header or bottom of a page or frame because you get extra and unwanted space.

Note1: The shortcut Alt+Enter in the top-leftmost cell of a table insert a paragraph just before the table and is working well.

Note 2: This shortcut was documented in the help but I could not find it anymore.
Comment 1 Jorendc 2013-02-16 19:56:25 UTC
As discussed on IRC, I can reproduce this problem using Linux Mint 14 x64.

Following [1] I mark this bug as 'minor high':
* Minor: prevent user to use a feature
* High: regression

[1] https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg
Comment 3 Jorendc 2013-02-16 19:58:34 UTC
@Michael: following this commit 'rhbz#689053: fix crash following delete at last table cell:' http://cgit.freedesktop.org/libreoffice/core/commit/?id=af4b6c94c68b5f67b931cde8d0acda6ec8b288bb I add you to CC.
Comment 4 Jan Holesovsky 2013-02-26 09:40:39 UTC
Olivier: Thank you for the report!  Would be great to attach a minimal test document the next time too, so that everyone touching the bug does not have to create his / her own :-)
Comment 5 Jan Holesovsky 2013-02-26 10:37:08 UTC
Joren: Thank you for the analysis, great work!  Confirmed, the commit

http://cgit.freedesktop.org/libreoffice/core/commit/?id=af4b6c94c68b5f67b931cde8d0acda6ec8b288bb

causes this, assigning.
Comment 6 Michael Stahl (CIB) 2013-04-03 16:56:31 UTC
*** Bug 45784 has been marked as a duplicate of this bug. ***
Comment 7 Michael Stahl (CIB) 2013-05-16 22:19:04 UTC
oops, you are right, it was even documented
in the "Shortcut Keys for Tables in LibreOffice Writer":

"If no whole cell is selected and the cursor is at the end of the table, the following sentence from below the table will be deleted and the remainder of that paragraph will be moved into the last table cell. If an empty line follows the table, the empty line will be deleted."

this part of the help does not make sense to me: "and the remainder of that paragraph will be moved into the last table cell"... what is the point in doing that? also, this doesn't work in LO 3.5.7: on Undo the previous text is not restored properly.

... how about the following:
  "If no whole cell is selected and the cursor is at the end of the table, the paragraph following the table will be deleted, unless it is the last paragraph in the document."

since this really is a special case anyway, i don't see much reason to muck about with this weird delete-a-sentence-then-merge-the-rest-of-the-para stuff.

have pushed a commit implementing the above to master.

hmm... playing with it a bit more it appears my commit in comment #5
also fixed a related problem: cursor in first cell of table,
Ctrl+Shift+Backspace would remove the paragraph from the cell,
leaving a completely empty cell behind!  surely that's broken...
Comment 8 Commit Notification 2013-05-16 22:24:22 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=38b06c661559e6eca60e2c4a4a3637b8293307b2

fdo#60967: re-enable deletion of paragraph following table



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2013-05-17 07:32:14 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b4aeed3b8dc402d72ae9a8b928babc228e2ead7a&h=libreoffice-3-6

fdo#60967: re-enable deletion of paragraph following table


It will be available in LibreOffice 3.6.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2013-05-17 07:32:51 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eebd5646baa7075b486563b84a2fad97c829fb2c&h=libreoffice-4-0

fdo#60967: re-enable deletion of paragraph following table


It will be available in LibreOffice 4.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Michael Stahl (CIB) 2013-05-17 22:20:03 UTC
since i heard no objections to comment #7 i've adapted
the help content to the new implementation now.
Comment 12 Commit Notification 2013-05-17 22:22:22 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=7cbed0ad307c87de550f032046a39375979efe76

fdo#60967: adapt help content to new implementation



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 bugquestcontri 2013-05-19 08:22:14 UTC
Thanks to Michael Stahl!!!!
Comment 14 Marcos Mello 2013-06-25 19:09:13 UTC
4.0.4 on Windows here.

Why not delete if "it is the last paragraph in the document"? I have a documment here that is just one full page big table. Still didn't find a way to delete the useless empty second page that consists in just one blank paragraph!
Comment 15 Jochen 2013-06-25 20:39:17 UTC
Hi Marcos,

please post your document as an attach
Comment 16 Marcos Mello 2013-06-25 23:58:09 UTC
Created attachment 81434 [details]
Can't delete blank paragraph after table
Comment 17 Marcos Mello 2013-06-25 23:58:36 UTC
Yes, it matches "if it is the last paragraph in the document"... but in this case what to do?
Comment 18 Johnny Baloney 2013-09-12 20:38:01 UTC
This bug is back.

3.6.0.4 -> works OK

4.0.3.3 -> does NOT work

4.1.1.2 -> does NOT work

Tested on Debian GNU/Linux 7.0 (wheezy) 64bit
Comment 19 severoraz 2013-12-09 01:40:49 UTC
This seems to work in LibreOfficeDev 4.2.0.0.beta2 however with the keyboard shortcut Control+Delete instead of Control+Shift+Delete. Can anybody confirm this?
Comment 20 Thomas Hackert 2013-12-09 17:22:51 UTC
Hello Olivier, *,
I can confirm Comment 19 from wolter6, that it seems to be fixed in LO Version: 4.2.0.0.beta2 Build-ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d on Debian Testing AMD64 with installed Germanophone lang- as well as helppack, when you use <Ctrl>+<Del> instead of <Ctrl>+<Shift>+<Del> :) But this problem still exists in Version: 4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a on the same system, where none of them works ... :(
@Olivier: Would you be so kind to test it on your system again, if it is fixed for you as well?
TIA
Thomas.
Comment 21 Jochen 2013-12-09 17:40:00 UTC
Hi Michael,

what do you mean:
1) Set Status to "new"?
2) Set Version to "4.2.0"?
Comment 22 Peter Lairo 2014-01-20 10:26:51 UTC
4.1.4.2 -> does NOT work

I have a table in the footer, and there is an empty line above and below the table that I cannot get rid of. This makes the footer needlessly tall.
Comment 23 Michael Stahl (CIB) 2014-01-30 23:12:42 UTC
can't reproduce this with master or 4.1.4 - can somebody attach a document where it does not work?
Comment 24 Brice Maron 2014-02-06 18:32:41 UTC
Created attachment 93552 [details]
Problematic doc

Hi...
I have the same problem, .. i'm unable to remove the last page of a pretty simple document  :

i'm on archlinux using 
Version: 4.1.4.2
Build ID: 4.1.4.2 Arch Linux build-3

i'll add my doc as an attach.


i've tried the ctrl+shift+del or ctrl+del but it does not seems to work...
Comment 25 Jochen 2014-02-06 18:38:41 UTC
Hi Brice,

IMHO your document isn´t a good example because the last paragraph can´t be deleted.
I will try to create a document.
Comment 26 Jochen 2014-02-06 19:03:08 UTC
Created attachment 93554 [details]
example for bug
Comment 27 Jochen 2014-02-06 19:04:39 UTC
Bug still exits in LO 4.1.3
Comment 28 Robert Großkopf 2014-02-06 19:55:36 UTC
(In reply to comment #25)
> Hi Brice,
> 
> IMHO your document isn´t a good example because the last paragraph can´t be
> deleted.
> I will try to create a document.

You can delete the last paragraph, when there is a table in the document - not the last paragraph of the document at all.
Works up to the first versions of LO 3.6 - don't know when it is broken, but have tested with some versions up to LO 3.6.0.0beta3 (works) and versions beginning with LO 3.6.6.2 (doesn't work).
Then it begins to work (with Ctrl+Del) again with LO 4.2.0.0alpha1+ (alpha0 doesn't work) and ends with LO 4.2.0.0beta2 (4.2.0.rc1 doesn't).

Seems to be broken again. Can't find any other version where it works. Have all RCs from LO 4.* installed parallel on my system.

My System: OpenSUSE 12.3 64bit rpm Linux.
Comment 29 Miguel 2014-03-20 09:35:51 UTC
I have created another useful example  (example-bug60967.odt). The issue is proven as an inability to make the document 1 page long, even though the contents fit 1 page.
Comment 30 Miguel 2014-03-20 09:36:27 UTC
Created attachment 96086 [details]
example-bug60967
Comment 31 Commit Notification 2014-04-27 09:49:17 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f5fb361df94449850a83be3b412f68e1f9b949c5

fdo#60967: fix deletion of paragraph following table



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 32 Commit Notification 2014-04-30 08:22:11 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d1782bfa94e1f526b90587b74f51b236b3b774c7&h=libreoffice-4-2

fdo#60967: fix deletion of paragraph following table


It will be available in LibreOffice 4.2.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 33 Michael Stahl (CIB) 2014-05-02 11:10:45 UTC
fixed the empty-paragraph case from comment #26.

for the paragraph at end of document case (comment #24 and #30)
i've done a bit of testing and found that there are quite a
few things that break if the document does not end with a paragraph:

- Load Styles crashes
- Insert->Footnote then Insert->Index (in the table cell) crashes
- Select All has numerous problems (and probably requires a special
  handling similar to table-at-start-of-document, cf. bug 37606),
  Select All then Delete will crash too
- ODF export works but ODF import adds a trailing paragraph
- Word is apparently unable to end the document with a table,
  so there's an interop issue
- save as DOC, reopen with LO the table is gone

so i am resolving this bug as FIXED, please file a new bug for
the case at document end.
Comment 34 Commit Notification 2015-08-17 19:21:48 UTC
Varun committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c5f2122f66cfbb1186fe8d77854edbcdccad9841

Added test for tdf#60967 deleting paragraph following a table

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 35 Axel Braun 2018-04-26 16:31:52 UTC
I'm running 6.0.3.2 and still have the issue that I cant delete a blank page following on a table
Comment 36 Xisco Faulí 2018-04-27 07:30:45 UTC
(In reply to Axel Braun from comment #35)
> I'm running 6.0.3.2 and still have the issue that I cant delete a blank page
> following on a table

Dear Axel Braun,
This bug has been in RESOLVED FIXED status for more than 6 months.
If the issue is still reproducible with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/, please report a new issue in https://bugs.documentfoundation.org/enter_bug.cgi providing, if     needed, the steps and documents to reproduce it.
Thanks for your understanding and collaboration.
Closing as RESOLVED FIXED