Bug 45895 - Writer FILESAVE: validation of odt not passed: attribute "text:start-value" has a bad value: "0" does not satisfy the "positiveInteger" type
Summary: Writer FILESAVE: validation of odt not passed: attribute "text:start-value" h...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: odf odf_validation
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-10 06:58 UTC by sasha.libreoffice
Modified: 2012-09-16 06:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test case (39.14 KB, application/vnd.oasis.opendocument.text)
2012-02-10 06:58 UTC, sasha.libreoffice
Details
source document (35.00 KB, application/msword)
2012-02-10 06:59 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2012-02-10 06:58:41 UTC
Created attachment 56867 [details]
test case

document not passed validation on http://odf-validator.rhcloud.com/
error is:
bug_image_conv1.odt/styles.xml[142,140]: Error: attribute "text:start-value" has a bad value: "0" does not satisfy the "positiveInteger" type

used 3.6.0 master 97fdf02-9eed775-f061262
Comment 1 sasha.libreoffice 2012-02-10 06:59:24 UTC
Created attachment 56868 [details]
source document
Comment 2 Florian Reisinger 2012-05-20 05:51:34 UTC
*** Bug 45897 has been marked as a duplicate of this bug. ***
Comment 3 Joel Madero 2012-09-10 20:29:00 UTC
I'm marking this as a duplicate. 

@Sasha - if you open incredibly similar bugs please do the following:

a) acknowledge that it's similar
b) point out other similar bugs
c) most importantly, say exactly how it is different

*** This bug has been marked as a duplicate of bug 45700 ***
Comment 4 Michael Stahl (CIB) 2012-09-14 13:15:26 UTC
this is certainly not a duplicate of 45700 or of 45897,
which are obviously about completely different errors
(see also my rant on the qa mailing list).

i can't reproduce this problem on current 3.5/3.6/master,
so i'll resolve it WORKSFORME
Comment 5 sasha.libreoffice 2012-09-14 13:50:56 UTC
I just reproduced problem in 3.5.5 and 3.6.1 on Fedora 64 bit
I opened doc from second attachment, saved as odt, unzipped and in file styles.xml found line text:start-value="0" on line 240
Comment 6 Michael Stahl (CIB) 2012-09-14 20:34:31 UTC
aha... hmm... further investigation reveals:

the text:start-value attribute is tricky because it has different
types, depending on the element on which it occurs; see
http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part1.html#__RefHeading__1419160_253892949

in the first attachment, the following elements have
text:start-value="0":

 text:list-level-style-number  positiveInteger
 text:outline-level-style      positiveInteger
 text:notes-configuration      nonNegativeInteger

while in my document saved by version 3.5.5 there are
2 elements of this in line 240 and 241

 text:notes-configuration      nonNegativeInteger

so for text:list-level-style-number and text:outline-level-style
the 0 value is an error, but for text:notes-configuration it is valid

=> no problem after all :)
Comment 7 sasha.libreoffice 2012-09-16 06:10:50 UTC
Thanks for additional investigation.
As I understand, status should be NotABug because it is validator's fault, and LO saves odt correctly. Changing to NotABug.