Download it now!
Bug 45897 - Writer FILESAVE: validation of odt not passed: Document root element "math", must match DOCTYPE root "null"
Summary: Writer FILESAVE: validation of odt not passed: Document root element "math", ...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.5.0 RC2
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: odf odf_validation
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-10 07:24 UTC by sasha.libreoffice
Modified: 2012-09-13 11:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
test case (30.65 KB, application/vnd.oasis.opendocument.text)
2012-02-10 07:24 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2012-02-10 07:24:28 UTC
Created attachment 56876 [details]
test case

document not passed validation on http://odf-validator.rhcloud.com/
errors is:
math_newline_issue.odt/Object 1/content.xml[2,6]: Error: Document is invalid: no grammar found.
math_newline_issue.odt/Object 1/content.xml[2,6]: Error: Document root element "math", must match DOCTYPE root "null".

used 3.6.0 master 97fdf02-9eed775-f061262
Comment 1 Florian Reisinger 2012-05-20 05:51:34 UTC
IMHo this is a duplicate....

*** This bug has been marked as a duplicate of bug 45895 ***
Comment 2 sasha.libreoffice 2012-05-21 02:05:06 UTC
It is not duplicate. Bugs is completely different
Comment 3 Joel Madero 2012-09-10 20:26:51 UTC
This looks like a dupe to me...
Comment 4 Michael Stahl (CIB) 2012-09-13 11:10:58 UTC
hmm that "no grammar found" error sounds suspicious, like that validator
is missing some schema files...

LO Math doesn't appear to write a DOCTYPE into MathML documents.

quickly skimming these, it seems to me that a DOCTYPE declaration
is entirely optional for MathML documents:

http://www.w3.org/TR/REC-MathML/appendixA.html
http://www.w3.org/TR/MathML2/appendixa.html
http://www.w3.org/TR/MathML3/appendixa.html

(and i don't even know which version LO Math is supposed to support)

so based on that i'd say NOTABUG

also, this is in no way a duplicate of any other bug that i've seen.