Download it now!
Bug 46057 - FORMULAEDITOR: Unable to input into formula editor
Summary: FORMULAEDITOR: Unable to input into formula editor
Status: RESOLVED DUPLICATE of bug 46071
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 47180 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-14 11:27 UTC by Janis Petersons
Modified: 2012-04-03 20:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
the Math window (63.62 KB, image/png)
2012-02-14 11:27 UTC, Janis Petersons
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Janis Petersons 2012-02-14 11:27:35 UTC
Created attachment 57045 [details]
the Math window

Problem description: Unable to input anything with the formula editor.  

Steps to reproduce:
1. open Math
2. press any key on keyboard

1. open Writer
2. double-click a formula or insert formula 

Current behavior: When using Math, keyboard input is ignored, editing field has no focus (no blinking cursor) and there appears to be no way of gaining it. When in Writer, the formula input field does not appear. 

Expected behavior: Ability to input. 

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.20 (KHTML, like Gecko) Chrome/19.0.1036.7 Safari/535.20
Comment 1 Temachtiani 2012-02-16 16:13:38 UTC
It's not possible create new formulas or edit existing created in older versions.
Comment 2 Janis Petersons 2012-02-16 17:10:44 UTC
After downgrading to 3.4.5 problem persists, so a clean reinstall could probably fix it.
Comment 3 Temachtiani 2012-02-21 11:01:11 UTC
In Mac OS after upgrading to 3.5 version, even uninstalling and returning to previous version, the problem appear in this version too.
Comment 4 Janis Petersons 2012-02-21 12:05:50 UTC
To solve the problem, delete the installation folder and all Libre Office settings  folders (AppData on Windows,don't know about Mac).Then install 3.5.

As of posting this I have resolved the issue and am not certain that installing 3.4.5 and upgrading would replicate the problem.
Comment 5 addammo 2012-02-22 07:34:23 UTC
I had the same issue. I deleted all .libreoffice directory i found into .config and root directories and reinstalled libreoffice 3.5.0. Now the math module works again.
Comment 6 Urmas 2012-03-10 21:06:46 UTC
*** Bug 47180 has been marked as a duplicate of this bug. ***
Comment 7 Andrzej 2012-03-11 09:34:29 UTC
"To solve the problem, delete the installation folder and all Libre Office
settings  folders (AppData on Windows,don't know about Mac)" -thanks this work. Now all is right. Good Job.
Comment 8 dalobz 2012-04-03 18:52:11 UTC
See also bug 46573
Comment 9 dalobz 2012-04-03 20:14:48 UTC
See bug 46701 for instructions on how to resolve this issue.

*** This bug has been marked as a duplicate of bug 46071 ***