Download it now!
Bug 46107 - UI: Voiceover not announcing cell content or position
Summary: UI: Voiceover not announcing cell content or position
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: 49576 a11y-macOS
  Show dependency treegraph
 
Reported: 2012-02-15 07:06 UTC by Chris Blouch
Modified: 2013-07-28 21:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Blouch 2012-02-15 07:06:12 UTC
Problem description: 

Steps to reproduce:
1. Turn on Voiceover (Apple-F5)
2. Create new spreadsheet
3. Type something in a cell
4. Navigate the spreadsheet with arrows

Current behavior:
Column and row not announced and if we move to a cell with content, that is also not read.

Expected behavior:
Column and row information should be announced as the user navigates cells. When a cell has content it should also be announced. Eventually voiceover announces busy and then the app crashes.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/534.53.11 (KHTML, like Gecko) Version/5.1.3 Safari/534.53.10
Comment 1 Roman Eisele 2012-09-25 12:39:52 UTC
Thank you very much for your bug report!

I have tried to reproduce this issue in order to confirm it, following your steps. However, as far as I can tell,
* LibreOffice 3.5.7.1 and
* LibreOffice 3.6.2.1,
both on Mac OS X 10.6.8, do not show the problem -- it seems to be fixed!

* If I navigate to an empty cell, I get announced: “cell C7” etc.
* If I navigate to a cell containing some text, e.g. “apple”, I get announced:
  “apple, cell C7”

It does not make any difference if I use the mouse or the arrows to navigate the spreadsheet.


@ Chris Blouch:

Could you please test yourself a recent version of LibreOffice (3.5.6 or 3.6.1 or newer) and check if I have missed something or if this issue is really fixed?

(It is also possible that there is a problem with the Mac OS X version -- I use 10.6.8, you have used 10.7.3 for your test, but I don’t hope so; if necessary,
we must test this later.)
Comment 2 Roman Eisele 2012-11-18 15:42:35 UTC
@ Alex Thurgood:

Hi Alex -- IIRC you have some experience with the MAC AT accessibility problems (you have filed bug 49576 - “Accessibility - MAC AT accessibility problems” ;-).
Could you please take a look at *this* bug?

According to my tests, it is already fixed in LibreOffice 3.5.7.1 and 3.6.3 or better, so we could close this bug as RESOLVED/WORKSFORME. But it would be very nice if you could double-check if my results are correct. (The original reporter did not answer to my question about the state of this bug, therefore I ask you to get a second opinion before closing the bug.)

Thank you very much!
Comment 3 steve -_- 2012-12-20 10:51:19 UTC
Roman: I tried verifying this bug, but I'm not sure if I'm doing the right stuff, since I have very little experience with VoiceOver.

I tried:

* turning on VoiceOver
* creating a new spreadsheet
* typing sth in a new cell
* navigating the spreadsheet with arrows

My observations
1. the OP writes that when navigating with arrows, cell column and row should be announced.
> that does not happen for me.
> it does announce that I'm on a textfield, but not which

2. More oddities (maybe another bug?): a text field is selected (D16) and that field also gets announced as being D16 textfield and editable. But when I move with the arrow keys (B9) the field I end on, does not get announced. Not sure if that is expected or intended.
http://cl.ly/image/443s24083K3S

3. OP writes that text in textfields should get read.
> when navigating to D7, no text is read. When I move around with the arrow keys, VoiceOver tells me "You are currently on Textfield, you can edit information bla bla bla" (loosely translated), but it does not announce column and row.

4. When I move around VoiceOver tells me, that I can navigate using ctrl + alt and arrow keys, but when I do that, nothing happens.

As I wrote, I thought this was an easy test, but it turns out, VoiceOver is rather difficult to grasp, if you are not used to it.

Hope this helps.
Comment 4 steve -_- 2012-12-20 11:54:24 UTC
Sorry forgot to mention, testing was done on OS X 10.8.2 and LO 3.6.4.3.
Comment 5 Alex Thurgood 2013-02-27 20:25:10 UTC
Confirming.
Mac OSX 10.8.2
Version 4.1.0.0.alpha0+ (Build ID: f5cde53719544c7445ab6fdb465e332ac5678b0)


Alex
Comment 6 Alex Thurgood 2013-02-27 20:27:27 UTC
VoiceOVer thinks that the table area is empty and announces it as such even when there is content in a cell.

Alex
Comment 7 Alex Thurgood 2013-02-27 20:31:19 UTC
Adding Stuart to CC FYI as he's dealing with some of the accessibility issues.

Alex
Comment 8 Boris Dušek 2013-07-28 09:28:47 UTC
This is fixed by patch provided in #54320. Not that the information spoken by VoiceOver is ideal (it behaves as if the cells had typing cursor active), but this specific issue is fixed.

Issue verified present without the patch on latest master on OS X 10.8.4 and fixed with the patch present on the latest master on OS X 10.8.4.
Comment 9 retired 2013-07-28 21:35:08 UTC
As Boris writes, the fix from https://bugs.freedesktop.org/show_bug.cgi?id=54320 should fix this here too. Setting to fixed.