Bug 54320 - ACCESSIBILITY: VoiceOver does not follow keyboard focus
Summary: ACCESSIBILITY: VoiceOver does not follow keyboard focus
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.6.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.2.0 target:4.1.1 target:...
Keywords:
Depends on:
Blocks: a11y-macOS
  Show dependency treegraph
 
Reported: 2012-08-31 12:26 UTC by Niklas Johansson
Modified: 2013-08-10 14:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Fix (1.37 KB, patch)
2013-07-27 18:36 UTC, Boris Dušek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Niklas Johansson 2012-08-31 12:26:20 UTC
Problem description: 
When you move through LibreOffice toolbars, dialogs etc using arrow and tab keys the VoiceOver cursor does NOT move with current focus. If this were to be fixed quite a few accessibility problems on Mac might be "worked around". Ex. On mac the tree controls used by Options-dialog, Navigator etc is not possible to navigate using VoiceOver cursor. If the currently selected item was reported to VoiceOver it would be possible to use the arrow keys to navigate. 
By the way at the moment Calc is totally unaccassible using VoiceOver this would not be the case if focus was reported.

Steps to reproduce:
1. Start LibreOffice any component will do but lets say Writer
2. Start VoiceOver cmd+F5 (if your on a laptop you might need to use fn+cmd+F5)
3. If a VoiceOver welcome message shows just press OK
4. Press F6 (fn+F6 on laptop) to move focus between the toolbars.

Current behavior:
Libreoffice moves focus between the toolbars and highlights the control in focus. But VoiceOver focus stays still.

Expected behavior:
VoiceOver focus moves with the changed keyboard focus.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_4) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1
Comment 1 V Stuart Foote 2013-02-13 15:47:02 UTC
Setting platform to OS X, and adding to tracking bug 55571 -- for you Roman.

Similar Narration/TTS AT issues for Windows and Linux, but should probably keep them separate since they all will have different QA and DEV actions.
Comment 2 Jorendc 2013-05-31 00:09:20 UTC
I can confirm this issue using Mac OSX 10.8.3 with LibreOffice 4.0.3.3.

Kind regards,
Joren
Comment 3 Boris Dušek 2013-07-27 18:36:42 UTC
Created attachment 83097 [details]
Fix

From the commit message:

The AXFocusedUIElementChanged notification must have the application object
as its parameter, as it is the application object whose AXFocusedUIElement
attribute value is changing (and because the docs say so).
Comment 4 Boris Dušek 2013-07-28 09:30:03 UTC
The previously attached patch also fixes #46107.
Comment 5 Boris Dušek 2013-07-28 17:23:09 UTC
Just submitted the patch to gerrit: https://gerrit.libreoffice.org/#/c/5155/
Comment 6 Commit Notification 2013-07-28 18:12:33 UTC
Boris Dušek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e9257fa0e642de2f1c79f2c80387334010812dab

fdo#54320: VoiceOver does not follow keyboard focus



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2013-07-28 18:57:54 UTC
Boris Dušek committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=37eb789055b3b079fc8f6784832822f85dab2d0e&h=libreoffice-4-1

fdo#54320: VoiceOver does not follow keyboard focus


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2013-07-28 18:58:12 UTC
Boris Dušek committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b9b452a570bea90f27082e5b70aedf9b8f9d421e&h=libreoffice-4-0

fdo#54320: VoiceOver does not follow keyboard focus


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 retired 2013-07-28 21:26:23 UTC
I assume this is fixed? adjujsting status
Comment 10 Emir Sarı (away) 2013-07-29 14:03:22 UTC
Thanks for fixing this important accessibility bug.
Comment 11 Niklas Johansson 2013-07-30 13:56:12 UTC
I can verify that the latest daily build of LibreOffice 4.1 follows the keyboard focus. This fix makes a huge difference for the accessibility on the Mac platform. Thanks a lot!
Comment 12 Commit Notification 2013-08-04 19:31:58 UTC
Boris Dušek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bf7f9e3d6009424275260d21c4b946d4c963a201

Revert "fdo#54320: VoiceOver does not follow keyboard focus"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2013-08-09 13:07:56 UTC
Boris Dušek committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7828ef17579ca132735e9b37462e6c7c591b3e3c&h=libreoffice-4-1

Revert "fdo#54320: VoiceOver does not follow keyboard focus"


It will be available in LibreOffice 4.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2013-08-10 14:57:21 UTC
Boris Dušek committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ddba6389b685d4f839da350d0ea42e6aebf67b70&h=libreoffice-4-0

Revert "fdo#54320: VoiceOver does not follow keyboard focus"


It will be available in LibreOffice 4.0.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.