Download it now!
Bug 46140 - Files not overwritten during upgrade result in crash citing msvcr90.dll
Summary: Files not overwritten during upgrade result in crash citing msvcr90.dll
Status: RESOLVED DUPLICATE of bug 38913
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All Windows (All)
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-15 17:50 UTC by liam.kirsh
Modified: 2012-02-17 00:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Windows crash log (454.60 KB, text/plain)
2012-02-15 17:50 UTC, liam.kirsh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liam.kirsh 2012-02-15 17:50:07 UTC
Created attachment 57126 [details]
Windows crash log

Problem description: Every time I update LibreOffice, for a while I continue to get a "LibreOffice has encountered a problem and needs to close. We are sorry for the inconvenience." error whenever I try to open a file with it. Uninstalling and reinstalling doesn't make a difference, nor does removing the PDF import extension. The problem usually fixes itself after a while but returns when I update again. The crash log is attached. (Possibly related to Bug 46105?)

Steps to reproduce:
1. Install LibreOffice
2. Associate LibreOffice with documents, spreadsheets, and presentations
3. Try to open a document.

Current behavior:
LibreOffice begins to load, but once the loading bar reaches halfway or so and the window reads "Enabling Danish spelling dictionary, hyphenation rules, and thesaurus" (which is odd because I only have the English dictionary installed), LibreOffice crashes and I get the error described above.

Expected behavior: LibreOffice should open the document.

Platform (if different from the browser): Windows XP Pro SP3
              
Browser: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C)
Comment 1 liam.kirsh 2012-02-16 23:22:35 UTC
I resolved the problem by doing a clean uninstall of LibreOffice using Revo Uninstaller, which means that some files were being left over and not overwritten from a previous version I had installed. I would assume they existed in the \Program Files\LibreOffice 3.5\ folder.
Comment 2 liam.kirsh 2012-02-17 00:24:06 UTC

*** This bug has been marked as a duplicate of bug 38913 ***