Bug Hunting Session
Bug 46141 - UI: Header/footer prompts should only appear if user clicks in header/footer area
Summary: UI: Header/footer prompts should only appear if user clicks in header/footer ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA target:3.7.0 (target:3.6.2)
Keywords:
: 47062 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-15 18:12 UTC by Kim Bastin
Modified: 2013-07-30 20:46 UTC (History)
18 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kim Bastin 2012-02-15 18:12:27 UTC
Problem description: Place the mouse cursor in the header or footer area of a document, or scroll the page so that the header/footer area moves over the mouse cursor and move said cursor slightly.

Current behavior: After a second or two there appears a dashed blue horizontal line across the page and a blue prompt labelled with a description the area the cursor is in e.g. Footer (first page).

Requested behavior: The blue line and prompt should only appear if the user explicitly clicks in the header or footer area. 

Comments: It is distracting when the blue line and prompt appear spontaneously, without any conscious action on the user’s part. One typically spends very little time editing headers/footers, so these visual elements are almost never wanted when they appear. The blue prompt can overlay part of the text you are editing, requiring you to interrupt your work to move the mouse cursor. It would be preferable if these features only appeared in response to explicit user action, e.g. a mouse click in the header/footer area.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Peter Roelofsen 2012-02-28 11:59:55 UTC
Confirmed for Windows Vista Home. 
I noticed besides that the option to edit borders/backgrounds doesn't activate the paragraph style dialog box for header or footer text but simply the borders/background dialog box, encouraging direct formatting. People over at the community forum user.services.openoffice.org are always telling newcomers to use styles, and with good reason, so this is counter productive.
Comment 2 vitriol 2012-03-07 09:16:24 UTC
*** Bug 47062 has been marked as a duplicate of this bug. ***
Comment 3 vitriol 2012-03-07 09:21:13 UTC
I agree, it's very annoying during scrolling and editing. BTW on my (recent) system the prompt has a terrible flickering...
Comment 4 Roman Eisele 2012-05-02 07:37:05 UTC
Seems related to
* Bug 46518 - UI: Header, footer & and page break indicators in multipage view 
* Bug 44725 - "VIEWING: Heading - Footer - Pagebreak lines
appear somewhere in the page".
Comment 5 MRK 2012-06-13 05:24:41 UTC
I agree 100%.
Please convey to the developers that most of us would rather think for ourselves, and if we needed help, we'd ask for it...  :) 
MRK
Comment 6 BrendaEM 2012-06-14 11:40:02 UTC
Hi All,

I will go one further and state that I think that the header/footer should only become active if the user double-clicks on the header and footer.

I have written over 270,000 words with Libreoffice and OpenOffice. When I am editing and correcting a book. I frequently clicking on the upper and lower lines. Doing so, it is very easy to click in the header and footer area. I need the ability to accidentally click near the top and bottom without being punished for it.

After some tuning, the new header and footer system will be a blessing, but people edit the text inside the document more often than they edit the headers and footers. For all the hard work that went into it the header/footer system will remain annoying until it is changed.

In ask for the header/footer system be modified for double clicks.

Thank you,
BrendaEM
Comment 7 Kim Bastin 2012-06-14 17:40:50 UTC
The platform is set to x86(IA32) – Linux (All). The problem is not confined to Linux and in fact was first reported on Windows XP, so I would substitute All for Linux (All). (I can’t determine the appropriate CPU setting.)
Comment 8 manj_k 2012-07-07 15:05:37 UTC
Reset version picker due to → http://wiki.documentfoundation.org/BugReport_Details#Version
Comment 9 Michael Meeks 2012-07-11 09:44:24 UTC
A good number of views pointing to this bug at ask as well (it happens to annoy me too ;-) - particularly the auto-scrolling behaviour as you type bringing an un-moved mouse cursor over that region causing the popup.
Comment 10 pisseduser 2012-07-16 22:19:10 UTC
I registered just to say how this "feature" looks useless and annoying to me.
After training in vain to remove that bu****it, I ended up installing open office.
Comment 11 Michael Meeks 2012-07-17 09:18:16 UTC
pisseduser: kind of you to register. Consider creating a patch to reduce the visual annoyance; I too agree it is annoying, but it's not annoying enough to me to actually fix the bug ;-) Presumably either a volunteer, or someone that pays for support will eventually complain and it'll get fixed.
Comment 12 tom.platteter 2012-07-22 11:04:17 UTC
yeah slows the hell out of the program for no reason. Who cares about UI features over functionality of a program. I'm going to uninstall.
Comment 13 Exponat 2012-07-24 08:07:56 UTC
Please, create option in settings Writer to enable/disable auto pop-up new header/footer.
Comment 14 Michael Meeks 2012-08-15 11:15:32 UTC
Code pointer for this is around here:

git log -u -1 beb8a85796c78d4cdcf6497b6725fce8f7141d75
Comment 15 Jerguš Moravčík 2012-08-17 11:26:25 UTC
(In reply to comment #6)
> Hi All,
> 
> I will go one further and state that I think that the header/footer should only
> become active if the user double-clicks on the header and footer.
> 
> I have written over 270,000 words with Libreoffice and OpenOffice. When I am
> editing and correcting a book. I frequently clicking on the upper and lower
> lines. Doing so, it is very easy to click in the header and footer area. I need
> the ability to accidentally click near the top and bottom without being
> punished for it.
> 
> After some tuning, the new header and footer system will be a blessing, but
> people edit the text inside the document more often than they edit the headers
> and footers. For all the hard work that went into it the header/footer system
> will remain annoying until it is changed.
> 
> In ask for the header/footer system be modified for double clicks.
> 
> Thank you,
> BrendaEM

Same for me and my mother - she does her job at LO and the last thing 
she needs is permanent change in behaviour of her working tools. Things
like this new blinking blue thing, changes in layouts and keyboard shortcuts
force people to explore the news, mostly find a way how to get it into state
they are used to instead of using the tool. That's pretty annoying and 
spread wide across the operating systems, text editors, graphical editors -
and most of other software.
Comment 16 Glutanimate 2012-08-20 20:28:20 UTC
I agree with Exponat, an option to disable the new popup would eliminate one of the great annoyances with LO >3.5.x releases. As of right now the prompt is very buggy and appears to slow down my whole LO experience compared to 3.4.x.
Comment 17 Cor Nouws 2012-08-22 10:47:16 UTC
(In reply to comment #4)
> Seems related to
> * Bug 46518 - UI: Header, footer & and page break indicators in multipage view 
> * Bug 44725 - "VIEWING: Heading - Footer - Pagebreak lines
> appear somewhere in the page".

And related to bug 45959
Comment 18 Cor Nouws 2012-08-22 10:51:07 UTC
(In reply to comment #16)
> I agree with Exponat, an option to disable the new popup would eliminate one of
> the great annoyances with LO >3.5.x releases. As of right now the prompt is
> very buggy and appears to slow down my whole LO experience compared to 3.4.x.

Though it's no user forum here: the line can IMO be less annoying when you sett the color to light grey or so (Tools > Option > LibreOffice ... Appearance > Text document > Header footer separator).
I've not noticed that the line shows down the application, although my 3 yrds old laptop is not too fast, and has only (?) 4 Gig memory
Comment 19 Not Assigned 2012-08-23 07:54:45 UTC
Cedric Bosdonnat committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3d7927152169474c3c73ac36d5d79008fe6bab3e

fdo#46141: Don't use a timer to show header/footer separators
Comment 20 manj_k 2012-08-24 08:38:25 UTC
(In reply to comment #19)
> Cedric Bosdonnat committed a patch related to this issue.
> It has been pushed to "master" [...]


Thank you so much!

That works fine for me (on WinXP 32b)
with
LibO-Dev_3.7.0.0.alpha0+
W2008R2@20-With-Symbol-Bytemark-Hosting MASTER
pull time 2012-08-23 23:24:26
core:e155a555c97db9e3f54d7500f912fe88f634dc99.
Comment 21 Glutanimate 2012-08-26 18:17:18 UTC
(In reply to comment #18)
> Though it's no user forum here: the line can IMO be less annoying when you sett
> the color to light grey or so (Tools > Option > LibreOffice ... Appearance >
> Text document > Header footer separator).
> I've not noticed that the line shows down the application, although my 3 yrds
> old laptop is not too fast, and has only (?) 4 Gig memory

Thank you, that did indeed help a bit. As far as the speed issue is concerned I just went through a trial run of reinstalling LO 3.4.6 and comparing its performance to 3.6.0. There seems to be a slight advantage in scrolling speed for 3.4.6 but the difference is much smaller than I had thought.
Comment 22 Roman Eisele 2012-08-29 11:31:50 UTC
(In reply to comment #19)
> Cedric Bosdonnat committed a patch related to this issue.
> It has been pushed to "master":
> 
> http://cgit.freedesktop.org/libreoffice/core/commit/?id=3d7927152169474c3c73ac36d5d79008fe6bab3e
> 
> fdo#46141: Don't use a timer to show header/footer separators


@Cédric:
Is there any chance to backport that fix to the 3.6 branch? This would be very much appreciated by many users ... Thank you!
Comment 23 Rainer Bielefeld Retired 2012-09-03 08:17:42 UTC
Did a quick test with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: 9bb30a4]"  {tinderbox: 2008R2@20, pull time 2012-08-30 23:44:35} on German WIN7 Home Premium (64bit), works fine.

This fix improves situation caused by "Bug 44725 - VIEWING: Heading - Footer - Pagebreak lines appear somewhere in the page"

Backport to 3.6 would be great (if without risks)
Comment 24 Roman Eisele 2012-09-03 09:38:59 UTC
I repeated Rainer's quick test (see prev. comment), but on Mac OS X 10.6.8 with LOdev 3.7.0.0.alpha0+ (Build ID: 4deb9d4, pull time: 2012-08-31 04:36:39), and my results are the same -- the fix works fine, and the situation reported in bug 44725 is (at least) improved.
Comment 25 Ivan Timofeev (retired) 2012-09-03 10:10:48 UTC
(In reply to comment #23)
> Backport to 3.6 would be great (if without risks)

Hmm, at least it is now impossible to draw or pick a drawing in header/footer.
Comment 26 Rainer Bielefeld Retired 2012-09-03 10:50:38 UTC
(In reply to comment #25)
> Hmm, at least it is now impossible to draw or pick a drawing in header/footer.

Drawing circle into footer was one of my quick tests and worked fine for me, can you submit a new bug with more detailed description and add me to CC?
Comment 27 Ivan Timofeev (retired) 2012-09-03 17:43:50 UTC
Sure, Bug 54453.
Comment 28 vitriol 2012-09-13 08:54:40 UTC
Seems fixed in version 3.6.2.1 to me.
Comment 29 Kim Bastin 2012-09-25 00:17:42 UTC
I originally reported this bug, which now appears to be fixed (in 3.6.2.1). Is it open to me to change its status to RESOLVED? Not sure of the protocol here.
Comment 30 Rainer Bielefeld Retired 2012-09-25 04:15:42 UTC
Although I do not see any hint concerning a backport to 3.6, the difference between 3.6.0.4 and 3.6.2.1 us obvious, Header/footer prompts appear the same way as in 3.7.0.
3.5.7.1 still shows the old behavior, but I doubt that there will be a backport.

So I close this one, please feel free to correct my decision if it is wrong.
Comment 31 Theo 2013-02-09 16:49:05 UTC
Sorry, but the problem is not fixed. 
It is the same bahaviour up to now, it is not possible to deactivate the line. It is the same in LO 4.0 as well.
Comment 32 Michael Meeks 2013-02-11 17:05:36 UTC
Hi Theo

> Sorry, but the problem is not fixed. It is the same bahaviour up to now,
> it is not possible to deactivate the line. It is the same in LO 4.0 as well.

Can you give a clearer explanation of what remains to be fixed here; I require a click to show the header insertion / pop-down menu. I can select it nicely, and I can select a custom-shape in the header.

Can you provide some easy-to-reproduce steps / screenshots to reproduce the "de-activation of the line" you mention ?

Thanks !
Comment 33 tommy27 2013-07-30 20:46:52 UTC
Header/footer prompts work as expected in 4.0.4 and 4.1.0 so, after 5 months of NEEDINFO status with no reply from the user who reopened, I think it's time to mark it as RESOLVED FIXED again.