Bug Hunting Session
Bug 46160 - Calc UI: Unacceptable lag when editing spreadsheet cells
Summary: Calc UI: Unacceptable lag when editing spreadsheet cells
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: high major
Assignee: Eike Rathke
URL:
Whiteboard: target:3.6.0 target:3.5.4
Keywords: regression
: 47986 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-02-16 03:33 UTC by Max
Modified: 2012-05-10 07:40 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Formatted spreadsheet for testing purposes (39.40 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-03-22 06:50 UTC, Max
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Max 2012-02-16 03:33:11 UTC
After upgrading from version 3.4.5 to version 3.5.0rc3, I'm experiencing a significant time lag (2 to 3 seconds) when editing cells in a regularly used spreadsheet (with around 2500 rows and around 9 columns, but no calculations - it's just a list, but with various formatting applied to many of the cells).

After opening, there is no lag when clicking in the 1st cell to be edited, only with the second and subsequent cells.

I wouldn't describe the laptop involved as fast, however this lag never occurred in version 3.4.5. Defragmenting the hard drive made no difference. Other operations (saving, sorting, etc), seem unaffected.
Comment 1 Max 2012-02-19 08:59:54 UTC
Further to my initial report, I've now been able to compare performance on faster hardware under Windows 7. Using 3.5.0rc3 there is a small lag (noticeable but unimportant - a couple of tenths of a second) when editing cells in the spreadsheet concerned. In version 3.4.5 there is no detectable lag at all on the same hardware.

It is therefore probable that this lag is related to computer performance rather that to Windows XP, however version 3.5.0rc3 has degraded performance and remains unusable for my purposes on my XP machine.

Since XP is still the World's most popular operating system (and probably runs on older hardware), this is a serious bug.
Comment 2 p.d.mallinson 2012-03-02 06:35:36 UTC
I have a similar problem on upgrading from 3.4.5 on Windows 7 (64 bit).

The spreadsheet has a graph.  When any cell is updated in 3.5.0 final release the CPU hits 100% for a _very_ long time (many minutes) and, understandably, my system does not respond.  When removing 3.5.0 and re-installing 3.4.5 there is no such behaviour.
Comment 3 Max 2012-03-22 06:50:59 UTC
Created attachment 58869 [details]
Formatted spreadsheet for testing purposes

This file contains only formats - no 'data' - but still exhibits the time lag issue.
Comment 4 Max 2012-03-22 06:55:55 UTC
Having just tested version 3.5.1 on my fast PC under Windows7 64bit, I can now
report that the performance is worse than it was for version 3.5.0, with a
delay of between 0.5 and 1 second to edit the fields.

Not yet tested on the older laptop under XP.

Sample file uploaded for replications test.

Could this somehow be related to the newly introduced 'unlimited number of
rules for conditional formatting' feature?
Comment 5 Max 2012-03-25 15:45:50 UTC
Have now tested on version 3.5 under Ubuntu and get a lag of around 1 second using the demonstration file on a reasonably fast PC. Since it's now a problem under 3 operating systems I'm changing this to affecting 'All' platforms.
Comment 6 sasha.libreoffice 2012-04-04 09:03:07 UTC
reproduced in 3.5.2 on Fedora 64 bit and 3.5.0 on Windows XP 32 bit
Considerably slower than in 3.3.4 and 3.4.3 versions
Comment 7 Michael Meeks 2012-05-02 06:58:31 UTC
Great bug :-) can someone install debuginfo packages under Linux, and run the latest libreoffice 3.5.x under callgrind:

cd /path/to/soffice.bin
sudo chmod a+w .
export OOO_DISABLE_RECOVERY=1
valgrind --tool=callgrind --simulate-cache=yes --dump-instr=yes ./soffice.bin -writer --splash-pipe=0

When it starts up (beware very slow ... ;-) then trigger the problem multiple times - say 10x or so (so as to swamp the startup profile), exit cleanly,
 gzip and attach the callgrind.1235.out.

That should make it -far- easier to find & fix quickly.

Thanks ! :-)
Comment 8 Eike Rathke 2012-05-03 08:50:29 UTC
Bug 47986 sounds related.
Comment 9 Eike Rathke 2012-05-03 09:17:28 UTC
Bug 47986 mentions that with LibO 3.5.3 the problem is gone.

@Max: can you please try 3.5.3? Thanks.
Comment 10 Max 2012-05-03 15:38:11 UTC
@Eike Rathke Have only tested 3.5.3 on my fast Win7 64bit machine, but the problem remains the same - about a 1 second lag on every cell.
Comment 11 Max 2012-05-03 15:51:18 UTC
@Eike Rathke - a test file is available for testing - see attachments.
Comment 12 Eike Rathke 2012-05-04 04:23:04 UTC
Problem seems to be formatting / cell attributes.
Taking this.
Comment 13 Not Assigned 2012-05-04 14:18:53 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7c5064d3bd57a0d5e57e188274d74d61a3ac9922

resolved fdo#46160 query model only once whether it is a preview
Comment 14 sasha.libreoffice 2012-05-04 23:06:08 UTC
Thanks for fixing this bug
Comment 15 Not Assigned 2012-05-08 02:30:07 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=52fc5dc51fc3f5f8cf212898e45fc90066fa7f8d&g=libreoffice-3-5

resolved fdo#46160 query model only once whether it is a preview


It will be available in LibreOffice 3.5.4.
Comment 16 Boyko V 2012-05-10 07:33:22 UTC
Thank you Eike Rathke for fixing this bug.
Comment 17 Boyko V 2012-05-10 07:40:33 UTC
*** Bug 47986 has been marked as a duplicate of this bug. ***