Download it now!
Bug 47986 - EDITING: Slow response and cpu-load spikes when clicking on Input line
Summary: EDITING: Slow response and cpu-load spikes when clicking on Input line
Status: RESOLVED DUPLICATE of bug 46160
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 47918 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-28 01:10 UTC by Boyko V
Modified: 2012-05-10 07:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
The first spike is when I click on input line and wait for it to start responding. The second spike is when I hit enter to confirm the content in Input Line. (2.51 KB, image/png)
2012-03-28 01:10 UTC, Boyko V
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Boyko V 2012-03-28 01:10:00 UTC
Created attachment 59140 [details]
The first spike is when I click on input line and wait for it to start responding. The second spike is when I hit enter to confirm the content in Input Line.

In LibreOffice Calc editing cells is very slow when using the Input Line.
Whne I click on an empty cells and enter data, it works fine. However, if I click on the Input Line, the applications freezes for 3 seconds, and after those 3 seconds the marker appears in the text box. This makes it tedious to edit content of cells.

I attach snapshots of my cpu-load when I replicate the issue. The first spike is when I click on input line and wait for it to start responding. The second spike is when I hit enter to confirm the content in Input Line.

Using this build: LibreOffice 3.5.1.2 
Build ID: dc9775d-05ecbee-0851ad3-1586698-727bf66
On a Win7 Professional + SP1

Best regards
/Boyko Vasilev
Comment 1 Boyko V 2012-04-12 02:27:25 UTC
Made a clean install of LibreOffice 3.5.2.2 
Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f

The problem persists.
Comment 2 Victor 2012-05-01 18:40:18 UTC
I second this bug. Win 7 64-bit, Libre Office version 3.5.2.2
Comment 3 Victor 2012-05-01 18:41:06 UTC
Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f
Comment 4 Thorsten Behrens (CIB) 2012-05-03 07:58:12 UTC
Hm, don't immediately see this - does that happen with any, even an empty document? How many languages have you installed, and which locale do you use?
Comment 5 Rainer Bielefeld Retired 2012-05-03 08:28:33 UTC
NOT reproducible during a quick test with an empty new spreasheet and "LibreOffice 3.5.3.2 (RC2) German UI/Locale [Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit). No visible delay, no spikes in the resources monitor.

@Boyko V:
May I recommend to try a server installation due to <https://wiki.documentfoundation.org/Installing_in_parallel#Windows> including modificatons of bootstrap.ini? That's a _really_ clean new installation, we will see what happens.
Comment 6 Victor 2012-05-03 08:32:17 UTC
I can reproduce with an empty document, or a previously created ODS or XLS
file. Spikes can be reproduced by the following actions:

- alternating mouse clicks between a cell and the input line
- alternating clicks between a cell and the menu. 
- alternating clicks between the input line and the menu
- alternating clicks between the any other window (e.g. the Windows Task
Manager) and the LibreOffice Window title bar


Does not happen when using the F2 key to edit a cell or when using the ALT key
to use the menu.

User interface languages installed: only English
Dictionaries installed: Spanish, English
Program Modules installed: Writer, Calc, Draw, Impress
Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f
Win 7 64-bit
Comment 7 Victor 2012-05-03 08:40:43 UTC
*** Bug 47918 has been marked as a duplicate of this bug. ***
Comment 8 Eike Rathke 2012-05-03 08:51:31 UTC
Bug 46160 sounds related.
Comment 9 Victor 2012-05-03 09:14:57 UTC
Just installed LibreOffice 3.5.3.2 
Build ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80

Cannot reproduce the issue.
Comment 10 Dmitry Yakimov 2012-05-08 07:05:33 UTC
3.5.3.2 Can reproduce it. At least the first spike. Try it on netbook, is is very slow.
Comment 11 Boyko V 2012-05-10 07:40:33 UTC
Have confirmed that the bug is a duplicate of 
Bug 46160 - Calc UI: Unacceptable lag when editing spreadsheet cells

Eike Rathke committed a patch which solves the issue. 
The patch has been pushed to "libreoffice-3-5".
It will be available in LibreOffice 3.5.4.

Impatient users (like me) can grab the daily build LOdev 3.5.4rc0+ 

http://dev-builds.libreoffice.org/daily/Win-x86@7-MinGW/libreoffice-3-5/2012-05-09_19.07.10/

Thanks everyone :)

*** This bug has been marked as a duplicate of bug 46160 ***