Bug Hunting Session
Bug 46221 - Simplify file open dialog file types list
Summary: Simplify file open dialog file types list
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86 (IA32) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 56304 (view as bug list)
Depends on:
Blocks: File-Dialog
  Show dependency treegraph
 
Reported: 2012-02-17 02:23 UTC by Owen Savill
Modified: 2017-09-17 13:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Savill 2012-02-17 02:23:56 UTC
The number of file types that Libre can open is impressive but this leads to a problem with the File Open dialog. Apart from the rather odd looking "All files" list, which fills the entire height of the display, the sheer number of options is a little overwhelming.

Would it be possible to have two drop downs, one for a category and then the other which lists the file types associated with that file type. It kind of already does that but the categories appear at the top of the list, i.e. "All files", "Text Documents", "Spreadsheets", followed by all the distinct file types. So the enhancement might look something like:
"All Documents" -- "All Files"
"Text Documents" -- "All Files"
                    "Open Office Document (.odf)"
                    "Word 2007 Document (.doc)"
                    "Plain text document (.txt)"
                    "..."
"Template Documents" -- "All Files"
                        "Open Office Template (.odt)"
                        "Word Template"
                        "Excel Template"
                        "..."
"Spreadsheets" -- "All Files"
                  "..."

and so on.
Comment 1 Aldo Román Nureña 2012-09-07 07:11:51 UTC
I think having two dropdown lists would make it even more overwhelming. 

Having that the bug title is "Simplify file open dialog"... I would focus on solving the "entire height of the display" issue. Maybe we can group all the Microsoft formats in a row (like "Text docuements(...)" as it already is, but only "Microsoft Office (...)" because they are displayed each one in a row and it occupies most of the dropdown list.
Comment 2 Rainer Bielefeld Retired 2013-01-28 05:38:14 UTC
Same in WIN
Comment 3 Heiko Tietze 2017-08-28 12:18:10 UTC
More controls don't reduces the complexity. Two dropdowns are not familiar and require two clicks - totally annoying. That's also for me a WF.
Comment 4 Yousuf Philips (jay) (retired) 2017-09-17 13:15:07 UTC
*** Bug 56304 has been marked as a duplicate of this bug. ***