Bug Hunting Session
Bug 56304 - FILEOPEN: Enhancement: use multi level drop downs for file types
Summary: FILEOPEN: Enhancement: use multi level drop downs for file types
Status: RESOLVED DUPLICATE of bug 46221
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: File-Dialog
  Show dependency treegraph
 
Reported: 2012-10-22 23:47 UTC by pcsnow@gmail.com
Modified: 2017-09-17 13:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pcsnow@gmail.com 2012-10-22 23:47:20 UTC
Problem description: 
The list of files for open has become quite long in spreadsheet.
Find .csv, one of the more common spreadsheet suffixes at the end of
the file. The first one is text and csv is further down under text csv
Could you use a submenu under txt for both txt and csv.
Some of the other MicroCrap extensions could also benefit from that approach.

Enhancement Request



Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Comment 1 Joel Madero 2013-02-11 03:41:00 UTC
Interesting idea, personally I like it, UX team will have to get involved before implementation. What are some other suggestions for groupings? Microsoft Standards, Open Standards, hm any others?

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Marking as:
New (confirmed)
Enhancement
Medium


Best Regards and thanks for helping!
Comment 2 pcsnow@gmail.com 2013-02-11 17:44:24 UTC
Not sure the best configuration but the large number of elements feels to cumbersome. Isn't there some Human Factors consultants on Fedora Projects?

Your suggestion seems OK ( Microsoft, Libre, Generic)
Generic might be txt, csv, tsv, other ?

Functional Groupings Text, Calc, Presentation, Graphic, Photo
Comment 3 Yousuf Philips (jay) (retired) 2017-09-17 13:15:07 UTC

*** This bug has been marked as a duplicate of bug 46221 ***