Bug Hunting Session
Bug 46246 - crash/deadlock/conflict problems with old stdlibs
Summary: crash/deadlock/conflict problems with old stdlibs
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 45074 (view as bug list)
Depends on: 45696
Blocks:
  Show dependency treegraph
 
Reported: 2012-02-17 13:19 UTC by Michael Meeks
Modified: 2013-01-08 10:59 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2012-02-17 13:19:32 UTC
Field to act as a close-able bug for the outstanding issues here.

commit 848b0b4bf8fb5407cb4fecdc0d3238dbef8596e3
Author: Petr Mladek <pmladek@suse.cz>
Date:   Fri Feb 10 14:58:29 2012 +0100

    use system stdlibs on Linux by default (fdo#45074, fdo#45696)
    
    The old system libraries breaked 3rd-party extensions.
    There were also problems with exceptions hadnling.
    
    We use pretty old compiler for the official build, so it should be compatible
    with most systems. It is the preferred default also for other distro builds.

We stop shipping these libs in 3.5.1.
Comment 1 Michael Meeks 2012-02-17 13:20:11 UTC
*** Bug 45074 has been marked as a duplicate of this bug. ***
Comment 2 Michael Meeks 2012-02-17 13:20:54 UTC
*** Bug 44681 has been marked as a duplicate of this bug. ***
Comment 3 Michael Meeks 2012-02-17 13:23:40 UTC
*** Bug 46129 has been marked as a duplicate of this bug. ***
Comment 4 Michael Meeks 2012-02-17 13:26:41 UTC
so marking fixed.
Comment 5 Dave Richards 2012-05-24 05:50:00 UTC
@All:
     This issue still is lingering in 3.5.3.  Michael indicated there was a regression in 3.5.2 and I had to remove:

-rwxr-xr-x 1 root root  53872 Apr 24 19:37 libgcc_s.so.1
-rwxr-xr-x 1 root root 977776 Apr 24 19:37 libstdc++.so.6

to get it to periodically stop hanging at the splash screen.  I just installed 3.5.3 and it's doing the same thing.  I moved the libraries out of the way again.

Operating system is OpenSuse 11.2; which I understand is older but that's what we have in production at this time. Possibly this is only affecting users on older versions of Linux.
Comment 6 Michael Meeks 2012-05-24 06:25:20 UTC
We should have split those libraries out into a separate RPM in the desktop integration sub-directory and made it hard to install that (you shouldn't) ;-) did you go install it ? if not, I wonder where those libs came from.
Comment 7 Dave Richards 2012-05-24 06:52:20 UTC
Ok, I see they are in:libreoffice3.5-stdlibs-3.5.3-2.x86_64.rpm.  I thought the 'fix' in some way made it OK to install these libraries and can certainly just move this RPM out of the way and never install.  Is this a proper fix for people that do this infrequently or don't think about such things?  They're going to have deadlocks.

This deadlock is not frequent, but we did get calls about it.

I can close this if everyone thinks it's a WFM issue :)
Comment 8 Julien Nabet 2013-01-05 14:53:06 UTC
Michael: any update about this?
Comment 9 Michael Meeks 2013-01-08 10:59:09 UTC
So - yes, you don't want to install the stdlibs RPM unless you have to :-) Unless you're using specific, problematic binary extensions eg. DudenCorrector you won't have issues not installing it.

I believe we're dropping that for 4.0 anyway so ...

Thanks :-)