Bug Hunting Session
Bug 45074 - Failed symbol dependency from builtin libstc++ DSO
Summary: Failed symbol dependency from builtin libstc++ DSO
Status: RESOLVED DUPLICATE of bug 46246
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-22 04:55 UTC by gordon.lack
Modified: 2012-02-17 13:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gordon.lack 2012-01-22 04:55:17 UTC
The distribution of LibreOffice for 3.5.0RC1 contains it's own elibstdc++.so.6 DSO, and things are set up for that to be used ahead of the system libstdc++.so.6.
However - this version is not the latest, and so libraries which are used from the underlying system install (as the LO install does not include them) can fail to load because of missing symbol version dependencies.
Hence this:

 [parent]: /opt/libreoffice3.5/program/soffice
 /opt/libreoffice3.5/program/../ure-link/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib64/libproxy.so.1)
 Failed to load module: /usr/lib64/gio/modules/libgiolibproxy.so

The supplied libstdc++.so.6 only goes up to GLIBCXX_3.4.9

Since I don't actually use a proxy this may not affect me directly (I was only running 3.4.5RC1 to check out another bug) but it may well affect others, and there may well be other library dependencies which would affect me.

Similar things have been reported before (see, e.g. Bug32852), but that report has been closed a No a Bug.  However, I reckon that if I can't load libraries which are needed in certain circumstances then that *is* a bug.
Comment 1 Stephan Bergmann 2012-02-06 06:43:59 UTC
we are currently discussing whether it would not be better to build the <http://www.libreoffice.org/download/> installation sets --without-system-stdlibs (so they do not bring along their own versions of libstdc++.so.6 and libgcc_s.so.1) in the scope of issue 45696
Comment 2 Michael Meeks 2012-02-17 13:20:11 UTC
fixed by not shipping the old stdlibs.

*** This bug has been marked as a duplicate of bug 46246 ***