Bug 46269 - TDF Site: remove icons and older versions from download page, offer direct links for all OSes and languages
Summary: TDF Site: remove icons and older versions from download page, offer direct li...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-18 18:33 UTC by Asa Dotzler
Modified: 2012-06-26 02:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Asa Dotzler 2012-02-18 18:33:42 UTC
The http://www.libreoffice.org/download/ page is super confusing. See my rant here http://weblogs.mozillazine.org/asa/archives/2012/02/libreoffice_youre_do.html

If you all make downloading from the front page work as it should, bug 44585, then you can turn the download page into something useful for picking alternate languages or operating systems. See http://www.mozilla.org/firefox/all.html for how to do this. 

The current select widget set-up is sub-optimal because it masks the available languages and OSes, pushing them into secondary UI for no good reason. Also, a user cannot easily use find in page to get to the language she's looking for. Just make it a big list instead. 

This page should have a link somewhere at the bottom for "older versions" but should absolutely not offer two different versions -- that does nothing but confuse potential users.
Comment 1 Asa Dotzler 2012-02-18 18:35:05 UTC
At a bare minimum, please remove those meaningless (worse, confusing!) icons from the two versions and push the older release below the fold somewhere. It's a right confusing mess today.
Comment 2 Rainer Bielefeld Retired 2012-02-18 23:27:07 UTC
I think this one is INVALID, it's intended that we offer (at least) 2 Versions.

But the report that it's terrible unclear for a user who visits that page the first time what the intention of that page might be, we have discussed 100 times with the same result: those "I", checkmark and whatever icons explain absolutely nothing, a text line has to be added what explains what version is for what user.

NEEDINFO because I doubt that all requested changes are common sense.
Comment 3 Andras Timar 2012-02-19 02:34:58 UTC
@Rainer, new download page is in the works.https://www.libreoffice.org/download35/?stage=Stage
Comment 4 Björn Michaelsen 2012-02-19 03:04:12 UTC
going back to NEW as the website team is already active on this.
Comment 5 Emil Stenström 2012-02-19 04:32:06 UTC
@Rainer Bielefeld: What percentage of users want the old version? This bug is not about removing the old version, but to move it down, or to a separate page, to better account for the big percentage of people that want the latest version. 

I guess you have stats on clicks in the latest versus the old version.

@Andras Timar: Is there a version that's not behind login (maybe just a screenshoot?), so I can give feedback on the work in progress?
Comment 6 Björn Michaelsen 2012-02-19 09:01:19 UTC
Seems to be solved for me with the download page that is online now.

@website-team: please pick up and assign/close with proper kudos to the hero implementing it!
Comment 7 Michael Meeks 2012-02-20 02:28:15 UTC
Asa - we are well aware of your rant ;-) We're trying to fix everything for 3.5.1 which is due in ~two weeks. So far, we nailed the 'base' in the start menu, there is a patch floating for the last malingering (two) transient JRE warnings [ the JRE is not really required ], and there is a better design for the Download page coming along.

Hoping you'll re-try your review with 3.5.1 :-)

I tend to agree that we want to hide the old/more-stable version somewhere, but we need it - users appear never to bother testing/complaining until a point-zero release.

Anyhow - thanks for your input.
Comment 8 Marc Pare 2012-06-26 02:32:44 UTC
The new download page has been working for a while and there seems to be an overall satisfaction of the page. It looks like most, if not all, of the requests were satisfied with the new layout and text.

Marc