Bug 46579 - Form fields 'Image Button' do not work in Forms
Summary: Form fields 'Image Button' do not work in Forms
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
: 89169 (view as bug list)
Depends on:
Blocks: Base-Images
  Show dependency treegraph
Reported: 2012-02-24 09:03 UTC by Robert Großkopf
Modified: 2020-02-14 12:45 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:

Open the form and try the graphical buttons, which are added. (20.74 KB, application/vnd.sun.xml.base)
2012-02-24 11:05 UTC, Robert Großkopf
Enhanced sample document (24.34 KB, application/vnd.sun.xml.base)
2012-02-25 00:39 UTC, Rainer Bielefeld Retired

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2012-02-24 09:03:03 UTC
When trying to set an action to a graphical button nothing happens. Only the reset-function will work.
I could not find this bug, but it won't work also in OOo 3.3.
Comment 1 Rainer Bielefeld Retired 2012-02-24 10:35:55 UTC
NOT reproducible with and first sample from "Bug 37024 - UI: WEB-View for Form layout no longer available " <https://bugs.freedesktop.org/show_bug.cgi?id=37024> I tried Navigation toolbar, everything worked fine. To be honest, I have no idea what problem reporter is talking about.

This is not a valid bug report, any useful information is missing. Robert, you should know better, please contribute additional information concerning your OS, LibO version, due to Bug 44204#C1!
Comment 2 Robert Großkopf 2012-02-24 11:05:29 UTC
Created attachment 57604 [details]
Open the form and try the graphical buttons, which are added.

I have not realised that you could think: graphical buttons are the navigation-bar and so on. These buttons are control-fields of a form. And these buttons wont work under Linux-rpm in LibreOffice 3.3.4 and in LibreOffice 3.5. And these Buttons wont't work (not our problem, you might think) in OOo 3.3 under Linux-rpm, Windows and Mac.
I can not realise that nobody had recognised it before.

Comment 3 Rainer Bielefeld Retired 2012-02-25 00:27:08 UTC
[Reproducible] with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-]" 

Also a problem  with 3.4.5, 3.5.0

Still [Reproducible] with "LOdev 3.6.0alpha0+  English UI/Locale [Build ID: aa7e105-b2dd236-9eed775-d06f752-4dba2d1 (libreoffice-3-5-branch-point)]"  {Win-x86@9-Voreppe Win32 pull time 2012-02-14 16:17:23}. OS: German WIN7 Home Premium (64bit)  

Inherited from OOo, also a Problem with OOo 3.1.1, 3.3, 3.4Beta; I did not find an AOOo Issue.

I attached a modified version of reporter's database showing that normal Push Buttons work as expected.

One for you? Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug.
Comment 4 Rainer Bielefeld Retired 2012-02-25 00:39:59 UTC
Created attachment 57621 [details]
Enhanced sample document

Enhanced sample document additionally shows that "normal" buttons work fine.
Comment 5 Julien Nabet 2014-10-12 09:14:02 UTC
For the record, on pc Debian x86-64 with master sources updated yesterday, I could reproduce this.
Comment 6 Alex Thurgood 2015-01-03 17:39:15 UTC Comment hidden (no-value)
Comment 7 Alex Thurgood 2015-02-06 14:52:39 UTC
*** Bug 89169 has been marked as a duplicate of this bug. ***
Comment 8 QA Administrators 2017-01-03 19:41:04 UTC Comment hidden (obsolete)
Comment 9 Robert Großkopf 2017-01-04 07:16:00 UTC
Bug still exist in
Build-ID: 3d5603e1122f0f102b62521720ab13a38a4e0eb0
CPU-Threads: 4; BS-Version: Linux 4.1; UI-Render: Standard; VCL: kde4; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group

Also tested with LO Same behavior. Nothing happens if I click on any "ImageButton" of the form.
Comment 10 Robert Großkopf 2017-01-04 11:14:35 UTC
OK, I have found a workaround:
You could set the action to 
"Open document/web page"
and then type for URL
... so you get the action "Next Record"

Seems the actions have simply been forgotten ...
Comment 11 QA Administrators 2018-02-08 03:35:07 UTC Comment hidden (obsolete)
Comment 12 Julien Nabet 2018-02-08 08:03:23 UTC
On pc Debian x86-64 with master sources updated yesterday, I can still reproduce this.
Comment 13 QA Administrators 2019-02-09 03:44:38 UTC Comment hidden (obsolete)
Comment 14 Robert Großkopf 2019-02-09 08:48:57 UTC
Bug still exists with LO on OpenSUSE 15, 64bit rpm Linux.
Comment 15 Tom 2020-02-14 10:56:07 UTC
Bug still exists in LO 6.3.4  on Windows 10 (64 bits). Database-type does not matter. Unfortunately the suggested workaround does not work either (in my case): The settings are accepted when editing the form, but nothing happens when used.
Comment 16 Tom 2020-02-14 12:45:57 UTC
(In reply to Tom from comment #15)
> Bug still exists in LO 6.3.4  on Windows 10 (64 bits).