Bug Hunting Session
Bug 46715 - PRINTING: Printing documents from word processor garbles print output
Summary: PRINTING: Printing documents from word processor garbles print output
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-02-28 03:28 UTC by Parameshwara Bhat
Modified: 2013-06-24 17:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Parameshwara Bhat 2012-02-28 03:28:50 UTC
Problem description: 

Steps to reproduce:
1. Create a document
2. Print it
3. printed page will have many lines with garbled print

Current behavior:As above

Expected behavior:Print on page should be equal to prnt preview

Platform (if different from the browser): Opensuse Linux 12.1
              
Browser: Opera/9.80 (X11; Linux i686; U; en) Presto/2.10.229 Version/11.60
Comment 1 sasha.libreoffice 2012-05-24 05:14:48 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
Comment 2 Joel Madero 2012-09-07 22:04:54 UTC
We need more than this to know what the problem is. Please attach a document, name your printer and LibO version. Also any other relevant information. I've never had problems printing or had "garbled print" - also please explain what that means.

Marking as NEEDINFO. If you attach the documentation and provide further explanation please mark as UNCONFIRMED and I'll take a look at it
Comment 3 Parameshwara Bhat 2012-09-08 05:48:19 UTC
(In reply to comment #2)
> We need more than this to know what the problem is. Please attach a document,
> name your printer and LibO version. Also any other relevant information. I've
> never had problems printing or had "garbled print" - also please explain what
> that means.
> 
> Marking as NEEDINFO. If you attach the documentation and provide further
> explanation please mark as UNCONFIRMED and I'll take a look at it

The printer is Samsung SCX 4300.

Version :
pbhat@linux-u7cr:~> rpm -qa|grep libreoffice
libreoffice-base-3.5.4.7-5.3.i586
libreoffice-templates-labels-a4-1.0.1-2.1.1.noarch
libreoffice-draw-3.5.4.7-5.3.i586
libreoffice-icon-theme-hicontrast-3.5.4.7-9.1.noarch
libreoffice-templates-presentation-layouts-3.3-8.2.noarch
libreoffice-base-extensions-3.5.4.7-5.3.i586
libreoffice-branding-openSUSE-3.3.1-4.2.1.noarch
libreoffice-draw-extensions-3.5.4.7-5.3.i586
libreoffice-pyuno-3.5.4.7-5.3.i586
libreoffice-filters-optional-3.5.4.7-5.3.i586
libreoffice-icon-theme-galaxy-3.5.4.7-9.1.noarch
libreoffice-math-3.5.4.7-5.3.i586
libreoffice-impress-extensions-3.5.4.7-5.3.i586
libreoffice-converter-3.3-8.1.1.noarch
libreoffice-mailmerge-3.5.4.7-5.3.i586
libreoffice-impress-3.5.4.7-5.3.i586
libreoffice-icon-theme-oxygen-3.5.4.7-9.1.noarch
libreoffice-writer-3.5.4.7-5.3.i586
libreoffice-calc-3.5.4.7-5.3.i586
libreoffice-base-drivers-mysql-3.5.4.7-5.3.i586
libreoffice-icon-theme-crystal-3.5.4.7-9.1.noarch
libreoffice-templates-en-3.3-3.1.noarch
libreoffice-3.5.4.7-5.3.i586
libreoffice-calc-extensions-3.5.4.7-5.3.i586
libreoffice-templates-labels-letter-1.0.1-2.1.1.noarch
libreoffice-kde4-3.5.4.7-5.3.i586
libreoffice-writer-extensions-3.5.4.7-5.3.i586

What I mean by garbles is,

here and there lines will spill over margins and pages,are misaligned, some letters are printed half only.

This happens mostly in Writer. But if the writer consists wholly of Table, it does not happen. 

Upto LibO 3.5, only Writer used to show this problem. After upgrade to LibO 3.5.4, occassionally it shows up in Calc also.

Another thing to note is, this shows up in Calligra-word and Abiword too if the document is of OD format. With Abiword's own format, it is less likely to happen, but does happen after upgrade to version 3.5.4(Upto 3.5, Abiword format used to work)

The printer driver is Samsung unified driver for Unix.
Comment 4 sasha.libreoffice 2012-09-10 05:20:36 UTC
Thanks for additional testing and information
In LO printing performs via exporting to pdf.
Try workarounds from bug 44664. May be it will help.

> this shows up in Calligra-word and Abiword too
Therefore problem may be not LO specific. May be problem in some system library. Try some another Linux distro if available.
Comment 5 Joel Madero 2012-09-10 15:39:34 UTC
I tend to agree with Sasha on this and say it's not our bug if it happens at all with other software. I'm honestly not sure where to go from here so I'll see if someone else can help. I don't see the need to try another distribution (we try not to put that on our users) but like I said, I've never seen any printing problems with LibO so it's hard for me to help. I suspect it'll go down as NOTOURBUG as you've said Calligra has the same problem.

Have you checked to see if there is a new driver available for the printer? A quick google search did show quite a few hits for issues with that printer and linux
Comment 6 Timur 2013-04-05 10:04:41 UTC
Please attach a document. And explaint this "This happens mostly in Writer. But if the writer consists wholly of Table, it does not happen. "
There are printing problems with tables from Calc in .odt, such as Bug 62719 and Bug 62197. 

Apart from that, we had some problems which we supposed were with the drivers. When we chose in printer settings "Type Font -Softfont" instead "Substitute with Device Font" it printed OK for HP Laser 1150.
Comment 7 Joel Madero 2013-06-24 17:06:44 UTC
Because problem exists in other software I am convinced this is NOTOURBUG - like a driver issue or distro issue.

Marking as NOTOURBUG