Download it now!
Bug 46840 - Impress/Draw: Line and Filling toolbar: Turn Combobox Line Color into Split Button
Summary: Impress/Draw: Line and Filling toolbar: Turn Combobox Line Color into Split B...
Status: RESOLVED DUPLICATE of bug 46839
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.1 RC1
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 72055 (view as bug list)
Depends on:
Blocks: 45671
  Show dependency treegraph
 
Reported: 2012-03-01 10:24 UTC by Stefan Knorr (astron)
Modified: 2014-05-18 11:10 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Knorr (astron) 2012-03-01 10:24:22 UTC
We should try to use split buttons for all toolbar color choosers, for a longer
rationale, see: bug 45671.

How to get to see the combo box:
* Open Draw or Impress
* Below the Standard toolbar, there is the Line and Filling toolbar.
* In the aforementioned toolbar, see the first combobox (Line Color)

This is a combo box, but ideally, it should be a split button.
Comment 1 Joel Madero 2012-10-30 18:27:12 UTC
Set as NEW, enhancement request, medium.

Buttons should be consistent, also adds some functionality, many users could be affected.

Also ProposedEasyHack as the code to do split buttons is already all over the place. 

Astron: Do you have any pointers where code could be? We can get a new dev working on this one and maybe have it done relatively fast :)
Comment 2 Winfried Donkers 2012-10-31 06:47:40 UTC
@Joel:
This is not an easy hack. Calc and Writer have a different code base for the button action-handling. As yo can read in the meta bug 45671, the 'easy' ones have been dealt with, but some buttons remain to be done. These remaining buttons are the difficult ones and require a large change in the code, both the action-handling code and the button-definition code.
Comment 3 Joel Madero 2012-10-31 17:32:59 UTC
Removed ProposedEasyHack, thanks for the info
Comment 4 Maxim Monastirsky 2014-05-15 19:46:57 UTC
*** Bug 72055 has been marked as a duplicate of this bug. ***
Comment 5 Maxim Monastirsky 2014-05-15 20:47:53 UTC
*** Bug 74297 has been marked as a duplicate of this bug. ***
Comment 6 Maxim Monastirsky 2014-05-18 11:10:08 UTC
Actually Impress/Draw share the same implementation with Writer.

*** This bug has been marked as a duplicate of bug 46839 ***