Bug 46973 - Libreoffice uses GtkMenu background as color of document frame shadow
Summary: Libreoffice uses GtkMenu background as color of document frame shadow
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
Depends on:
Blocks: GTK UI-Theming
  Show dependency treegraph
 
Reported: 2012-03-05 05:42 UTC by Tomasz Sałaciński
Modified: 2022-10-23 01:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomasz Sałaciński 2012-03-05 05:42:22 UTC
Hello,

LibreOffice have issue with darker themes - because it uses GtkMenu background for frame shadow, and foreground color (text color) for frame itself.

When a GTK theme have darker menus but light background (such as Zukitwo, Ubuntu theme) it will draw ugly, fat black borders. Screenshot:

http://luxperpetua.net/lo-screenshot.png

The solution is to use GtkWidget background for frame shadow, or use GtkMenu text color for frame color (this way we'll be sure that there will be contrast between two colors - text must be readable inside menu).

I can try to fix this, but where is the code for this?
Comment 1 Roman Eisele 2012-05-07 10:27:41 UTC
This is (at least at the surface) a UI issue, therefore changed the 'Component' field accordingly.
Comment 2 Samuel Mehrbrodt (allotropia) 2013-10-26 21:15:24 UTC
Hi Tomasz,
can you please upload the screenshot here? It's no longer available at the given URL.

Thanks
Comment 3 QA Administrators 2014-05-17 00:34:01 UTC Comment hidden (noise)
Comment 4 Adolfo Jayme Barrientos 2014-05-19 15:58:59 UTC
This is atill a bog in 4.3, just use a theme such as Numix and look at the harsh borders around the sidebar.
Comment 5 Julien Nabet 2014-11-30 16:07:02 UTC
If it can help, here are Opengrok's results (just 1 page) searching gtkMenu:
http://opengrok.libreoffice.org/search?q=GtkMenu&project=core&defs=&refs=&path=&hist=
Comment 6 Robinson Tryon (qubit) 2015-12-13 11:24:23 UTC Comment hidden (noise)
Comment 7 QA Administrators 2017-10-26 08:09:35 UTC Comment hidden (noise, obsolete)
Comment 8 QA Administrators 2019-12-03 14:00:43 UTC Comment hidden (noise)
Comment 9 QA Administrators 2021-12-03 04:24:49 UTC Comment hidden (noise)
Comment 10 Rafael Lima 2022-10-21 01:47:20 UTC
Is this bug still valid?? So much has changed since 2014!

Can someone confirm if this is still an issue?
Comment 11 Adolfo Jayme Barrientos 2022-10-23 01:00:35 UTC
Andreas Kainz led an effort years ago to remove the fugly borders. We all forgot about this bug.