Bug 59329 - UI: docked panels (like navigator or styles) looks inconsistent with other borders
Summary: UI: docked panels (like navigator or styles) looks inconsistent with other bo...
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.0.beta2
Hardware: All All
: medium normal
Assignee: Ahmad Harthi
URL:
Whiteboard: target:4.3.0 target:4.2.3 target:4.1.6
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-13 21:53 UTC by Francisco
Modified: 2015-11-27 14:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The first one is how a docked panel looked in 3.5 (29.78 KB, image/png)
2013-01-13 21:53 UTC, Francisco
Details
4.0 look (29.81 KB, image/png)
2013-01-13 21:55 UTC, Francisco
Details
solution? (28.93 KB, image/png)
2013-01-13 21:56 UTC, Francisco
Details
Docked on the right side. (21.44 KB, image/png)
2013-01-13 22:37 UTC, m.a.riosv
Details
lower border of a docked objet (6.80 KB, image/png)
2013-01-21 20:06 UTC, Francisco
Details
Mockup of proposed solution (358.71 KB, image/png)
2014-01-27 23:21 UTC, Tin Man
Details
How docked objects look in LibO 4.3.1 (63.43 KB, image/png)
2014-09-11 14:45 UTC, Francisco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2013-01-13 21:53:41 UTC
Created attachment 72969 [details]
The first one is how a docked panel looked in 3.5

This is something maybe secondary when comparing with MABs, but since the change in theme in 3.6 and 4.0, the border of docked panels looks inconsistent with the rest of the borders. For example, in figs I'm attaching, there a white line over the upper border of the docked panel, which remains from the previous look of rulers and toolbars. 
I'm ataching 3 images. The first one is how a docked panel looked in 3.5. The second one is how it looks on 4.0. The 3rd one is a possible solution.
Comment 1 Francisco 2013-01-13 21:55:21 UTC
Created attachment 72970 [details]
4.0 look
Comment 2 Francisco 2013-01-13 21:56:00 UTC
Created attachment 72971 [details]
solution?
Comment 3 m.a.riosv 2013-01-13 22:37:17 UTC
Created attachment 72972 [details]
Docked on the right side.

Reproducible.
Win7x64 Ultimate
Versión 4.0.0.1 (ID de compilación: 527dba6f6e0cfbbc71bd6e7b88a52699bb48799)
Version 4.1.0.0.alpha0+ (Build ID: 3db92283955741b490dc2d4f9e1782b179fee89)
TinderBox: Win-x86@6, Branch:master, Time: 2013-01-11_04:53:05
Comment 4 Francisco 2013-01-21 20:06:47 UTC
Created attachment 73403 [details]
lower border of a docked objet

I dont usually use Windows, but it seems to be that there is an inconsistent border at the bottom in this specific theme, which I didnt see under Kubuntu.
Comment 5 Tin Man 2014-01-27 23:19:25 UTC
The ideal solution would be to get rid of all 3D borders, stretch fields within panels to the panels' edges, and have panels and toolbars draw borders only on sides where they are needed. By that I mean:
* A line stretching across the whole width of the window would be drawn below the toolbars docked at the top, or, if there are none there, below the menubar. (Just to clarify, the line would be drawn below all the toolbars, not below each one.)
* In the same manner, a line would be drawn above the toolbars docked at the bottom if there are any.
* A line would also be drawn to the left/right of toolbars docked at the sides if there are any. This line would stretch from the aforementioned top line to the bottom line.
* A line would be drawn below each panel docked at the top, above each panel docked at the bottom, to the right of each panel docked on the left, and to the left of each panel docked on the right.
* If two panels docked at the side share the same column (one is above the other), a line should be drawn between them.
Hopefully I'm not missing any scenarios.

As for the line, it should be 1 px thick. It would be excellent if we could get its color from the theme, just like we are doing with the current borders. If that's impossible, I'd suggest to use the same color we use for the line separating the status bar.
Comment 6 Tin Man 2014-01-27 23:21:43 UTC
Created attachment 92892 [details]
Mockup of proposed solution
Comment 7 Francisco 2014-01-27 23:26:53 UTC
(In reply to comment #6)
> Created attachment 92892 [details]
> Mockup of proposed solution

Mirek, I think it looks 0K :) . May I ask you a mockup with Oxygen theme (if you have the time)?
Comment 8 Tin Man 2014-01-27 23:37:21 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Created attachment 92892 [details]
> > Mockup of proposed solution
> 
> Mirek, I think it looks 0K :) . May I ask you a mockup with Oxygen theme (if
> you have the time)?

Sorry, I don't have the time, but hopefully you get the idea from my description. If there's anything that's unclear, just ask. :)
Comment 9 Commit Notification 2014-02-11 08:49:14 UTC
Ahmad H. Al Harthi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4357dd89ca50deddd7cec7bfba87627a8515f62c

fdo#59329 fix docked panels borders



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Ahmad Harthi 2014-02-25 06:46:24 UTC
Hi,

I'm changing this patch, there will be two patches, one for 4.2 and another for 4.3

the one for 4.2 will fix the missing lines only, and the one for 4.3 will copy the mockup by Mirek2
Comment 11 Commit Notification 2014-03-02 10:38:22 UTC
Ahmad H. Al Harthi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bbd51100fa9686821f59224933d0cefd272006a5

fdo#59329 Fix docked window border lines



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2014-03-05 14:54:49 UTC
Ahmad H. Al Harthi committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=af172141738bf50c7edbc502acf8286191adae95&h=libreoffice-4-2

fdo#59329 fix docked panels borders


It will be available in LibreOffice 4.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2014-03-05 14:56:10 UTC
Ahmad H. Al Harthi committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=682f723d31e6c4a59254a08f5ec62abc700f3fd6&h=libreoffice-4-2

fdo#59329 Fix docked window border lines


It will be available in LibreOffice 4.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2014-03-05 15:01:38 UTC
Ahmad H. Al Harthi committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=60b257f47750a3315edd3024ff7931a0c40ae33a&h=libreoffice-4-1

fdo#59329 fix docked panels borders


It will be available in LibreOffice 4.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2014-03-05 15:01:53 UTC
Ahmad H. Al Harthi committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=24de7939b2f4416506bf4858711b91d48064a201&h=libreoffice-4-1

fdo#59329 Fix docked window border lines


It will be available in LibreOffice 4.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Adolfo Jayme 2014-05-01 06:24:39 UTC
@Ahmad: did you commit the “different patch for 4.3” that you mentioned? 3D borders can still be seen on 4.3, see https://wiki.documentfoundation.org/images/3/3d/In-margins-option.png for an example.
Comment 17 Ahmad Harthi 2014-05-01 06:29:26 UTC
(In reply to comment #16)
> @Ahmad: did you commit the “different patch for 4.3” that you mentioned? 3D
> borders can still be seen on 4.3, see
> https://wiki.documentfoundation.org/images/3/3d/In-margins-option.png for an
> example.

Not yet, the patch for 4.3 doesn't look good on Windows.

I don't have time for it now, but I'll try to fix it ASAP.
Comment 18 Francisco 2014-09-06 20:16:46 UTC
If the bug is still present, why is it marked as "RESOLVED/FIXED"?
Comment 19 retired 2014-09-11 10:00:31 UTC
Feel free to reopen and provide exact info what is not yet fixed and still needs to be done. Thanks.
Comment 20 Francisco 2014-09-11 14:28:56 UTC
> Feel free to reopen and provide exact info 
> what is not yet fixed and still needs to be done. Thanks.

The bug is still present in LibreOffice 4.3.1. Dock borders still looks as indicated in 2nd attachment (4.0 look)
Comment 21 Francisco 2014-09-11 14:45:03 UTC
Created attachment 106140 [details]
How docked objects look in LibO 4.3.1

(In reply to comment #20)
> > Feel free to reopen and provide exact info 
> > what is not yet fixed and still needs to be done. Thanks.
> 
> The bug is still present in LibreOffice 4.3.1. Dock borders still looks as
> indicated in 2nd attachment (4.0 look)

Sorry, dock borders doesn't look exactly like in 2nd attachment, but 3D borders are still present and 2 borders are at the bottom of docks.

In the attachment, the left image is the actual situation, and the left is how it should look according to Mirek's proposal (attachment 92892 [details])
Comment 22 Tin Man 2014-09-11 15:05:14 UTC
(In reply to comment #21)
> Created attachment 106140 [details]
> How docked objects look in LibO 4.3.1
> 
> (In reply to comment #20)
> > > Feel free to reopen and provide exact info 
> > > what is not yet fixed and still needs to be done. Thanks.
> > 
> > The bug is still present in LibreOffice 4.3.1. Dock borders still looks as
> > indicated in 2nd attachment (4.0 look)
> 
> Sorry, dock borders doesn't look exactly like in 2nd attachment, but 3D
> borders are still present and 2 borders are at the bottom of docks.

They don't need to -- the white highlight is perfectly acceptable, possibly even nicer. My proposal was just based on assumed ease of the implementation.

The problem with the implementation, though, is that the toolbar area isn't delineated -- e.g. above the ruler or to the left of the sidebar in your screenshot.
Comment 23 Francisco 2014-09-11 20:01:21 UTC
(In reply to comment #22)
> They don't need to -- the white highlight is perfectly acceptable, possibly
> even nicer. My proposal was just based on assumed ease of the implementation.
> 
> The problem with the implementation, though, is that the toolbar area isn't
> delineated -- e.g. above the ruler or to the left of the sidebar in your
> screenshot.

Personally, I prefer the look without the white line, I think is more consistent with the rest but that's only my opinion. 

But in any case, my previous comment (18) was only because of comment #16 and comment #17.
Comment 24 Francisco 2014-09-11 20:05:36 UTC
Is the problem of the separator line is related to bug 57433?
Comment 25 Jan Holesovsky 2015-11-27 14:22:19 UTC
This bug is old & there were various changes over the place in the meantime.

Please let's close it, and if you are still unhappy with some aspects, please file new, separate issues.  Please note that the look is different in OS X, Windows, and on Linux, and that mostly we try to mimic the look of the 'native' applications on those platforms.

Thank you for your understanding.