Bug 47031 - if register java(JRE) for x64 which LibO uses on the x64 OS, It have problem.
Summary: if register java(JRE) for x64 which LibO uses on the x64 OS, It have problem.
Status: RESOLVED DUPLICATE of bug 37089
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-06 21:58 UTC by sanada
Modified: 2013-10-07 09:05 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sanada 2012-03-06 21:58:21 UTC
about registration of java(JRE) In option setting of LibO,  it is likely to be caused by mismatch between x86 based LibO and x64 based java.

Therefore, if JRE was registered to LibO system, occur problem.
(relation to bug45756)


for comparison,
aforementioned JRE try to registration to unofficial build (r1293550) of Apache OpenOffice
on same OS with JRE,
in the first place not registered on AOOo.


from this reason,
I suppose that may be bug that x64 based JRE is registered on x86 based core-system.



-WinXP(x64) SP2
-JDK 1.6.0_31 (install from jdk-6u31-windows-x64.exe)
--LibO 3.5.1rc1
--AOOo 3.4.0(r1293550/unofficial)
ftp://bircher2.nine.ch/AOO/devsnap/r1293550/en-US/
Comment 1 sanada 2012-03-06 22:01:03 UTC
for JAPANESE:
---------------------
x64 OS上でLibOが使用するx64用java(JRE)を登録した場合、問題がある。

LibOのオプション設定、java(JRE)の登録において、x86ベースであるLibOとx64用javaがミスマッチである可能性が高い。
このため、LibOシステム側にJREが登録できた場合、問題が発生する(bug45756と関連)。


比較のために、
同一OS上において、Apache OpenOfficeのアンオフィシャルビルド(r1293550)を使用して
上記LibOでの登録フェーズと同様に、同一JREを登録しようとしたところ、
AOOoではそもそも登録されません。


このことから、x86ベースのコアシステムでx64-JREが登録されることはバグかもしれないと推測します。


確認環境:
-WinXP(x64) SP2
-JDK 1.6.0_31(jdk-6u31-windows-x64.exeからインストール)
--LibO 3.5.1rc1
--AOOo 3.4.0(r1293550/unofficial)
Comment 2 Wyndham Clampett 2012-04-05 02:27:41 UTC
I was having several problems (with Spell & Grammar dialog, etc), and discovered that many of the problems went away after I uninstalled 64-bit Java and installed the 32-bit version.

I am now using Java 7 SE Update 03 (32-bit).
Comment 3 Don't use this account, use tml@iki.fi 2013-03-03 19:36:34 UTC

*** This bug has been marked as a duplicate of bug 58663 ***
Comment 4 Don't use this account, use tml@iki.fi 2013-03-03 19:37:24 UTC
Oops, this one was for Windows, not a duplicate of the corresponding Mac bug;)
Comment 5 ign_christian 2013-10-07 09:05:57 UTC

*** This bug has been marked as a duplicate of bug 37089 ***