Bug 47483 - Hijacks MS Office file types on non-custom install
Summary: Hijacks MS Office file types on non-custom install
Status: RESOLVED DUPLICATE of bug 39791
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86 (IA32) Windows (All)
: highest enhancement
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-18 15:32 UTC by h2oskr2001
Modified: 2013-03-06 11:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description h2oskr2001 2012-03-18 15:32:01 UTC
I've used Open Office in conjunction with MS Office for a number of years. In switching to Libre Office, I chose the Typical Install as I've done a number of times before with OO. Unlike OO, Libre Office took over many of the MS Office file types. In looking at the documentation more closely, I saw that I could have avoided this if I'd used the Custom Install. I can probably remove and reinstall Libre Office to correct this but it would be nice if there was an indication when you pick Typical/Custom that helps direct you OR a check box in the Typical Install path to choose the behavior.

Thanks
Comment 1 Joel Madero 2012-07-02 21:24:31 UTC
I can see why this would be annoying for people making the transition from MS Office to LO and still using both or those who have to use both for other reasons. Going to mark this as a HIGHEST priority Enhancement as I think it's not great policy to auto "hijack" MS formats. Thanks a lot for the suggestion
Comment 2 Andras Timar 2012-07-02 23:12:18 UTC
There is a custom action in installer that checks if Microsoft Office filetypes are registered, and if they are, installer will not associate them to LibreOffice by default. The problem is that this custom action does not work properly. I want to fix this before 3.6.0.
Comment 3 Andras Timar 2012-09-12 14:27:44 UTC
I wonder whether this bug is a duplicate of bug 39791. Reporter wrote: "Unlike OO, Libre Office took over many of the MS Office file types." But we do not know what file types were that exactly. Maybe only .rtf and .doc?
Comment 4 adilecu 2012-11-19 21:54:48 UTC
It hijacks all the extensions, for Word, Excel and Powerpoint. Please solve. I try to keep software updated in a computer lab, every time I upgrade LibreOffice (I cannot run custom update, the update is done in batch for a bunch of programs) it hijacks all the MS Office extensions, I have to go on and either repair MS Office or associate all the extensions back with MS Office.
Comment 5 adilecu 2012-11-20 14:46:39 UTC
I have to revise my previous statement, it looks (latest version anyway) like it hijacks only .docx
Comment 6 Timur 2013-03-05 09:44:39 UTC
This is rather old and marked for 3.5.x. This is likely a duplicate of Bug 39791 but anyway it works fine with LO 3.6, although there are some other problems.

*** This bug has been marked as a duplicate of bug 39791 ***