Bug 47614 - Impress Fails to Display Themes and Render Fonts in Slideshow Mode
Summary: Impress Fails to Display Themes and Render Fonts in Slideshow Mode
Status: RESOLVED DUPLICATE of bug 46901
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-20 13:53 UTC by James Carroll
Modified: 2012-03-21 08:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A quick screenshot of a slide in both design and slideshow mode next to each other, slideshow mode however has been cropped to save disk space. (it was all just blank anyway) (138.36 KB, image/gif)
2012-03-20 13:53 UTC, James Carroll
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James Carroll 2012-03-20 13:53:34 UTC
Created attachment 58783 [details]
A quick screenshot of a slide in both design and slideshow mode next to each other, slideshow mode however has been cropped to save disk space. (it was all just blank anyway)

In short, although LibreOffice correctly stores themes in the contents of the file, when displaying the exact same file in SlideShow mode, all colours and fonts are removed. Despite this, transitions and custom animation effects still work as intended, and if the file is exported (for example, as html) it gets generated correctly with fonts and colours intact. It's only in the SlideShow mode where any problem is presented.

I've attached a screenshot of an example in both a slide in design mode and the same slide in slideshow mode, the quality is pretty poor but helps to give an idea of the issue.

Reproducing the bug is fairly simple, just create/open a presentation, make sure it uses a theme (I just picked one from the layout menu) and then press f5/navigate to tools -> slideshow and the content does not render properly.

I'm completely new to the bug report method used on this site and I'm sorry if I've missed out any crucial information, or if this is a duplicate report. If any more information is needed about my computer build, feel free to ask.
Comment 1 manj_k 2012-03-21 08:02:49 UTC
Thanks for your report.
There are already two related bug reports:
'Bug 46901 - SLIDESHOW shows characters too slim with Hardware Acceleration activated',
'Bug 46532 - SLIDESHOW does not show pictures with Hardware Acceleration activated'.

*** This bug has been marked as a duplicate of bug 46901 ***