Download it now!
Bug 46532 - SLIDESHOW does not show pictures with Hardware Acceleration activated
Summary: SLIDESHOW does not show pictures with Hardware Acceleration activated
Status: RESOLVED DUPLICATE of bug 46901
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
: 46308 47555 47571 47591 47642 47744 47799 47898 47902 48432 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-02-23 11:20 UTC by tschloesser
Modified: 2012-04-08 00:48 UTC (History)
23 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Kit (165.01 KB, application/zip)
2012-03-02 07:25 UTC, Rainer Bielefeld Retired
Details
PPS showing problem when Hardware Acceleration is enabled (2.80 MB, application/vnd.ms-powerpoint)
2012-03-19 11:18 UTC, M8R-19jnla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tschloesser 2012-02-23 11:20:46 UTC
Problem description: 

When starting a slideshow only the content from the slide master is displayed but not the real slide content.

Steps to reproduce:
1. Open a *.odp file which was created/modified with LibreOffice 3.4.5
2. start the slide show
3. ....

Current behavior:
Only the content of the master slide is displayed

Expected behavior:
The slide should be shown during the slide show the same way as in the editor.
 
Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/534.53.11 (KHTML, like Gecko) Version/5.1.3 Safari/534.53.10

When creating a presentation from scratch in LO 3.5 everything seems to work, but on all my old stuff I can not use LO3.5 :-(

Just for Refference I attach an sample file
Comment 1 Rainer Bielefeld Retired 2012-03-02 06:48:50 UTC
[Reproducible] with "LibreOffice 3.5.1.1 German UI/Locale [Build-ID: 45a2874-aa8c38d-dff3b9c-def3dbd-62463c8] on German WIN7 Home Premium (64bit) 

@tschloesser@maintainet.de
Please attach the promised sample document. If it's not for public use you can send it to me by mail. I currently only have very large presentations with lots of linked pitures available.

What's the difference to your "Bug 46395 - SLIDESHOW: Presentation shows only "empty" master slides"?
Comment 2 Rainer Bielefeld Retired 2012-03-02 07:25:55 UTC
Created attachment 57920 [details]
Test Kit

Was ok for me with old Master versions (if they did not crash) and RC until 3.5.0 RC2
Deleting user profile will not heal the problem

Attached Test Kit contains a sample document  (created with 3.4.5 from editing an older presentation) demonstrating the problem, pictures will not be shown
Comment 3 Rainer Bielefeld Retired 2012-03-02 07:29:18 UTC
Switching off Hardware Acceleration heals at least my problem.

Not a blocker because of that workaround, but definitively critical.
Comment 4 Thorsten Behrens (CIB) 2012-03-02 08:41:59 UTC
(In reply to comment #3)
> Switching off Hardware Acceleration heals at least my problem.
> 
Hmm, don't see that on Linux - appears to be Windows-only. Or can you attach a sample preso?
Comment 5 Thorsten Behrens (CIB) 2012-03-02 08:45:37 UTC
(In reply to comment #4)
> Hmm, don't see that on Linux - appears to be Windows-only. Or can you attach a
> sample preso?
>
I mean, a sample preso that shows the bug also on Linux :)
Comment 6 Rainer Bielefeld Retired 2012-03-02 08:46:58 UTC
This problem is not limited to old documents, I can reproduce it with a presentation created from the scratch with 3.5.1RC1

@tschloesser@maintainet.de
If I occupied your Bug for a problem only similar, but not identical with your one please submit a new Bug.

@Thorsten:
no linux here - sigh
Comment 7 Rainer Bielefeld Retired 2012-03-02 10:36:32 UTC
*** Bug 46308 has been marked as a duplicate of this bug. ***
Comment 8 Cor Nouws 2012-03-02 15:30:28 UTC
I cannot reproduce the problem on 3.5.1rc1 on Ubuntu and also not on 3.5.0 on Win7 Virtual Box.

The sample.odp from Rainer contains to links to graphics for slides 2 and 3.
Comment 9 sasha.libreoffice 2012-03-02 22:28:52 UTC
reproduced with attachment in 3.5.0 on Fedora 64 bit KDE
For reproduce this:
1. open presentation and press F5, pay attention how animation effect behaves
2. find
Tools->Option, LibreOffice->View->Use Hardware acceleration
 and remove check mark from there
3. repeat step 1
Expected: the same behaviour
Actually: remarkable different
I have reproduced disappearing of content of presentation only once, then it becomes not reproducible
IMHO problem with animation (may be animation or skip or not played until end)
Comment 10 Cor Nouws 2012-03-03 01:48:08 UTC
Hi Sasha,

(In reply to comment #9)
> reproduced with attachment in 3.5.0 on Fedora 64 bit KDE

No you did not. The issue is about graphics not being shown.
And you write about the animation effect:

> 1. open presentation and press F5, pay attention how animation effect behaves
Comment 11 Cor Nouws 2012-03-03 01:49:49 UTC
(In reply to comment #8)

> The sample.odp from Rainer contains to links to graphics for slides 2 and 3.

And to be cristal clear: the pictures are shown for me, both on Win7 and Ubuntu
Comment 12 Rainer Bielefeld Retired 2012-03-03 02:23:57 UTC
Cor's comment meets the point: If pictures are missing during slide show you reproduced the bug, if the pictures are visible you did not reproduce the problem. 

I can reproduce the problem with LibO 3.5.0 German on German WIN XP 32bit on VirtualBox
Comment 13 Rainer Bielefeld Retired 2012-03-03 02:26:50 UTC
I'm Sorry, confusion with my versions, I can reproduce the problem with LibO 3.5.1.1. German on German WIN XP 32bit on VirtualBox. 3.5.0 not tested.
Comment 14 Cor Nouws 2012-03-03 04:03:07 UTC
Installed 3.5.1.1 in Win7.

Tested sample.odp.
Pictures are indeed not shown when hardware accelleration is on.

For my own convenience I added a shape with the number of the slide on some pages ;-) 
Simple blue with a white number.
With hardware accelleration on, the blue background was not shown, only the number.
Comment 15 pierre-yves samyn 2012-03-10 08:31:52 UTC
Hi

Reproduced (fr-discuss) with :

LibO 3.5.1.2 Build ID: dc9775d-05ecbee-0851ad3-1586698-727bf66
> Windows 7 64 bits 
> Windows 7 SP1 32 bits

Not Reproduced (fr-discuss) with :

Ubuntu LibO 3.5.0
Mac OS 10.6.8
> LibreOffice 3.4.5 
> LibreOffice 3.5.0rc3 Version ID : 7e68ba2-a744ebf-1f241b7-c506db1-7d53735 

Regards
Pierre-Yves
Comment 16 Jean-Baptiste Faure 2012-03-11 14:48:35 UTC
Not reproduced for me with LO 3.5.1 rc2 and LO 3.5.2 rc0+ under Ubuntu 11.10 x86_64

Best regards. JBF
Comment 17 Corey Bodendein 2012-03-15 16:11:49 UTC
Here is a link to another example of a .ppt created by LibreOffice 3.5.0: https://skydrive.live.com/redir.aspx?cid=3040498ea73fc5f8&resid=3040498EA73FC5F8!167&parid=3040498EA73FC5F8!128&authkey=!AFRXfCl5BVPMD6U .  You will notice when you open the presentation, the image doesn't appear at first, but is in the slide sorter. You can work around this by choosing a different slide in the slide sorter, than switching back, and them image will appear. (I don't know if that is a separate issue and this happens whether or not hardware acceleration is enabled.)

Also, if you start a slideshow, the background image won't show up, the image on the first slide won't show up, and it won't show the contents of the other slides. On my machine, disabling hardware acceleration fixes these issues.  I am on a Dell Dimension 2400 with a NVIDIA GeForce 8400 GS 512MB graphics card, now running LibreOffice 3.5.1 on Windows 7 32-bit.
Comment 18 M8R-19jnla 2012-03-19 11:16:18 UTC
Using LO 3.5.1 release on Win7 x64 SP1 with NVIDIA GeForce GTS 250M graphics card, I see the complete slides (including picture) with Hardware Acceleration disabled, and I see black or white background with just the text (no picture) with Hardware Acceleration enabled.

I see the white background with a .PPTX from my company (which is company secret).  I see the black background with the attached preikestolen_en.pps file.
Comment 19 M8R-19jnla 2012-03-19 11:18:27 UTC
Created attachment 58699 [details]
PPS showing problem when Hardware Acceleration is enabled
Comment 20 vitriol 2012-03-20 02:22:53 UTC
*** Bug 47555 has been marked as a duplicate of this bug. ***
Comment 21 vitriol 2012-03-20 08:58:10 UTC
*** Bug 47571 has been marked as a duplicate of this bug. ***
Comment 22 vitriol 2012-03-21 05:01:09 UTC
*** Bug 47642 has been marked as a duplicate of this bug. ***
Comment 23 manj_k 2012-03-21 15:38:43 UTC
*** Bug 47591 has been marked as a duplicate of this bug. ***
Comment 24 vitriol 2012-03-22 23:59:10 UTC
*** Bug 47744 has been marked as a duplicate of this bug. ***
Comment 25 Kevin Luxford 2012-03-23 00:02:58 UTC
I have yemporarily solved the problem by uninstalling 3.5.1 and
re-installing 3.5.0

Kevin

On Fri, Mar 23, 2012, at 06:59 AM, bugzilla-daemon@freedesktop.org
wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=46532
> 
> vitriol <vitriol_vitriol@katamail.com> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                  CC|                            |kbgluxford@fastmail.fm
> 
> --- Comment #24 from vitriol <vitriol_vitriol@katamail.com> 2012-03-22
> 23:59:10 PDT ---
> *** Bug 47744 has been marked as a duplicate of this bug. ***
> 
> -- 
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
Comment 26 sasha.libreoffice 2012-03-23 23:12:44 UTC
Another story about Hardware acceleration, this time Linux specific:
Bug 45269 - Presentation does not Look the same on Linux and Windows
Comment 27 Cheng-Chia Tseng 2012-03-24 04:34:30 UTC
This is the Linux related bug I have filed [0], people having interest on it can have a look. 

I suggest that these issues can be seem as a whole. It is good to fix them at once.


0. https://bugs.freedesktop.org/show_bug.cgi?id=47719
Comment 28 manj_k 2012-03-24 06:51:32 UTC
*** Bug 47799 has been marked as a duplicate of this bug. ***
Comment 29 M8R-19jnla 2012-03-26 07:10:17 UTC
I reproduced this bug using LO 3.5.1 on Win7 x32 SP1 with an ATI Mobility Radeon HD 5730 graphics card.

The bug is not specific to one graphics card manufacturer since it was reproduced using both ATI and NVIDIA graphics cards.
Comment 30 richard_g 2012-03-26 07:24:38 UTC
Answer to Comment 29 "The bug is not specific to one graphics card manufacturer":

Also it is not specifc to old versions of the graphic card driver. Updating my NVIDIA driver from the old 176.26 to the last 296.10 WHQL does not solve the problem.
Comment 31 vitriol 2012-03-26 07:25:52 UTC
*** Bug 47898 has been marked as a duplicate of this bug. ***
Comment 32 vitriol 2012-03-26 07:48:54 UTC
*** Bug 47902 has been marked as a duplicate of this bug. ***
Comment 33 Only A Test Account, do not aadd to CC! 2012-03-26 09:11:03 UTC
<http://wiki.documentfoundation.org/BugReport_Details#Version>
Comment 34 Michael Meeks 2012-03-29 03:19:51 UTC
Thanks for the report, this is a dup of 46901 at root - and should be fixed in a new build for 3.5.2 after rc2 that Fridrich is just working on.

Thanks!

*** This bug has been marked as a duplicate of bug 46901 ***
Comment 35 vitriol 2012-04-08 00:48:55 UTC
*** Bug 48432 has been marked as a duplicate of this bug. ***