Bug Hunting Session
Bug 47805 - 64-bit shell extensions are not registered
Summary: 64-bit shell extensions are not registered
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: Other Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:3.6.0.0.beta1 target:3.6.0 tar...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-24 08:41 UTC by Andras Timar
Modified: 2012-08-03 09:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2012-03-24 08:41:27 UTC
Although the wrong registry entries are fixed in 3.5.1, the shell extensions
are still not enabled after a clean installation of LibreOffice 3.5.1 in
Windows x64. 

Procedure:
In a clean Windows 7 x64 system you install LibreOffice 3.5.1. After
installation, libreoffice document properties and images are not shown in
windows explorer.

Manually registering the following dlls (win admin rights) solves the problem:
regsvr32 "C:\Program Files (x86)\LibreOffice
3.5\program\shlxthdl\ooofilt_x64.dll"
regsvr32 "C:\Program Files (x86)\LibreOffice
3.5\program\shlxthdl\shlxthdl_x64.dll"
Comment 1 Michail Pappas 2012-05-03 22:25:14 UTC
(In reply to comment #0)
> Although the wrong registry entries are fixed in 3.5.1, the shell extensions
> are still not enabled after a clean installation of LibreOffice 3.5.1 in
> Windows x64. 
> 
> Procedure:
> In a clean Windows 7 x64 system you install LibreOffice 3.5.1. After
> installation, libreoffice document properties and images are not shown in
> windows explorer.

I can confirm this behaviour on 64-bit systems. Will try the workaround when I get back at home, thanks for sharing!
Comment 2 Michail Pappas 2012-05-04 06:25:48 UTC
Andras, I thought that the issue I was experiencing was similar to yours, but it seems that this might not be the case. Let me explain please:

I have a 64-bit windows 7 box, on which I just installed 3.5.3. In 32-bit Windows 7, under Control Panel -> Indexing Options -> Advanced -> File Types one can see that C:\Program Files (x86)\LibreOffice 3.5\program\shlxthdl\ooofilt.dll is associated for LibO files. 

On my own 64-bit system, "No registered IFilter was found" is displayed. I have tried your regsvr commands, thinking that they will solve this issue, but after a reboot I still see the same message there...

Do you believe a new bug report should be opened for it?
Comment 3 Andras Timar 2012-06-02 13:58:52 UTC
Reg64 custom actions do not run because lack of elevated privileges. The whole installer logic was developed with Windows XP in mind.
Comment 4 Andras Timar 2012-06-02 14:03:37 UTC
(In reply to comment #2)
> Do you believe a new bug report should be opened for it?

Yes, let's open a new bug for that, it seems to be different. See bug #50623.
Comment 5 Not Assigned 2012-06-05 04:47:23 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6d9be05a6fb251ed0cbcbcefd55ed174b1e8e39d

fdo#47805 rework handling of 64-bit registry entries
Comment 6 Not Assigned 2012-06-05 05:51:19 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9972ab27d4432ba2b5258f58b99abb09d2ff597c&g=libreoffice-3-6

fdo#47805 rework handling of 64-bit registry entries


It will be available in LibreOffice 3.6.0.
Comment 7 Andras Timar 2012-06-05 05:54:59 UTC
So, we got rid of many custom hacks (Reg64 table, and using custom actions to write registry). Hopefully it will work for all.
Comment 8 Not Assigned 2012-06-07 08:51:20 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=51b091da5445b219e04a01950a141c9a64aaf36d&g=libreoffice-3-5

fdo#47805 rework handling of 64-bit registry entries


It will be available in LibreOffice 3.5.5.
Comment 9 Rainer Bielefeld Retired 2012-08-03 09:16:03 UTC
We need exact and correct target information for automated lists in Wiki and LibO Web Site.