Bug Hunting Session
Bug 47995 - font features disabled when using OpenType font -- even when same font in TrueType format works
Summary: font features disabled when using OpenType font -- even when same font in Tru...
Status: RESOLVED DUPLICATE of bug 31821
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 RC1
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-28 03:50 UTC by Steve White
Modified: 2012-08-07 09:18 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Hindi text with OpenType version of Gargi font -- many letters scrunch together (130.15 KB, image/png)
2012-03-28 03:51 UTC, Steve White
Details
Hindi text with TrueType version of Gargi font -- readable (131.03 KB, image/png)
2012-03-28 03:51 UTC, Steve White
Details
Sinhala text with OpenType version of FreeSerif font -- many letters scrunch together (99.98 KB, image/png)
2012-03-28 03:53 UTC, Steve White
Details
Sinhala text with TrueType version of FreeSerif font -- readable (107.33 KB, image/png)
2012-03-28 03:53 UTC, Steve White
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve White 2012-03-28 03:50:18 UTC
OpenType fonts are the trigger for many serious problems in LibreOffice.

Tested this on my distro version 3.4.4, as well as 3.5.2 RC1.  (on two different architectures running Ubuntu 11.10)

The effect is: text in some Indic languages such as Hindi and Sinhala was just mangled, evidently because necessary font features (ligatures, positioning, etc) were not activated.  But then the problem would go away.  And then come back.
But I have been messing with the installed fonts a lot.

The trigger
===========
The problem occurs precisely when OpenType versions of the fonts are installed.  If TrueType versions of the exact same fonts are installed, the text looks fine.

The font features in question are not specific to OpenType.
The type of outline has nothing to do with it.
Comment 1 Steve White 2012-03-28 03:51:15 UTC
Created attachment 59149 [details]
Hindi text with OpenType version of Gargi font -- many letters scrunch together
Comment 2 Steve White 2012-03-28 03:51:56 UTC
Created attachment 59150 [details]
Hindi text with TrueType version of Gargi font -- readable
Comment 3 Steve White 2012-03-28 03:53:07 UTC
Created attachment 59151 [details]
Sinhala text with OpenType version of FreeSerif font -- many letters scrunch together
Comment 4 Steve White 2012-03-28 03:53:41 UTC
Created attachment 59152 [details]
Sinhala text with TrueType version of FreeSerif font -- readable
Comment 5 Steve White 2012-03-28 03:58:35 UTC
Some web searches show a lot of remarks to the effect that LibreOffice/OpenOffice do not support OpenType features.  I suspect these refer to just this bug.

Also see for example
https://bugs.freedesktop.org/show_bug.cgi?id=31821
Bug 31821 - Writer ignores OpenType ligatures.
Comment 6 Steve White 2012-04-02 04:54:12 UTC
I applied Caolán's patch from
https://bugs.freedesktop.org/show_bug.cgi?id=31821

It had a decidedly positive effect.  Most font features are suddenly working in OpenType as well as in TrueType, so he's on the right track.

However this uncovered other issues, which I'll report separately.
Comment 7 leighman 2012-08-06 18:43:27 UTC
Steve White, is this still an issue for you?
It seems from the comment that the immediate issues might have been fixed.
If it is still an issue, could you please upload a sample file that could be used to see the problem.
Comment 8 Caolán McNamara 2012-08-07 09:18:45 UTC
lets consider this mostly a duplicate of bug 31821 and use bug 48191 to try and get an example of the follow up problems

*** This bug has been marked as a duplicate of bug 31821 ***