Bug Hunting Session
Bug 48033 - FILEOPEN : Import RTF file but pictures are not well positioned on table/cells
Summary: FILEOPEN : Import RTF file but pictures are not well positioned on table/cells
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.1 release
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:3.7.0 target:3.6.1 target:3.5.6
Keywords: regression
: 58290 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-03-29 01:53 UTC by Nahir Mohamed
Modified: 2012-12-14 19:55 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
RTF file with pictures troubles (2.15 MB, application/rtf)
2012-03-29 01:53 UTC, Nahir Mohamed
Details
Template used to generate the file (906.59 KB, application/rtf)
2012-03-29 01:54 UTC, Nahir Mohamed
Details
Screenshot of the result in MS Word Viewer 2003 (78.97 KB, image/png)
2012-03-29 01:54 UTC, Nahir Mohamed
Details
Screenshot of the result in Writer 3.5.1 (70.77 KB, image/png)
2012-03-29 01:55 UTC, Nahir Mohamed
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nahir Mohamed 2012-03-29 01:53:50 UTC
Created attachment 59197 [details]
RTF file with pictures troubles

Hi,

I have some RTF files which are not well displayed on Writer.

The cells should contains picture but on Writer the picture are not on the right place.

The file was generated from a template created by MS Word 2000. This template
is filled with data by a homemade application.

I put on attachment the bugged file, screenshots and the template used.

Thanks in advance
Comment 1 Nahir Mohamed 2012-03-29 01:54:19 UTC
Created attachment 59198 [details]
Template used to generate the file
Comment 2 Nahir Mohamed 2012-03-29 01:54:43 UTC
Created attachment 59199 [details]
Screenshot of the result in MS Word Viewer 2003
Comment 3 Nahir Mohamed 2012-03-29 01:55:04 UTC
Created attachment 59200 [details]
Screenshot of the result in Writer 3.5.1
Comment 4 Nahir Mohamed 2012-04-10 01:35:19 UTC
Regression working on 3.3.4
Comment 5 jurgen.depicker 2012-04-16 11:46:19 UTC
We are affected by the same bug.  LibreOffice 3.5.2.2
Comment 6 Jean-Baptiste Faure 2012-05-06 03:35:22 UTC
Reproducible with master (Build ID: f1005e5) and LO 3.5.3.2 under Ubuntu 11.10 x86_64

There is something strange: pictures are inserted as OLE objects. If you look in the Navigator you will see both lists, graphics and OLE objects, which are not empty but with blank names. You can browse through both lists and it seems that each picture appears in both lists.


Best regards. JBF
Comment 7 Marek Jagielski 2012-07-26 15:46:50 UTC
I note that all pictures are always inserted into the first cell of a table.
Comment 8 Miklos Vajna 2012-07-27 20:23:11 UTC
Marek mentioned on IRC this will be probably a problem with table buffering, I'm looking into it.
Comment 9 Not Assigned 2012-07-27 20:29:30 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0705b9f75d31c433b9ff263a0f1af06035664219

fdo#48033 fix RTF import of pictures inside table cells
Comment 10 Miklos Vajna 2012-07-27 20:33:08 UTC
Nahir, thanks for the report, the bad positioning of pictures inside tables is now resolved in master, I'll request cherry-pick to -3-6 and -3-5 soon.
Comment 11 Miklos Vajna 2012-07-27 21:08:49 UTC
Sorry, forgot to mention that both the RTF and the DOCX version of this doc has problems with OLE objects inside tables on import, we should probably deal with it in a separate bug to avoid mixing different issues.

Thanks.
Comment 12 Not Assigned 2012-07-30 15:16:55 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=577f1a54efe800c0e45bb64d78e2d9f6e489c2c6&g=libreoffice-3-6

fdo#48033 fix RTF import of pictures inside table cells


It will be available in LibreOffice 3.6.1.
Comment 13 Marek Jagielski 2012-07-31 10:16:53 UTC
Pictures that are OLE objects are still not palced in good cell. More, they are not well displayed (size is microscopic). Dans la version 3.5.4 these pictures are well displayed.
Comment 14 Not Assigned 2012-07-31 10:53:27 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=32af6dec1b7b80759a793e5f1da0a1129823c51e&g=libreoffice-3-5

fdo#48033 fix RTF import of pictures inside table cells


It will be available in LibreOffice 3.5.6.
Comment 15 z1949 2012-12-14 19:55:30 UTC
*** Bug 58290 has been marked as a duplicate of this bug. ***