Download it now!
Bug 48243 - Some extensions not work after install
Summary: Some extensions not work after install
Status: RESOLVED DUPLICATE of bug 51115
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: David Tardon
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-04-03 05:57 UTC by Korrawit Pruegsanusak
Modified: 2012-06-25 05:19 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of extension manager (38.69 KB, image/png)
2012-04-03 05:58 UTC, Korrawit Pruegsanusak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Korrawit Pruegsanusak 2012-04-03 05:57:28 UTC
Windows Master daily build obtained from http://dev-builds.libreoffice.org/daily/Win-x86@6-fast/master/2012-04-02_22.33.50/
Build ID: 43084e8-6299bf6-879ce3
Windows XP

1. Select "Custom Install"
2. Make sure that all extensions in "Optional Components > Extensions" are enabled
3. Install, then run
4. Tools > Extensions Manager
5. Some extensions are not detected, details as follows

In the installation wizard, we have 5 extensions, default to all checked:
* pdf import
* report builder
* presenter screen
* script provider for python
* presentation minimizer

In the Extensions Manager, only 2 of 5 in the above list are shown: "report builder" and "script provider for python".

The others (not in install wizard list) shown are:
* English spelling dictionaries, hyphenation rules, thesaurus, ... (lightproof)
* French spelling dictionaries, hyphenation rules, and thesaurus
* Spanish spelling dictionaries

So, the extensions installed but *not shown* are:
* pdf import
* presenter screen
* presentation minimizer

Try opening a pdf file -> failed, it shows "ASCII filter options" dialog. So, the extension is not work.

Looking in install-path/share/extensions, there are:
* dict-en
* dict-es
* dict-fr
* package.txt
* pdfimport
* presentation-minimizer
* presenter-screen
* report-builder
* script-provider-for-python
Comment 1 Korrawit Pruegsanusak 2012-04-03 05:58:25 UTC
Created attachment 59420 [details]
screenshot of extension manager
Comment 2 Korrawit Pruegsanusak 2012-04-03 06:01:49 UTC
Copy from the build info at http://dev-builds.libreoffice.org/daily/Win-x86@6-fast/master/2012-04-02_22.33.50/master~2012-04-02_22.33.50_build_info.txt

==>8==
checking whether to build the Presentation Minimizer extension... yes
checking whether to build the Presenter Console extension... yes
checking whether to build the PDF Import extension... yes
checking which pdf backend to use... internal
checking for sdext module... checking whether to build the Wiki Publisher extension... no
checking whether to build the Report Builder extension... yes
checking for reportbuilder module... checking which jfreereport libs to use... internal
checking for jfreereport module... checking which Apache commons-* libs to use... internal
checking whether to build extension for support of scripts in BeanShell... no
checking whether to build extension for support of scripts in JavaScript... no
checking whether to enable the lockdown pieces... no
checking whether to enable evolution 2 support... no
checking whether to enable KDE address book support... no
checking whether to include MathMLDTD... no
checking which themes to include...  default crystal hicontrast oxygen tango
checking for helppack integration... integration
checking for extensions integration... yes, use integration
==>8==

So, the extensions are built, but somehow not detected.
Comment 3 Korrawit Pruegsanusak 2012-04-03 06:14:11 UTC
Another check from http://dev-www.libreoffice.org/l10n/am/LibO-Dev_3.6.0alpha0_Win_x86_install_en-US_am.msi

Extensions in installation wizard are:
* Solver for nonlinear programming
* MediaWiki Publisher
* Report Builder
* Presenter Screen
* Script provider for python
* Presentation minimizer

Extensions in Extensions Manager:
* English spelling dictionaries, hyphenation rules, thesaurus, ... (lightproof)
* French spelling dictionaries, hyphenation rules, and thesaurus
* Report Builder
* Script provider for python
* Solver for nonlinear programming
* Spanish spelling dictionaries
* Wiki Publisher

So, extensions that installed but *not shown* are:
* Presenter Screen
* Presentation minimizer

In install-path/share/extensions/:
* dict-en
* dict-es
* dict-fr
* nlpsolver
* package.txt
* presentation-minimizer
* presenter-screen
* report-builder
* script-provider-for-python
* wiki-publisher
Comment 4 Korrawit Pruegsanusak 2012-04-03 06:45:30 UTC
[NOT REPRODUCIBLE] LibreOffice 3.5.2 RC1 official build on Windows XP.

The 3 extensions:
* pdf import
* presenter screen
* presentation minimizer
are shown in Extension Manager.

And PDF import works => regression

Just notice that all three not-work extensions are in sdext/ ...
Comment 5 David Tardon 2012-04-15 22:06:36 UTC
This is somewhat better on linux: pdfimport and presenter console are fine (and working), just presentation minimizer shows with error status.
Comment 6 Cor Nouws 2012-05-02 05:28:52 UTC
In version 3.6.0alpha0+ Build ID: 87897ea 
on Ubuntu 32 bits, also the presentation minimizer is without error
Comment 7 Matúš Kukan 2012-05-19 13:52:49 UTC
Not reproducible in current master. I think since
http://cgit.freedesktop.org/libreoffice/core/commit/?id=f5ea2b5fa85660844daf092e84db45a759bf126d
Comment 8 Korrawit Pruegsanusak 2012-05-19 22:23:13 UTC
Thanks Matus, but it's partially.

On Windows XP, with Administrative install (msiexec /a) of build:
tinderbox: W2008R2@16-minimal_build
pull time: 2012-05-18 00:57:37
git core: 3da4ab93e14bbe472ac0a6bce52616a93a2506d2

Extension Manager correctly *show* installed sdext extensions, but pdfimport still *not* working.

When open attachment 56825 [details],
Actual: show "ASCII filter dialog", and open pdf internal content in Writer
Expected: not show "ASCII filter dialog", and open pdf in Draw
Comment 9 Korrawit Pruegsanusak 2012-05-19 23:07:23 UTC
(In reply to comment #8)
> On Windows XP, with Administrative install (msiexec /a) of build:

Also REPRODUCIBLE (still have problem) with normal install of same build (by double-click the installer, and following the wizard) on Windows XP.
Comment 10 Julien Nabet 2012-06-09 12:52:45 UTC
Just for information, on pc Debian x86-64 with master sources (updated today) or 3.5 branch (updated yesterday), with a brand new LO profile each time, the extensions work except barcode.
Opening a simple pdf works too for both of them.
Comment 11 Michael Meeks 2012-06-25 04:37:52 UTC
Looks like a duplicate of bug#51115 - which now has a fix from mst :-)
Comment 12 David Tardon 2012-06-25 05:19:09 UTC
righteo

*** This bug has been marked as a duplicate of bug 51115 ***