Download it now!
Bug 51115 - [FILEOPEN] PDF is not opened in draw, but as text file
Summary: [FILEOPEN] PDF is not opened in draw, but as text file
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta1
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:3.7.0 target:3.6.0.0.beta3
Keywords: regression
: 48243 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-06-15 04:23 UTC by Winfried Donkers
Modified: 2012-07-10 11:19 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Winfried Donkers 2012-06-15 04:23:02 UTC
process to reproduce problem:
-start LibO
-choose 'open file' and select a PDF file
-a text file import dialog appears where column delimiters and language settings can be set

expected behaviour for step 3 is that draw opens the PDF file.

problem does not occur with LibO 3.5.4
Comment 1 Rainer Bielefeld Retired 2012-06-15 09:38:43 UTC
More or less [Reproducible] with Server Installation of  "LibreOffice 3.6.0beta1  German UI/Locale [Build-ID: 1f1cdd8] on German WIN7 Home Premium (64bit). The 1 PDF I tested directly opened from LibO File menu was opened in WRITER without an import dialog appearing. Extension Manager Shows PDF import 1.0.6 available, but it does not work.

@Michael:
Looks similar to "Bug 43707 - FILEOPEN PDF brings up (ASCII) filter selector instead of opening document". Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug.
Comment 2 Michael Meeks 2012-06-15 10:21:14 UTC
Another packaging / component association problem ?
Comment 3 m.a.riosv 2012-06-17 15:12:11 UTC
Win7x64 Ultimate

Reproducible:
3.6.0.beta1 (Build ID: 1f1cdd8)

Not reproducible:
3.5.5.1
Comment 4 Michael Meeks 2012-06-22 14:19:32 UTC
Works for me with a build of master on Linux; Winfried - can you confirm that you have a:

/share/extensions/pdfimport/pdfimport.uno.dll

type file lying around somewhere :-) as well as an 'xpdfimport' binary ? perhaps it's a simple packaging problem.
Comment 5 Winfried Donkers 2012-06-25 01:26:06 UTC
(In reply to comment #4)

reproducible on 3.6.0.0beta2, Windows XP

The installed Lodev3.6 does _not_ have a /share/extensions/pdfimport/pdfimport.uno.dll, it doesn't have a pdfimport* at all (apart from directory share/extensions/pdfimport)

There is an 'xpdfimport' binary: share/extensions/pdfimport/xpdfimport.exe

(in windows itself, '\' should be used for '/')
Comment 6 Michael Stahl (CIB) 2012-06-25 02:52:01 UTC
ah i think i know why that is, let me guess Winfried that you have
some *pdfimport*.lib file somewhere in your installation,
which is because the makefile that builds the extension uses
the wrong gbuild function and bundles the link stub static library
as opposed to the DLL.
Comment 7 Michael Stahl (CIB) 2012-06-25 03:53:41 UTC
it seems the missing DLL problem affects not just PDF Import
but also Presentation Minimizer and Presenter Console.

if that is indeed the problem it should be fixed on master now.

please somebody test if all these work on Windows when built with the fix.
Comment 8 Not Assigned 2012-06-25 03:54:08 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f0de66d9a541505e14261ffac08e021bce6b67ba

fdo#51115: fix sdext extensions on Windows:
Comment 9 Not Assigned 2012-06-25 04:53:03 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cf6d37a8f4e45fc29e4b156acb098268048af6f6&g=libreoffice-3-6

fdo#51115: fix sdext extensions on Windows:


It will be available in LibreOffice 3.6.
Comment 10 Winfried Donkers 2012-06-25 05:04:29 UTC
(In reply to comment #6)
Yes, there is a /share/extensions/pdfimport/ipdfimport.lib in the lodev3.6 directory of 3.6.0.0beta2
I haven't the opportunity now to test, perhaps later
Comment 11 David Tardon 2012-06-25 05:19:09 UTC
*** Bug 48243 has been marked as a duplicate of this bug. ***
Comment 12 Not Assigned 2012-06-26 03:10:03 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e818f8fa1f79c2eb2d647678333b8d12599dda69

fdo#51115: gb_Extension_add_file: fix Windows build:
Comment 13 Not Assigned 2012-06-26 03:23:15 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1d179e2ccfd93c711386007e24828959d38c9c22&g=libreoffice-3-6

fdo#51115: gb_Extension_add_file: fix Windows build:


It will be available in LibreOffice 3.6.
Comment 14 Korrawit Pruegsanusak 2012-06-30 22:18:15 UTC
(In reply to comment #7)
> please somebody test if all these work on Windows when built with the fix.

VERIFIED the fix in both Windows XP and Windows 7 with following builds:

1) tinderbox Win-x86_9-Voreppe
branch libreoffice-3-6
pull time 2012-06-28 19:36:32
core:55d095a3122f68ebf97fd9b2567173c7fb648761
binfilter:8dcb94c6fcb2613834a91762aacdb07d4096a537
dictionaries:b385f067cc80957128b5fe7aefc360227e70bc28
help:dd3b86787d441b8b84e89cb25c61170ec8cf121d
translations:e606ec2e4a8b7cfff433a15f85a4d0f7e47df1e2

2) tinderbox W2008R2@16-minimal_build
branch MASTER
pull time 2012-06-27 04:02:20
core:3f135598fd508e70f31f36cd8a8d7a61ccf4ff79

PDF file now open in Draw. Thanks mst! :-)
Comment 15 Winfried Donkers 2012-07-10 11:19:33 UTC
VERIFIED the fix in both Windows XP with 3.6.0Beta3: all works fine. Thank you very much!